summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-10-29 18:30:13 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-10-29 18:30:13 +0000
commit3a9d99b2f8a0577e2074c54b521117a2992f3845 (patch)
tree2fb7b3a213a6a6082e2eb134f3fe7033e92fc1d6 /x11-libs/qt-xmlpatterns
parentProxy commit for chiiph, add him and myself to metadata.xml (diff)
downloadgentoo-2-3a9d99b2f8a0577e2074c54b521117a2992f3845.tar.gz
gentoo-2-3a9d99b2f8a0577e2074c54b521117a2992f3845.tar.bz2
gentoo-2-3a9d99b2f8a0577e2074c54b521117a2992f3845.zip
Adding a patch to fix regression in event loop
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-xmlpatterns')
-rw-r--r--x11-libs/qt-xmlpatterns/ChangeLog8
-rw-r--r--x11-libs/qt-xmlpatterns/files/qt-4.5.3-glib-event-loop.patch11
-rw-r--r--x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild35
3 files changed, 53 insertions, 1 deletions
diff --git a/x11-libs/qt-xmlpatterns/ChangeLog b/x11-libs/qt-xmlpatterns/ChangeLog
index 053e1ca2fcc1..7c65af39bc76 100644
--- a/x11-libs/qt-xmlpatterns/ChangeLog
+++ b/x11-libs/qt-xmlpatterns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-xmlpatterns
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/ChangeLog,v 1.42 2009/10/29 11:29:08 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/ChangeLog,v 1.43 2009/10/29 18:30:13 ayoy Exp $
+
+*qt-xmlpatterns-4.5.3-r1 (29 Oct 2009)
+
+ 29 Oct 2009; Dominik Kapusta <ayoy@gentoo.org>
+ +qt-xmlpatterns-4.5.3-r1.ebuild, +files/qt-4.5.3-glib-event-loop.patch:
+ Adding a patch to fix regression in event loop
29 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
qt-xmlpatterns-4.5.3.ebuild:
diff --git a/x11-libs/qt-xmlpatterns/files/qt-4.5.3-glib-event-loop.patch b/x11-libs/qt-xmlpatterns/files/qt-4.5.3-glib-event-loop.patch
new file mode 100644
index 000000000000..580f027a5471
--- /dev/null
+++ b/x11-libs/qt-xmlpatterns/files/qt-4.5.3-glib-event-loop.patch
@@ -0,0 +1,11 @@
+diff -up qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp
+--- qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than 2009-10-29 16:15:58.000000000 +0100
++++ qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp 2009-10-29 16:16:22.000000000 +0100
+@@ -263,7 +263,6 @@ QEventDispatcherGlibPrivate::QEventDispa
+ (void) new (&timerSource->timerList) QTimerInfoList();
+ timerSource->processEventsFlags = QEventLoop::AllEvents;
+ g_source_set_can_recurse(&timerSource->source, true);
+- g_source_set_priority(&timerSource->source, G_PRIORITY_DEFAULT_IDLE);
+ g_source_attach(&timerSource->source, mainContext);
+ }
+
diff --git a/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild b/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild
new file mode 100644
index 000000000000..feac4f6924aa
--- /dev/null
+++ b/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild,v 1.1 2009/10/29 18:30:13 ayoy Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The patternist module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/xmlpatterns tools/xmlpatterns"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtCore
+include/QtNetwork
+include/QtXmlPatterns
+src/network/
+src/corelib/"
+
+QCONFIG_ADD="xmlpatterns"
+QCONFIG_DEFINE="QT_XMLPATTERNS"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.5-nolibx11.diff"
+ "${FILESDIR}/qt-${PV}-glib-event-loop.patch"
+)
+
+src_configure() {
+ myconf="${myconf} -xmlpatterns"
+ qt4-build_src_configure
+}