summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-02 20:25:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-02 20:25:45 +0000
commitfaea6a3b2036f0f5872fd2f285073ecb8948d399 (patch)
treeb18c4a79417456d6afc5a3107a0938059caebfac /x11-libs/gtkmathview
parentgpsd bump (diff)
downloadgentoo-2-faea6a3b2036f0f5872fd2f285073ecb8948d399.tar.gz
gentoo-2-faea6a3b2036f0f5872fd2f285073ecb8948d399.tar.bz2
gentoo-2-faea6a3b2036f0f5872fd2f285073ecb8948d399.zip
bump to 0.8.0. Add fixes for gcc 4.3, bug #215965, clean up style and logic.
(Portage version: 2.1.5.2)
Diffstat (limited to 'x11-libs/gtkmathview')
-rw-r--r--x11-libs/gtkmathview/ChangeLog11
-rw-r--r--x11-libs/gtkmathview/files/gtkmathview-0.8.0-gcc43.patch45
-rw-r--r--x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild59
3 files changed, 113 insertions, 2 deletions
diff --git a/x11-libs/gtkmathview/ChangeLog b/x11-libs/gtkmathview/ChangeLog
index 0485027c5310..2e6732680e2a 100644
--- a/x11-libs/gtkmathview/ChangeLog
+++ b/x11-libs/gtkmathview/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtkmathview
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/ChangeLog,v 1.22 2006/12/07 19:39:43 mr_bones_ Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/ChangeLog,v 1.23 2008/06/02 20:25:45 eva Exp $
+
+*gtkmathview-0.8.0 (02 Jun 2008)
+
+ 02 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gtkmathview-0.8.0-gcc43.patch, +gtkmathview-0.8.0.ebuild:
+ bump to 0.8.0. Add fixes for gcc 4.3, bug #215965, clean up style and
+ logic.
07 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org>
-gtkmathview-0.5.1.ebuild, -gtkmathview-0.5.2.ebuild,
diff --git a/x11-libs/gtkmathview/files/gtkmathview-0.8.0-gcc43.patch b/x11-libs/gtkmathview/files/gtkmathview-0.8.0-gcc43.patch
new file mode 100644
index 000000000000..10313b4e8120
--- /dev/null
+++ b/x11-libs/gtkmathview/files/gtkmathview-0.8.0-gcc43.patch
@@ -0,0 +1,45 @@
+diff -urN gtkmathview-0.8.0-orig/mathmlps/main.cc gtkmathview-0.8.0/mathmlps/main.cc
+--- gtkmathview-0.8.0-orig/mathmlps/main.cc 2008-04-03 22:43:06.000000000 +0400
++++ gtkmathview-0.8.0/mathmlps/main.cc 2008-04-03 23:53:16.000000000 +0400
+@@ -20,6 +20,7 @@
+
+ #include <cassert>
+ #include <fstream>
++#include <cstring>
+
+ #include <popt.h>
+
+diff -urN gtkmathview-0.8.0-orig/mathmlsvg/main.cc gtkmathview-0.8.0/mathmlsvg/main.cc
+--- gtkmathview-0.8.0-orig/mathmlsvg/main.cc 2008-04-03 22:43:05.000000000 +0400
++++ gtkmathview-0.8.0/mathmlsvg/main.cc 2008-04-03 23:43:31.000000000 +0400
+@@ -20,6 +20,7 @@
+
+ #include <cassert>
+ #include <fstream>
++#include <cstring>
+
+ #include <popt.h>
+
+diff -urN gtkmathview-0.8.0-orig/mathmlsvg/SMS.cc gtkmathview-0.8.0/mathmlsvg/SMS.cc
+--- gtkmathview-0.8.0-orig/mathmlsvg/SMS.cc 2008-04-03 22:43:05.000000000 +0400
++++ gtkmathview-0.8.0/mathmlsvg/SMS.cc 2008-04-03 23:25:12.000000000 +0400
+@@ -19,6 +19,7 @@
+ #include <config.h>
+
+ #include <sstream>
++#include <cstring>
+ #include "defs.h"
+ #include "AbstractLogger.hh"
+ #include "ValueConversion.hh"
+diff -urN gtkmathview-0.8.0-orig/src/engine/mathml/mathVariantAux.cc gtkmathview-0.8.0/src/engine/mathml/mathVariantAux.cc
+--- gtkmathview-0.8.0-orig/src/engine/mathml/mathVariantAux.cc 2008-04-03 22:43:05.000000000 +0400
++++ gtkmathview-0.8.0/src/engine/mathml/mathVariantAux.cc 2008-04-03 23:10:05.000000000 +0400
+@@ -20,6 +20,8 @@
+
+ #include <cassert>
+
++#include <cstring>
++
+ #include "mathVariantAux.hh"
+
+ static MathVariantAttributes vattr[] = {
diff --git a/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild b/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
new file mode 100644
index 000000000000..ffc0d9208e4c
--- /dev/null
+++ b/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild,v 1.1 2008/06/02 20:25:45 eva Exp $
+
+inherit eutils
+
+DESCRIPTION="Rendering engine for MathML documents"
+HOMEPAGE="http://helm.cs.unibo.it/mml-widget/"
+SRC_URI="http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz"
+
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk svg t1lib"
+
+RDEPEND=">=dev-libs/glib-2.2.1
+ >=dev-libs/popt-1.7
+ >=dev-libs/libxml2-2.6.7
+ gtk? (
+ >=x11-libs/gtk+-2.2.1
+ >=media-libs/t1lib-5
+ >=dev-libs/gmetadom-0.1.8
+ x11-libs/pango
+ )
+ t1lib? ( >=media-libs/t1lib-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
+src_compile() {
+ # --disable-popt will build only the library and not the frontend
+ # TFM is needed for SVG, default value is 2
+ econf $(use_enable debug) \
+ $(use_enable gtk) $(use_enable gtk gmetadom) \
+ $(use_enable svg) \
+ $(use_with t1lib) \
+ --enable-popt \
+ --enable-libxml2 \
+ --enable-libxml2-reader \
+ --enable-ps \
+ --enable-tfm=2 \
+ --enable-builder-cache \
+ --enable-breaks \
+ --enable-boxml \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc ANNOUNCEMENT AUTHORS BUGS CONTRIBUTORS ChangeLog HISTORY NEWS TODO
+}