summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-12-28 16:42:59 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-12-28 16:42:59 +0000
commitf08fa9e56e06826057962fdf909cc5100a55e6bb (patch)
treec103047ea1b0816b14051987cb6ee6d0aab9f6c5 /www-apache/mod_auth_nufw
parentLock the target. Bait the line. Grab the net. Catch the man. 2.4.2 is stable ... (diff)
downloadgentoo-2-f08fa9e56e06826057962fdf909cc5100a55e6bb.tar.gz
gentoo-2-f08fa9e56e06826057962fdf909cc5100a55e6bb.tar.bz2
gentoo-2-f08fa9e56e06826057962fdf909cc5100a55e6bb.zip
use apr-1 instead of apr-0
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'www-apache/mod_auth_nufw')
-rw-r--r--www-apache/mod_auth_nufw/ChangeLog6
-rw-r--r--www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild17
2 files changed, 12 insertions, 11 deletions
diff --git a/www-apache/mod_auth_nufw/ChangeLog b/www-apache/mod_auth_nufw/ChangeLog
index 948433a25828..b042f77691ed 100644
--- a/www-apache/mod_auth_nufw/ChangeLog
+++ b/www-apache/mod_auth_nufw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_auth_nufw
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/ChangeLog,v 1.3 2007/09/21 21:07:07 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/ChangeLog,v 1.4 2007/12/28 16:42:59 hollow Exp $
+
+ 28 Dec 2007; Benedikt Böhm <hollow@gentoo.org>
+ mod_auth_nufw-2.2.0.ebuild:
+ use apr-1 instead of apr-0
21 Sep 2007; Benedikt Böhm <hollow@gentoo.org>
mod_auth_nufw-2.2.0.ebuild:
diff --git a/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild
index d2a811171bef..c8272216618f 100644
--- a/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild
+++ b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild,v 1.2 2007/09/21 21:07:07 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.0.ebuild,v 1.3 2007/12/28 16:42:59 hollow Exp $
inherit eutils apache-module autotools
DESCRIPTION="A NuFW authentication module for Apache."
-HOMEPAGE="http://www.inl.fr/mod-auth-nufw.html"
+HOMEPAGE="http://software.inl.fr/trac/wiki/EdenWall/mod_auth_nufw"
SRC_URI="http://software.inl.fr/releases/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -13,8 +13,7 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="ldap mysql postgres"
-DEPEND="=dev-libs/apr-0*
- ldap? ( net-nds/openldap )
+DEPEND="ldap? ( net-nds/openldap )
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql )"
RDEPEND="${DEPEND}"
@@ -25,7 +24,7 @@ APACHE2_MOD_DEFINE="AUTH_NUFW"
DOCFILES="doc/mod_auth_nufw.html"
-need_apache
+need_apache2_2
pkg_setup() {
local cnt=0
@@ -49,13 +48,11 @@ src_unpack() {
}
src_compile() {
- cd "${S}"
-
- econf --with-apache20 \
+ CPPFLAGS="-I$(/usr/bin/apr-1-config --includedir) ${CPPFLAGS}" \
+ econf --with-apache22 \
+ --with-apxs=${APXS2} \
$(use_with ldap ldap-uids) \
$(use_with mysql) \
- --with-apxs=${APXS2} \
- CPPFLAGS="-I$($(apr_config) --includedir) ${CPPFLAGS}" \
|| die "econf failed"
emake || die "emake failed"
}