summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-31 16:04:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-31 16:04:05 +0000
commit4898755cb443935b332c3adfe93f2587c1f5c7f5 (patch)
tree4b66335767fc54bec40363107e04581e01beefae /sys-process
parentRemove command-args use flag, as it pretty much does nothing anyways ... (#28... (diff)
downloadgentoo-2-4898755cb443935b332c3adfe93f2587c1f5c7f5.tar.gz
gentoo-2-4898755cb443935b332c3adfe93f2587c1f5c7f5.tar.bz2
gentoo-2-4898755cb443935b332c3adfe93f2587c1f5c7f5.zip
QA: cleanup old versions, PAM situation is still broken and needs a version bump.
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/at/ChangeLog9
-rw-r--r--sys-process/at/at-3.1.8-r11.ebuild79
-rw-r--r--sys-process/at/at-3.1.8-r12.ebuild53
-rw-r--r--sys-process/at/files/at-3.1.8-longuser.patch22
-rw-r--r--sys-process/at/files/at-3.1.8-makefile.patch47
-rw-r--r--sys-process/at/files/at.deny21
6 files changed, 8 insertions, 223 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index e15a7ad7b22b..b2f1fc9d7ffd 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/at
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.24 2010/09/20 01:06:40 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.25 2010/10/31 16:04:05 flameeyes Exp $
+
+ 31 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -at-3.1.8-r11.ebuild, -at-3.1.8-r12.ebuild,
+ -files/at-3.1.8-longuser.patch, -files/at-3.1.8-makefile.patch,
+ -files/at.deny:
+ QA: cleanup old versions, PAM situation is still broken and needs a
+ version bump.
20 Sep 2010; Michael Weber <xmw@gentoo.org> at-3.1.10.2-r1.ebuild:
Added ~arm keyword
diff --git a/sys-process/at/at-3.1.8-r11.ebuild b/sys-process/at/at-3.1.8-r11.ebuild
deleted file mode 100644
index bd17068d206a..000000000000
--- a/sys-process/at/at-3.1.8-r11.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.8-r11.ebuild,v 1.10 2009/09/23 21:28:54 patrick Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Queues jobs for later execution"
-HOMEPAGE="ftp://jurix.jura.uni-sb.de/pub/jurix/source/chroot/appl/at/"
-SRC_URI="mirror://debian/pool/main/a/at/at_${PV}-11.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND="virtual/mta
- >=sys-devel/flex-2.5.4a"
-RDEPEND="virtual/mta
- virtual/logger"
-
-pkg_setup() {
- enewgroup at 25
- enewuser at 25 -1 /var/spool/cron/atjobs at
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # respect LDFLAGS
- sed -i \
- -e "s/\(@LIBS@\)/@LDFLAGS@ \1/" \
- Makefile.in || die "sed Makefile.in failed"
-
- # Fix bug 33696 by allowing usernames longer than 8 chars,
- # thanks to Yuval Kogman for the patch
- epatch "${FILESDIR}"/at-3.1.8-longuser.patch
-}
-
-src_compile() {
- ./configure \
- --host=${CHOST/-pc/} \
- --sysconfdir=/etc/at \
- --with-jobdir=/var/spool/at/atjobs \
- --with-atspool=/var/spool/at/atspool \
- --with-etcdir=/etc/at \
- --with-daemon_username=at \
- --with-daemon_groupname=at \
- ${EXTRA_ECONF} || die "configure failed"
-
- emake LDFLAGS="${LDFLAGS}" || die "make failed"
-}
-
-src_install() {
- into /usr
- chmod 755 batch
- chmod 755 atrun
- dobin at batch
- fperms 4755 /usr/bin/at
- dosym at /usr/bin/atrm
- dosym at /usr/bin/atq
- dosbin atd atrun
-
- dodir /var/spool/at
- fowners at:at /var/spool/at
- for i in atjobs atspool ; do
- dodir /var/spool/at/${i}
- fowners at:at /var/spool/at/${i}
- fperms 700 /var/spool/at/${i}
- touch "${D}"/var/spool/at/${i}/.SEQ
- done
-
- newinitd "${FILESDIR}"/atd.rc6 atd
- insinto /etc/at
- insopts -m 0644
- doins "${FILESDIR}"/at.deny
- doman at.1 at_allow.5 atd.8 atrun.8
- dodoc ChangeLog Problems README timespec
-}
diff --git a/sys-process/at/at-3.1.8-r12.ebuild b/sys-process/at/at-3.1.8-r12.ebuild
deleted file mode 100644
index 0b1416b92ca3..000000000000
--- a/sys-process/at/at-3.1.8-r12.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.8-r12.ebuild,v 1.7 2008/06/26 10:37:33 bangert Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Queues jobs for later execution"
-HOMEPAGE="ftp://jurix.jura.uni-sb.de/pub/jurix/source/chroot/appl/at/"
-SRC_URI="mirror://debian/pool/main/a/at/at_${PV}-11.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND="virtual/mta
- >=sys-devel/flex-2.5.4a"
-RDEPEND="virtual/mta
- virtual/logger"
-
-pkg_setup() {
- enewgroup at 25
- enewuser at 25 -1 /var/spool/at/atjobs at
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-more-deny.patch
- epatch "${FILESDIR}"/${P}-makefile.patch
- epatch "${FILESDIR}"/${P}-longuser.patch
-}
-
-src_compile() {
- econf \
- --sysconfdir=/etc/at \
- --with-jobdir=/var/spool/at/atjobs \
- --with-atspool=/var/spool/at/atspool \
- --with-etcdir=/etc/at \
- --with-daemon_username=at \
- --with-daemon_groupname=at \
- || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- make install IROOT="${D}" || die
- touch "${D}"/var/spool/at/at{jobs,spool}/.SEQ
-
- newinitd "${FILESDIR}"/atd.rc6 atd
- prepalldocs
-}
diff --git a/sys-process/at/files/at-3.1.8-longuser.patch b/sys-process/at/files/at-3.1.8-longuser.patch
deleted file mode 100644
index 722587fcbb1e..000000000000
--- a/sys-process/at/files/at-3.1.8-longuser.patch
+++ /dev/null
@@ -1,22 +0,0 @@
- # Fix bug 33696 by allowing usernames longer than 8 chars,
- # thanks to Yuval Kogman for the patch
---- at-3.1.8/atd.c
-+++ at-3.1.8/atd.c
-@@ -196,7 +196,7 @@
- */
- pid_t pid;
- int fd_out, fd_in;
-- char mailbuf[9], jobbuf[9];
-+ char mailbuf[256], jobbuf[9];
- char *mailname = NULL;
- char *newname;
- FILE *stream;
-@@ -299,7 +299,7 @@
- * NFS and works with local file systems. It's not clear where
- * the bug is located. -Joey
- */
-- if (fscanf(stream, "#!/bin/sh\n# atrun uid=%d gid=%d\n# mail %8s %d",
-+ if (fscanf(stream, "#!/bin/sh\n# atrun uid=%d gid=%d\n# mail %255s %d",
- &nuid, &ngid, mailbuf, &send_mail) != 4)
- pabort("File %.500s is in wrong format - aborting",
- filename);
diff --git a/sys-process/at/files/at-3.1.8-makefile.patch b/sys-process/at/files/at-3.1.8-makefile.patch
deleted file mode 100644
index 30ceb079ee3c..000000000000
--- a/sys-process/at/files/at-3.1.8-makefile.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-- install into Gentoo/FHS doc dir
-- respect Gentoo LDFLAGS
-- at is setuid, link with bind now
-- dont allow install to strip binaries
-
---- Makefile.in
-+++ Makefile.in
-@@ -15,6 +15,9 @@
- man5dir = $(mandir)/man5
- man8dir = $(mandir)/man8
--docdir = $(prefix)/doc
--atdocdir = $(docdir)/at
-+ifndef PF
-+PF = at-$(VERSION)
-+endif
-+docdir = $(prefix)/share/doc
-+atdocdir = $(docdir)/$(PF)
- etcdir = @ETCDIR@
-
-@@ -38,5 +41,5 @@
- -DDAEMON_GROUPNAME=\"$(DAEMON_GROUPNAME)\" \
- -DLFILE=\"$(LFILE)\" -Wall
--LIBS = @LIBS@
-+LIBS = @LIBS@ @LDFLAGS@
- LIBOBJS = @LIBOBJS@
- INSTALL = @INSTALL@
-@@ -67,5 +70,5 @@
-
- at: $(ATOBJECTS)
-- $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
-+ $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB) -Wl,-z,now
- rm -f $(CLONES)
- $(LN_S) -f at atq
-@@ -101,5 +104,5 @@
- chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
- test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -m 600 at.deny $(IROOT)$(etcdir)/
-- $(INSTALL) -g root -o root -m 4755 -s at $(IROOT)$(bindir)
-+ $(INSTALL) -g root -o root -m 4711 at $(IROOT)$(bindir)
- $(LN_S) -f at $(IROOT)$(bindir)/atq
- $(LN_S) -f at $(IROOT)$(bindir)/atrm
-@@ -108,5 +111,5 @@
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
-- $(INSTALL) -g root -o root -m 755 -s atd $(IROOT)$(sbindir)
-+ $(INSTALL) -g root -o root -m 755 atd $(IROOT)$(sbindir)
- $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
- $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
diff --git a/sys-process/at/files/at.deny b/sys-process/at/files/at.deny
deleted file mode 100644
index 02f6e853d303..000000000000
--- a/sys-process/at/files/at.deny
+++ /dev/null
@@ -1,21 +0,0 @@
-guest
-nobody
-bin
-daemon
-lp
-sync
-mail
-news
-uucp
-games
-man
-ftp
-squid
-mysql
-alias
-qmaild
-qmaill
-qmailp
-qmailq
-qmailr
-qmails