summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-26 03:49:24 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-26 03:49:24 +0000
commit28aa687fac2b455a63076a2420f742aae9a93633 (patch)
tree2e459867ff05c00743a8a862570335b859d40076 /sys-process
parentBump, add moarvm support (diff)
downloadgentoo-2-28aa687fac2b455a63076a2420f742aae9a93633.tar.gz
gentoo-2-28aa687fac2b455a63076a2420f742aae9a93633.tar.bz2
gentoo-2-28aa687fac2b455a63076a2420f742aae9a93633.zip
bump; drop py2.6 pypy due to the 'share' in PyPy prefix issue, add py3.4 support, add IUSE doc & reset / fix doc install
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/glances/ChangeLog8
-rw-r--r--sys-process/glances/glances-1.7.7.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-process/glances/ChangeLog b/sys-process/glances/ChangeLog
index b2b2a806ee30..9dfae7d68c51 100644
--- a/sys-process/glances/ChangeLog
+++ b/sys-process/glances/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/glances
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/ChangeLog,v 1.16 2014/04/16 06:23:32 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/ChangeLog,v 1.17 2014/05/26 03:49:24 idella4 Exp $
+
+*glances-1.7.7 (26 May 2014)
+
+ 26 May 2014; Ian Delaney <idella4@gentoo.org> +glances-1.7.7.ebuild:
+ bump; drop py2.6 pypy due to the 'share' in PyPy prefix issue, add py3.4
+ support, add IUSE doc & reset / fix doc install
16 Apr 2014; Ian Delaney <idella4@gentoo.org> glances-1.7.4.ebuild:
add pypy support
diff --git a/sys-process/glances/glances-1.7.7.ebuild b/sys-process/glances/glances-1.7.7.ebuild
new file mode 100644
index 000000000000..d321ab5f78fe
--- /dev/null
+++ b/sys-process/glances/glances-1.7.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/glances-1.7.7.ebuild,v 1.1 2014/05/26 03:49:24 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 linux-info
+
+MYPN=Glances
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="CLI curses based monitoring tool"
+HOMEPAGE="https://github.com/nicolargo/glances"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/psutil[${PYTHON_USEDEP}]"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+python_prepare_all() {
+ sed -e "s:share/doc/glances:share/doc/${PF}:g" \
+ -e "s/'COPYING',//" \
+ -e "s:/etc:${EPREFIX}/etc:" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ mkdir "${D}"usr/share/doc/${P}/html || die
+ mv "${D}"usr/share/doc/${P}/{glances-doc.html,images/} "${D}"usr/share/doc/${P}/html/ || die
+ else
+ rm -rf "${D}"usr/share/doc/${P}/{glances-doc.html,images/} || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "${PN} can gain additional functionality with following packages:"
+ elog " dev-python/jinja - export statistics to HTML"
+ elog " app-admin/hddtemp - monitor hard drive temperatures"
+ fi
+}