summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-08-20 14:39:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-08-20 14:39:44 +0000
commit08b41751cc239a13189dfdb05b31b784804c5702 (patch)
tree11fed90c7acf0c48b15fddd36b5940358de76688 /sys-process
parentVersion bump. (diff)
downloadgentoo-2-08b41751cc239a13189dfdb05b31b784804c5702.tar.gz
gentoo-2-08b41751cc239a13189dfdb05b31b784804c5702.tar.bz2
gentoo-2-08b41751cc239a13189dfdb05b31b784804c5702.zip
Apply upstream commit http://gitorious.org/procps/procps/commit/7f6efed9bb85d1e212e06985ea3e06720f6ca949 for sysctl and config file loading problems wrt #520314 by Tobias Klausmann
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/procps/ChangeLog10
-rw-r--r--sys-process/procps/files/procps-3.3.9-sysctl-load-config-files.patch14
-rw-r--r--sys-process/procps/procps-3.3.9-r2.ebuild61
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index a40cf25fbc4c..d1814f3ca6e2 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-process/procps
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.122 2014/08/01 10:41:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.123 2014/08/20 14:39:44 ssuominen Exp $
+
+*procps-3.3.9-r2 (20 Aug 2014)
+
+ 20 Aug 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/procps-3.3.9-sysctl-load-config-files.patch, +procps-3.3.9-r2.ebuild:
+ Apply upstream commit http://gitorious.org/procps/procps/commit/7f6efed9bb85d1
+ e212e06985ea3e06720f6ca949 for sysctl and config file loading problems wrt
+ #520314 by Tobias Klausmann
01 Aug 2014; Raúl Porcel <armin76@gentoo.org> procps-3.3.9.ebuild:
ia64/sparc stable wrt #510316
diff --git a/sys-process/procps/files/procps-3.3.9-sysctl-load-config-files.patch b/sys-process/procps/files/procps-3.3.9-sysctl-load-config-files.patch
new file mode 100644
index 000000000000..c6b0a4a36251
--- /dev/null
+++ b/sys-process/procps/files/procps-3.3.9-sysctl-load-config-files.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/520314
+http://gitorious.org/procps/procps/commit/7f6efed9bb85d1e212e06985ea3e06720f6ca949
+
+--- sysctl.c
++++ sysctl.c
+@@ -640,7 +640,7 @@
+ }
+
+
+- if (stat(DEFAULT_PRELOAD, &ts) < 0 && S_ISREG(ts.st_mode)) {
++ if (stat(DEFAULT_PRELOAD, &ts) == 0 && S_ISREG(ts.st_mode)) {
+ if (!Quiet)
+ printf(_("* Applying %s ...\n"), DEFAULT_PRELOAD);
+ rc |= Preload(DEFAULT_PRELOAD);
diff --git a/sys-process/procps/procps-3.3.9-r2.ebuild b/sys-process/procps/procps-3.3.9-r2.ebuild
new file mode 100644
index 000000000000..5dc08f3ba1ca
--- /dev/null
+++ b/sys-process/procps/procps-3.3.9-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.3.9-r2.ebuild,v 1.1 2014/08/20 14:39:44 ssuominen Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="standard informational utilities and process-handling tools"
+# http://packages.debian.org/sid/procps
+HOMEPAGE="http://procps.sourceforge.net/ http://gitorious.org/procps"
+# SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.xz"
+FEDORA_HASH="0980646fa25e0be58f7afb6b98f79d74"
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}-ng/${PN}-ng-${PV}.tar.xz/${FEDORA_HASH}/${PN}-ng-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="+ncurses nls selinux static-libs systemd test unicode"
+
+RDEPEND="!<sys-apps/sysvinit-2.88-r6
+ ncurses? ( >=sys-libs/ncurses-5.7-r7[unicode?] )
+ selinux? ( sys-libs/libselinux )
+ systemd? ( >=sys-apps/systemd-209 )"
+DEPEND="${RDEPEND}
+ ncurses? ( virtual/pkgconfig )
+ systemd? ( virtual/pkgconfig )
+ test? ( dev-util/dejagnu )"
+
+S=${WORKDIR}/${PN}-ng-${PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.3.8-kill-neg-pid.patch \
+ "${FILESDIR}"/${P}-sysctl-load-config-files.patch
+ sed -i -e 's:systemd-login:systemd:' configure || die #501306
+}
+
+src_configure() {
+ econf \
+ --exec-prefix="${EPREFIX}" \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ $(use_with ncurses) \
+ $(use_enable nls) \
+ $(use_enable selinux libselinux) \
+ $(use_enable static-libs static) \
+ $(use_with systemd) \
+ $(use_enable unicode watch8bit)
+}
+
+src_install() {
+ default
+# dodoc sysctl.conf
+
+ mv "${ED}"/usr/bin/pidof "${ED}"/bin/ || die
+
+ # The configure script is completely whacked in the head
+ mv "${ED}"/lib* "${ED}"/usr/ || die
+ gen_usr_ldscript -a procps
+ prune_libtool_files
+}