summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-08 13:45:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-08 13:45:41 +0000
commit2033abbe1cc8337861b68808fdbf72b754dabfc0 (patch)
treeb2bb40036d0c2f4c43221008bc872c2b40189d45 /sys-fs
parentBump CMake minimum version to latest stable. (diff)
downloadgentoo-2-2033abbe1cc8337861b68808fdbf72b754dabfc0.tar.gz
gentoo-2-2033abbe1cc8337861b68808fdbf72b754dabfc0.tar.bz2
gentoo-2-2033abbe1cc8337861b68808fdbf72b754dabfc0.zip
Use /run/mdadm instead of /var/run/mdadm with baselayout that has the /run directory wrt #416081 by Alexander Tsoy and Robin Bankhead
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mdadm/ChangeLog10
-rw-r--r--sys-fs/mdadm/mdadm-3.2.6-r1.ebuild73
2 files changed, 81 insertions, 2 deletions
diff --git a/sys-fs/mdadm/ChangeLog b/sys-fs/mdadm/ChangeLog
index d6403b946fe4..5cb9c29cb326 100644
--- a/sys-fs/mdadm/ChangeLog
+++ b/sys-fs/mdadm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/mdadm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.160 2012/12/11 18:29:11 axs Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.161 2013/02/08 13:45:41 ssuominen Exp $
+
+*mdadm-3.2.6-r1 (08 Feb 2013)
+
+ 08 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> +mdadm-3.2.6-r1.ebuild:
+ Use /run/mdadm instead of /var/run/mdadm with baselayout that has the /run
+ directory wrt #416081 by Alexander Tsoy and Robin Bankhead
11 Dec 2012; Ian Stakenvicius <axs@gentoo.org> mdadm-3.2.3-r2.ebuild:
use udev.eclass for handling udevdir on un-patched versions, to support
diff --git a/sys-fs/mdadm/mdadm-3.2.6-r1.ebuild b/sys-fs/mdadm/mdadm-3.2.6-r1.ebuild
new file mode 100644
index 000000000000..52376cc11ce5
--- /dev/null
+++ b/sys-fs/mdadm/mdadm-3.2.6-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-3.2.6-r1.ebuild,v 1.1 2013/02/08 13:45:41 ssuominen Exp $
+
+EAPI="4"
+inherit multilib eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
+HOMEPAGE="http://neil.brown.name/blog/mdadm"
+SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="!<sys-apps/baselayout-2.1-r1
+ !<sys-apps/openrc-0.10
+ >=sys-apps/util-linux-2.16"
+
+# The tests edit values in /proc and run tests on software raid devices.
+# Thus, they shouldn't be run on systems with active software RAID devices.
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.2.1-mdassemble.patch #211426
+ epatch "${FILESDIR}"/${PN}-3.2.x-udevdir.patch #430900
+}
+
+mdadm_emake() {
+ emake \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ CC="$(tc-getCC)" \
+ CWFLAGS="-Wall" \
+ CXFLAGS="${CFLAGS}" \
+ MAP_DIR=/run/mdadm \
+ "$@"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ mdadm_emake all mdassemble
+}
+
+src_test() {
+ mdadm_emake test
+
+ sh ./test || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ into /
+ dosbin mdassemble
+ dodoc ChangeLog INSTALL TODO README* ANNOUNCE-${PV}
+
+ insinto /etc
+ newins mdadm.conf-example mdadm.conf
+ newinitd "${FILESDIR}"/mdadm.rc mdadm
+ newconfd "${FILESDIR}"/mdadm.confd mdadm
+ newinitd "${FILESDIR}"/mdraid.rc mdraid
+ newconfd "${FILESDIR}"/mdraid.confd mdraid
+}
+
+pkg_preinst() {
+ if ! has_version ${CATEGORY}/${PN} ; then
+ # Only inform people the first time they install.
+ elog "If you're not relying on kernel auto-detect of your RAID"
+ elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
+ elog " rc-update add mdraid boot"
+ fi
+}