summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-10 23:35:17 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-10 23:35:17 +0000
commitb4773944e1fa32b724a07e6c9c073e9804bcb3a2 (patch)
treeeed761e9eb920de15e9e44c0c4b2b65f69276fc6 /sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild
parentFix wrong echangelog user/missing name. Weird it did this. :( (diff)
downloadgentoo-2-b4773944e1fa32b724a07e6c9c073e9804bcb3a2.tar.gz
gentoo-2-b4773944e1fa32b724a07e6c9c073e9804bcb3a2.tar.bz2
gentoo-2-b4773944e1fa32b724a07e6c9c073e9804bcb3a2.zip
Add new ebuild with the patch from bug #230373, which builds with --as-needed and works on 64-bit arches. Mark older version -amd64 since it segfaults there.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r5 x86_64)
Diffstat (limited to 'sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild')
-rw-r--r--sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild
new file mode 100644
index 000000000000..a5c0ef49ef7c
--- /dev/null
+++ b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild,v 1.1 2008/12/10 23:35:17 flameeyes Exp $
+
+inherit eutils
+
+MY_PV=${PV%_p*}
+
+DESCRIPTION="HFS and HFS+ utils ported from OSX, supplies mkfs and fsck"
+HOMEPAGE="http://opendarwin.org"
+SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/diskdev_cmds-${MY_PV}.tar.gz
+ mirror://gentoo/diskdev_cmds-${PV}.patch.bz2"
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+DEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/diskdev_cmds-${PV}.patch
+}
+
+src_compile() {
+ emake -f Makefile.lnx || die "emake failed"
+}
+
+src_install() {
+ into /
+ dosbin fsck_hfs.tproj/fsck_hfs || die "dosbin fsck failed"
+ dosbin newfs_hfs.tproj/newfs_hfs || die "dosbin newfs failed"
+ dosym /sbin/newfs_hfs /sbin/mkfs.hfs || die "dosym mkfs.hfs failed"
+ dosym /sbin/newfs_hfs /sbin/mkfs.hfsplus || die "dosym mkfs.hfsplus failed"
+ dosym /sbin/fsck_hfs /sbin/fsck.hfs || die "dosym fsck.hfs failed"
+ dosym /sbin/fsck_hfs /sbin/fsck.hfsplus || die "dosym fsck.hfsplus failed"
+ doman newfs_hfs.tproj/newfs_hfs.8 || die "doman newfs_hfs.8 failed"
+ newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfs.8 || die "doman mkfs.hfs.8 failed"
+ newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfsplus.8 || die "doman mkfs.hfsplus.8 failed"
+ doman fsck_hfs.tproj/fsck_hfs.8 || die "doman fsck_hfs.8 failed"
+ newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfs.8 || die "doman fsck.hfs.8 failed"
+ newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfsplus.8 || die "doman fsck.hfsplus.8 failed"
+}