summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-10 08:42:57 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-10 08:42:57 +0000
commitb7d11bfb158b34986b9ab20582fc0f0f9b0a100b (patch)
tree66a73ee8ce01e6867677eaf95c7e1857e01220e1 /sys-devel/crossdev
parentAdd fix from upstream for MAKEFLAGS expansion when re-execing #331975. (diff)
downloadgentoo-2-b7d11bfb158b34986b9ab20582fc0f0f9b0a100b.tar.gz
gentoo-2-b7d11bfb158b34986b9ab20582fc0f0f9b0a100b.tar.bz2
gentoo-2-b7d11bfb158b34986b9ab20582fc0f0f9b0a100b.zip
Unify crossdev and emerge-wrapper and automate running of them.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-20100810.ebuild32
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild8
3 files changed, 44 insertions, 4 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 70999123addc..e9ddea597225 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.68 2010/07/31 17:09:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.69 2010/08/10 08:42:57 vapier Exp $
+
+*crossdev-20100810 (10 Aug 2010)
+
+ 10 Aug 2010; Mike Frysinger <vapier@gentoo.org> +crossdev-20100810.ebuild,
+ crossdev-99999999.ebuild:
+ Unify crossdev and emerge-wrapper and automate running of them.
31 Jul 2010; Mike Frysinger <vapier@gentoo.org> crossdev-20100620.ebuild:
Stabilize for everyone #330633 by Raúl Porcel.
diff --git a/sys-devel/crossdev/crossdev-20100810.ebuild b/sys-devel/crossdev/crossdev-20100810.ebuild
new file mode 100644
index 000000000000..b9bf070431dc
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20100810.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20100810.ebuild,v 1.1 2010/08/10 08:42:57 vapier Exp $
+
+EAPI="3"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index 0f2d426aebbf..6e833987787b 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-99999999.ebuild,v 1.2 2010/07/31 17:08:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-99999999.ebuild,v 1.3 2010/08/10 08:42:56 vapier Exp $
+
+EAPI="3"
if [[ ${PV} == "99999999" ]] ; then
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
@@ -8,8 +10,8 @@ if [[ ${PV} == "99999999" ]] ; then
SRC_URI=""
#KEYWORDS=""
else
- SRC_URI="mirror://gentoo/${P}.tar.lzma
- http://dev.gentoo.org/~vapier/dist/${P}.tar.lzma"
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
fi