summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-04-02 09:37:17 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-04-02 09:37:17 +0000
commit287b91fb23a2d5f481e138965ece33a7929d1488 (patch)
tree86fd8a6357e76043ca18b4c3fd8b9ba6b6062fcd /sys-apps/magneto-core
parentMask =media-libs/ffmpegsource-2.17.4_pre753 due to bug #464078 (diff)
downloadgentoo-2-287b91fb23a2d5f481e138965ece33a7929d1488.tar.gz
gentoo-2-287b91fb23a2d5f481e138965ece33a7929d1488.tar.bz2
gentoo-2-287b91fb23a2d5f481e138965ece33a7929d1488.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'sys-apps/magneto-core')
-rw-r--r--sys-apps/magneto-core/ChangeLog7
-rw-r--r--sys-apps/magneto-core/magneto-core-189.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-apps/magneto-core/ChangeLog b/sys-apps/magneto-core/ChangeLog
index 0662c3983280..c097025f1640 100644
--- a/sys-apps/magneto-core/ChangeLog
+++ b/sys-apps/magneto-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/magneto-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/ChangeLog,v 1.31 2013/03/14 18:25:46 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/ChangeLog,v 1.32 2013/04/02 09:37:17 lxnay Exp $
+
+*magneto-core-189 (02 Apr 2013)
+
+ 02 Apr 2013; Fabio Erculiani <lxnay@gentoo.org> +magneto-core-189.ebuild:
+ version bump
*magneto-core-183 (14 Mar 2013)
diff --git a/sys-apps/magneto-core/magneto-core-189.ebuild b/sys-apps/magneto-core/magneto-core-189.ebuild
new file mode 100644
index 000000000000..5ee118cae2fc
--- /dev/null
+++ b/sys-apps/magneto-core/magneto-core-189.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/magneto-core/magneto-core-189.ebuild,v 1.1 2013/04/02 09:37:17 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python multilib
+
+DESCRIPTION="Entropy Package Manager notification applet library"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+DEPEND="~sys-apps/rigo-daemon-${PV}"
+RDEPEND="${DEPEND}
+ x11-misc/xdg-utils"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-core-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/entropy/magneto"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/entropy/magneto"
+}