summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-09-01 23:09:44 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-09-01 23:09:44 +0000
commitd64df01153c2e919728ca3e7c82b83ab90d7bc1e (patch)
treea271c1196e7fd384997355fae39d4ac1d357183a /sys-apps/hwdata-gentoo
parentStable on ppc64; bug #145904 (diff)
downloadgentoo-2-d64df01153c2e919728ca3e7c82b83ab90d7bc1e.tar.gz
gentoo-2-d64df01153c2e919728ca3e7c82b83ab90d7bc1e.tar.bz2
gentoo-2-d64df01153c2e919728ca3e7c82b83ab90d7bc1e.zip
Added patches from the 2006.1 release to replace the nv driver with either vesa or fbdev.
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'sys-apps/hwdata-gentoo')
-rw-r--r--sys-apps/hwdata-gentoo/ChangeLog8
-rw-r--r--sys-apps/hwdata-gentoo/files/0.3-nv-fbdev.patch16
-rw-r--r--sys-apps/hwdata-gentoo/files/0.3-nv-vesa.patch16
-rw-r--r--sys-apps/hwdata-gentoo/hwdata-gentoo-0.3.ebuild12
4 files changed, 48 insertions, 4 deletions
diff --git a/sys-apps/hwdata-gentoo/ChangeLog b/sys-apps/hwdata-gentoo/ChangeLog
index 75a548a1bfdf..79e877f0a634 100644
--- a/sys-apps/hwdata-gentoo/ChangeLog
+++ b/sys-apps/hwdata-gentoo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwdata-gentoo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-gentoo/ChangeLog,v 1.11 2006/06/28 15:21:51 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-gentoo/ChangeLog,v 1.12 2006/09/01 23:09:44 wolf31o2 Exp $
+
+ 01 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/0.3-nv-fbdev.patch, +files/0.3-nv-vesa.patch,
+ hwdata-gentoo-0.3.ebuild:
+ Added patches from the 2006.1 release to replace the nv driver with either
+ vesa or fbdev.
28 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
hwdata-gentoo-0.3.ebuild:
diff --git a/sys-apps/hwdata-gentoo/files/0.3-nv-fbdev.patch b/sys-apps/hwdata-gentoo/files/0.3-nv-fbdev.patch
new file mode 100644
index 000000000000..4a0c7f08f844
--- /dev/null
+++ b/sys-apps/hwdata-gentoo/files/0.3-nv-fbdev.patch
@@ -0,0 +1,16 @@
+diff -urN hwdata-gentoo-0.3.orig/Cards hwdata-gentoo-0.3/Cards
+--- hwdata-gentoo-0.3.orig/Cards 2006-05-15 13:20:57.000000000 +0000
++++ hwdata-gentoo-0.3/Cards 2006-07-03 20:56:40.000000000 +0000
+@@ -322,10 +322,10 @@
+ DRIVER cyrix
+
+ NAME NVIDIA Legacy
+-DRIVER nv
++DRIVER fbdev
+
+ NAME NVIDIA GeForce
+-DRIVER nv
++DRIVER fbdev
+
+ NAME NVIDIA GeForce 256 (generic)
+ SEE NVIDIA Legacy
diff --git a/sys-apps/hwdata-gentoo/files/0.3-nv-vesa.patch b/sys-apps/hwdata-gentoo/files/0.3-nv-vesa.patch
new file mode 100644
index 000000000000..a473c7d2d2a8
--- /dev/null
+++ b/sys-apps/hwdata-gentoo/files/0.3-nv-vesa.patch
@@ -0,0 +1,16 @@
+diff -urN hwdata-gentoo-0.3.orig/Cards hwdata-gentoo-0.3/Cards
+--- hwdata-gentoo-0.3.orig/Cards 2006-05-15 13:20:57.000000000 +0000
++++ hwdata-gentoo-0.3/Cards 2006-07-03 20:56:40.000000000 +0000
+@@ -322,10 +322,10 @@
+ DRIVER cyrix
+
+ NAME NVIDIA Legacy
+-DRIVER nv
++DRIVER vesa
+
+ NAME NVIDIA GeForce
+-DRIVER nv
++DRIVER vesa
+
+ NAME NVIDIA GeForce 256 (generic)
+ SEE NVIDIA Legacy
diff --git a/sys-apps/hwdata-gentoo/hwdata-gentoo-0.3.ebuild b/sys-apps/hwdata-gentoo/hwdata-gentoo-0.3.ebuild
index aa65b2eba176..61b09d63572f 100644
--- a/sys-apps/hwdata-gentoo/hwdata-gentoo-0.3.ebuild
+++ b/sys-apps/hwdata-gentoo/hwdata-gentoo-0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-gentoo/hwdata-gentoo-0.3.ebuild,v 1.2 2006/06/28 15:21:51 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwdata-gentoo/hwdata-gentoo-0.3.ebuild,v 1.3 2006/09/01 23:09:44 wolf31o2 Exp $
inherit eutils
@@ -23,9 +23,15 @@ src_unpack() {
then
if use opengl && use binary-drivers
then
- epatch ${FILESDIR}/${PV}-fglrx.patch || die "patching for ATI"
- epatch ${FILESDIR}/${PV}-nvidia.patch || die "patching for nVidia"
+ epatch "${FILESDIR}"/${PV}-fglrx.patch || die "patching for ATI"
+ epatch "${FILESDIR}"/${PV}-nvidia.patch || die "patching for nVidia"
+ else
+ # On amd64/x86, we choose VESA over fbdev
+ epatch "${FILESDIR}"/${PV}-nv-vesa.patch || die "patching vesa"
fi
+ else
+ # The "nv" driver sucks so much, we choose fbdev, instead
+ epatch "${FILESDIR}"/${PV}-nv-fbdev.patch || die "patching fbdev"
fi
}