summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2014-10-03 21:17:21 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2014-10-03 21:17:21 +0000
commit77e1c89803d5f0a32e6256a01c02440eaf49099c (patch)
treea0666d35fd3ba5130e993e68e988784962718e26 /sci-visualization
parentVersion bump. Removed old (diff)
downloadgentoo-2-77e1c89803d5f0a32e6256a01c02440eaf49099c.tar.gz
gentoo-2-77e1c89803d5f0a32e6256a01c02440eaf49099c.tar.bz2
gentoo-2-77e1c89803d5f0a32e6256a01c02440eaf49099c.zip
Version bump, drop old
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/yt/ChangeLog7
-rw-r--r--sci-visualization/yt/yt-3.0.2.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/sci-visualization/yt/ChangeLog b/sci-visualization/yt/ChangeLog
index a977441e4bf6..b2f6145a6658 100644
--- a/sci-visualization/yt/ChangeLog
+++ b/sci-visualization/yt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/yt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/yt/ChangeLog,v 1.2 2014/09/04 22:48:30 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/yt/ChangeLog,v 1.3 2014/10/03 21:17:21 xarthisius Exp $
+
+*yt-3.0.2 (03 Oct 2014)
+
+ 03 Oct 2014; Kacper Kowalik <xarthisius@gentoo.org> +yt-3.0.2.ebuild:
+ Version bump, drop old
*yt-3.0.1 (04 Sep 2014)
diff --git a/sci-visualization/yt/yt-3.0.2.ebuild b/sci-visualization/yt/yt-3.0.2.ebuild
new file mode 100644
index 000000000000..56426d6c60cb
--- /dev/null
+++ b/sci-visualization/yt/yt-3.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/yt/yt-3.0.2.ebuild,v 1.1 2014/10/03 21:17:21 xarthisius Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Astrophysical Simulation Analysis and Vizualization package"
+HOMEPAGE="http://yt-project.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND="media-libs/freetype:2
+ media-libs/libpng:0=
+ sci-libs/hdf5:="
+RDEPEND="${CDEPEND}
+ dev-python/ipython[notebook,${PYTHON_USEDEP}]
+ dev-python/pyx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ >=dev-python/cython-0.19[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-0.7[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ sed -i yt/utilities/setup.py \
+ -e "s:/usr:${EPREFIX}/usr:g" || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ nosetests -sv || die "Tests fail with ${EPYTHON} ${PWD}"
+ popd > /dev/null
+}