summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-22 03:45:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-22 03:45:37 +0000
commitd7530f60fd96ac5625ddbb768e6f3fadbf3c9d06 (patch)
tree75fa98ed1a16a4e4a283440d7e8dbf02f68670b5 /sci-physics/geant
parentVersion Bump (diff)
downloadgentoo-2-d7530f60fd96ac5625ddbb768e6f3fadbf3c9d06.tar.gz
gentoo-2-d7530f60fd96ac5625ddbb768e6f3fadbf3c9d06.tar.bz2
gentoo-2-d7530f60fd96ac5625ddbb768e6f3fadbf3c9d06.zip
Proper CMake optional use bug #359437 thanks Rafal Lalik
(Portage version: 2.1.9.43/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/geant')
-rw-r--r--sci-physics/geant/ChangeLog5
-rw-r--r--sci-physics/geant/geant-4.9.4_p01.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index a22fe9c9e41a..a78a7a3acceb 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-physics/geant
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.47 2011/03/18 16:43:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.48 2011/03/22 03:45:37 bicatali Exp $
+
+ 22 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> geant-4.9.4_p01.ebuild:
+ Proper CMake optional use bug #359437 thanks Rafal Lalik
*geant-4.9.4_p01 (18 Mar 2011)
diff --git a/sci-physics/geant/geant-4.9.4_p01.ebuild b/sci-physics/geant/geant-4.9.4_p01.ebuild
index b8140834cce7..699036e1ff53 100644
--- a/sci-physics/geant/geant-4.9.4_p01.ebuild
+++ b/sci-physics/geant/geant-4.9.4_p01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.4_p01.ebuild,v 1.1 2011/03/18 16:43:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.4_p01.ebuild,v 1.2 2011/03/22 03:45:37 bicatali Exp $
EAPI=3
@@ -49,13 +49,13 @@ PATCHES=( "${FILESDIR}"/${PN}-4.9.4-{no-benchmarks,zlib,libdir,datadir,no-exampl
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_enable dawn GEANT4_USE_NETWORKDAWN)
- $(cmake-utils_use_enable gdml GEANT4_USE_GDML)
- $(cmake-utils_use_enable geant3 GEANT4_USE_GEANT3TOGEANT4)
- $(cmake-utils_use_enable granular GEANT4_BUILD_GRANULAR_BUILD)
- $(cmake-utils_use_enable vrml GEANT4_USE_NETWORKVRML)
- $(cmake-utils_use_enable qt4 GEANT4_USE_QT)
- $(cmake-utils_use_enable zlib GEANT4_USE_SYSTEM_ZLIB)
+ $(cmake-utils_use dawn GEANT4_USE_NETWORKDAWN)
+ $(cmake-utils_use gdml GEANT4_USE_GDML)
+ $(cmake-utils_use geant3 GEANT4_USE_GEANT3TOGEANT4)
+ $(cmake-utils_use granular GEANT4_BUILD_GRANULAR_BUILD)
+ $(cmake-utils_use vrml GEANT4_USE_NETWORKVRML)
+ $(cmake-utils_use qt4 GEANT4_USE_QT)
+ $(cmake-utils_use zlib GEANT4_USE_SYSTEM_ZLIB)
$(cmake-utils_use_build static-libs STATIC_LIBS)
)
cmake-utils_src_configure