summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-02 17:46:05 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-02 17:46:05 +0000
commitd628cfe88ad7195bce09c1c12ec2a99da27bdd69 (patch)
tree1a4fc6fb981b144a9ced3762e298d337db6d463b /sci-mathematics/ent
parentDon't set host to avoid bad interaction with pam_ck_connector.so from sys-aut... (diff)
downloadgentoo-2-d628cfe88ad7195bce09c1c12ec2a99da27bdd69.tar.gz
gentoo-2-d628cfe88ad7195bce09c1c12ec2a99da27bdd69.tar.bz2
gentoo-2-d628cfe88ad7195bce09c1c12ec2a99da27bdd69.zip
Addition requested #347577
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/ent')
-rw-r--r--sci-mathematics/ent/ChangeLog10
-rw-r--r--sci-mathematics/ent/ent-101202.ebuild26
-rw-r--r--sci-mathematics/ent/files/101202-gentoo.patch20
-rw-r--r--sci-mathematics/ent/metadata.xml8
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/ent/ChangeLog b/sci-mathematics/ent/ChangeLog
new file mode 100644
index 000000000000..729526332c42
--- /dev/null
+++ b/sci-mathematics/ent/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/ent
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ent/ChangeLog,v 1.1 2010/12/02 17:46:05 jlec Exp $
+
+*ent-101202 (02 Dec 2010)
+
+ 02 Dec 2010; Justin Lecher <jlec@gentoo.org> +files/101202-gentoo.patch,
+ +ent-101202.ebuild, +metadata.xml:
+ Addition requested #347577
+
diff --git a/sci-mathematics/ent/ent-101202.ebuild b/sci-mathematics/ent/ent-101202.ebuild
new file mode 100644
index 000000000000..5fa5278422db
--- /dev/null
+++ b/sci-mathematics/ent/ent-101202.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ent/ent-101202.ebuild,v 1.1 2010/12/02 17:46:05 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Pseudorandom number sequence test"
+HOMEPAGE="http://www.fourmilab.ch/random/"
+SRC_URI="mirror://gentoo/random-${PV}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="public-domain"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN} || die
+ dohtml ${PN}.html ${PN}itle.gif || die
+}
diff --git a/sci-mathematics/ent/files/101202-gentoo.patch b/sci-mathematics/ent/files/101202-gentoo.patch
new file mode 100644
index 000000000000..a71bc5050637
--- /dev/null
+++ b/sci-mathematics/ent/files/101202-gentoo.patch
@@ -0,0 +1,20 @@
+diff --git a/Makefile b/Makefile
+index 2a150cf..3f9b883 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,12 +1,12 @@
+
+ # Unix make file for random test program
+
+-CC = gcc
+-CFLAGS = -g -Wall
++CC ?= gcc
++CFLAGS ?= -g -Wall
+ #CFLAGS = -O
+
+ ent: ent.o iso8859.o randtest.o chisq.o
+- $(CC) $(CFLAGS) ent.o iso8859.o randtest.o chisq.o -o ent -lm
++ $(CC) $(LDFLAGS) $(CFLAGS) ent.o iso8859.o randtest.o chisq.o -o ent -lm
+
+ ent.c: iso8859.h randtest.h
+
diff --git a/sci-mathematics/ent/metadata.xml b/sci-mathematics/ent/metadata.xml
new file mode 100644
index 000000000000..a2070de023f7
--- /dev/null
+++ b/sci-mathematics/ent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>