summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-06-14 05:59:11 +0000
committerMike Frysinger <vapier@gentoo.org>2014-06-14 05:59:11 +0000
commitacd9664a3abb72819e7ff7b70bbe3a75cee1e35c (patch)
treee9e081a3df8145ec4a3bce2409205a9f8ce2a775 /sci-libs/libsigrokdecode
parentbump; add py3.4 support, update deps (diff)
downloadgentoo-2-acd9664a3abb72819e7ff7b70bbe3a75cee1e35c.tar.gz
gentoo-2-acd9664a3abb72819e7ff7b70bbe3a75cee1e35c.tar.bz2
gentoo-2-acd9664a3abb72819e7ff7b70bbe3a75cee1e35c.zip
Initial ebuild #426586.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sci-libs/libsigrokdecode')
-rw-r--r--sci-libs/libsigrokdecode/ChangeLog12
-rw-r--r--sci-libs/libsigrokdecode/files/libsigrokdecode-0.3.0-configure-test.patch28
-rw-r--r--sci-libs/libsigrokdecode/files/libsigrokdecode-0.3.0-no-check-linkage.patch30
-rw-r--r--sci-libs/libsigrokdecode/libsigrokdecode-0.3.0.ebuild54
-rw-r--r--sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild52
-rw-r--r--sci-libs/libsigrokdecode/metadata.xml5
6 files changed, 181 insertions, 0 deletions
diff --git a/sci-libs/libsigrokdecode/ChangeLog b/sci-libs/libsigrokdecode/ChangeLog
new file mode 100644
index 000000000000..6f9f1497c710
--- /dev/null
+++ b/sci-libs/libsigrokdecode/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-libs/libsigrokdecode
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsigrokdecode/ChangeLog,v 1.1 2014/06/14 05:59:11 vapier Exp $
+
+*libsigrokdecode-0.3.0 (14 Jun 2014)
+*libsigrokdecode-9999 (14 Jun 2014)
+
+ 14 Jun 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/libsigrokdecode-0.3.0-configure-test.patch,
+ +files/libsigrokdecode-0.3.0-no-check-linkage.patch,
+ +libsigrokdecode-0.3.0.ebuild, +libsigrokdecode-9999.ebuild, +metadata.xml:
+ Initial ebuild #426586.
diff --git a/sci-libs/libsigrokdecode/files/libsigrokdecode-0.3.0-configure-test.patch b/sci-libs/libsigrokdecode/files/libsigrokdecode-0.3.0-configure-test.patch
new file mode 100644
index 000000000000..921bb9a3d3ca
--- /dev/null
+++ b/sci-libs/libsigrokdecode/files/libsigrokdecode-0.3.0-configure-test.patch
@@ -0,0 +1,28 @@
+http://sourceforge.net/p/sigrok/mailman/message/32459769/
+
+From dc83770847c39934f5cbc63c8652124fafcb8d0b Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 14 Jun 2014 01:37:12 -0400
+Subject: [PATCH 1/2] fix test operator
+
+The == operator is not in POSIX.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9527379..3f661ec 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -125,7 +125,7 @@ AC_SUBST(MODNAME_PYTHON)
+ # We also need to find the name of the python3 executable (for 'make install').
+ # Some OSes call this python3, some call it python3.2, etc. etc.
+ AC_CHECK_PROGS([PYTHON3], [python3.4 python3.3 python3.2 python3])
+-if test "x$PYTHON3" == "x"; then
++if test "x$PYTHON3" = "x"; then
+ AC_MSG_ERROR([cannot find python3 executable.])
+ fi
+
+--
+2.0.0
+
diff --git a/sci-libs/libsigrokdecode/files/libsigrokdecode-0.3.0-no-check-linkage.patch b/sci-libs/libsigrokdecode/files/libsigrokdecode-0.3.0-no-check-linkage.patch
new file mode 100644
index 000000000000..6cbc4666b69b
--- /dev/null
+++ b/sci-libs/libsigrokdecode/files/libsigrokdecode-0.3.0-no-check-linkage.patch
@@ -0,0 +1,30 @@
+http://sourceforge.net/p/sigrok/mailman/message/32459770/
+
+From 27ecf0c85482786f7617571c690797ab3f07f795 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 14 Jun 2014 01:38:58 -0400
+Subject: [PATCH 2/2] do not add check to common cflags/libs
+
+Only the unittests use these flags, so don't go linking them in for
+the main library too.
+---
+ configure.ac | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3f661ec..10213a7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -134,8 +134,7 @@ AC_SEARCH_LIBS([pow], [m])
+
+ # The Check unit testing framework is optional. Disable if not found.
+ PKG_CHECK_MODULES([check], [check >= 0.9.4],
+- [have_check="yes"; CFLAGS="$CFLAGS $check_CFLAGS";
+- LIBS="$LIBS $check_LIBS"], [have_check="no"])
++ [have_check="yes"], [have_check="no"])
+ AM_CONDITIONAL(HAVE_CHECK, test x"$have_check" = "xyes")
+
+ # libsigrok is optional (only used for the protocol decoder test framework).
+--
+2.0.0
+
diff --git a/sci-libs/libsigrokdecode/libsigrokdecode-0.3.0.ebuild b/sci-libs/libsigrokdecode/libsigrokdecode-0.3.0.ebuild
new file mode 100644
index 000000000000..6c3fab103cc0
--- /dev/null
+++ b/sci-libs/libsigrokdecode/libsigrokdecode-0.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsigrokdecode/libsigrokdecode-0.3.0.ebuild,v 1.1 2014/06/14 05:59:11 vapier Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{2,3,4} )
+inherit eutils python-single-r1 autotools
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-2 autotools
+else
+ SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="provide (streaming) protocol decoding functionality"
+HOMEPAGE="http://sigrok.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=dev-libs/glib-2.24.0
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.0-configure-test.patch
+ epatch "${FILESDIR}"/${PN}-0.3.0-no-check-linkage.patch
+ eautoreconf
+
+ # Only a test program (not installed, and not used by src_test)
+ # is used by libsigrok, so disable it to avoid the compile.
+ sed -i \
+ -e '/build_runtc=/s:yes:no:' \
+ configure || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild b/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
new file mode 100644
index 000000000000..095901fb396d
--- /dev/null
+++ b/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild,v 1.1 2014/06/14 05:59:11 vapier Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{2,3,4} )
+inherit eutils python-single-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-2 autotools
+else
+ SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="provide (streaming) protocol decoding functionality"
+HOMEPAGE="http://sigrok.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=dev-libs/glib-2.24.0
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+
+ # Only a test program (not installed, and not used by src_test)
+ # is used by libsigrok, so disable it to avoid the compile.
+ sed -i \
+ -e '/build_runtc=/s:yes:no:' \
+ configure || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/sci-libs/libsigrokdecode/metadata.xml b/sci-libs/libsigrokdecode/metadata.xml
new file mode 100644
index 000000000000..253e7c37d1d4
--- /dev/null
+++ b/sci-libs/libsigrokdecode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>