summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-06-06 18:26:40 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-06-06 18:26:40 +0000
commit0f8aea1bfdf7f60f4d20050591f9652d75329be5 (patch)
treeeee80e7658f79236cbe3b3ec616df1a47bf42a61 /sci-chemistry
parentfix openexr dep (diff)
downloadgentoo-2-0f8aea1bfdf7f60f4d20050591f9652d75329be5.tar.gz
gentoo-2-0f8aea1bfdf7f60f4d20050591f9652d75329be5.tar.bz2
gentoo-2-0f8aea1bfdf7f60f4d20050591f9652d75329be5.zip
Adding pymol-0.99_rc10 which now depends on virtual/glut instead of media-libs/glut.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol/ChangeLog9
-rw-r--r--sci-chemistry/pymol/files/digest-pymol-0.99_rc100
-rw-r--r--sci-chemistry/pymol/files/pymol-0.99_rc10-data-path.patch64
-rw-r--r--sci-chemistry/pymol/pymol-0.99_rc10.ebuild77
4 files changed, 149 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index b822500b4eaf..629f63d098ed 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.25 2007/06/01 17:34:49 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.26 2007/06/06 18:26:40 je_fro Exp $
+
+*pymol-0.99_rc10 (06 Jun 2007)
+
+ 06 Jun 2007; Jeff Gardner <je_fro@gentoo.org>
+ +files/pymol-0.99_rc10-data-path.patch, +pymol-0.99_rc10.ebuild:
+ Adding pymol-0.99_rc10 which now depends on virtual/glut instead of
+ media-libs/glut.
01 Jun 2007; nixnut <nixnut@gentoo.org> pymol-0.99_rc6-r2.ebuild:
Stable on ppc wrt bug 176831
diff --git a/sci-chemistry/pymol/files/digest-pymol-0.99_rc10 b/sci-chemistry/pymol/files/digest-pymol-0.99_rc10
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sci-chemistry/pymol/files/digest-pymol-0.99_rc10
diff --git a/sci-chemistry/pymol/files/pymol-0.99_rc10-data-path.patch b/sci-chemistry/pymol/files/pymol-0.99_rc10-data-path.patch
new file mode 100644
index 000000000000..286489ff8d58
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-0.99_rc10-data-path.patch
@@ -0,0 +1,64 @@
+--- pymol-0.99rc8/modules/pymol/commanding.py 2007-04-18 02:11:48.000000000 -0400
++++ commanding.py 2007-04-24 02:17:53.000000000 -0400
+@@ -129,11 +129,11 @@
+ unlock(0)
+ r = DEFAULT_SUCCESS
+ if show_splash==1: # generic / open-source
+- png_path = cmd.exp_path("$PYMOL_PATH/data/pymol/splash.png")
++ png_path = cmd.exp_path("$PYMOL_DATA/pymol/splash.png")
+ elif show_splash==2: # evaluation builds
+- png_path = cmd.exp_path("$PYMOL_PATH/data/pymol/epymol.png")
++ png_path = cmd.exp_path("$PYMOL_DATA/pymol/epymol.png")
+ else: # incentive builds
+- png_path = cmd.exp_path("$PYMOL_PATH/data/pymol/ipymol.png")
++ png_path = cmd.exp_path("$PYMOL_DATA/pymol/ipymol.png")
+ if os.path.exists(png_path):
+ cmd.do("_ cmd.load_png('%s',0,quiet=1)"%png_path)
+ else:
+--- pymol-0.99rc8/modules/pymol/fitting.py 2007-04-18 02:11:48.000000000 -0400
++++ fitting.py 2007-04-24 02:18:07.000000000 -0400
+@@ -61,7 +61,7 @@
+ r = DEFAULT_ERROR
+ source = selector.process(source)
+ target = selector.process(target)
+- mfile = cmd.exp_path("$PYMOL_PATH/data/pymol/matrices/"+matrix)
++ mfile = cmd.exp_path("$PYMOL_DATA/pymol/matrices/"+matrix)
+ if object==None: object=''
+ try:
+ lock()
+--- pymol-0.99rc8/modules/pymol/importing.py 2007-04-18 02:11:47.000000000 -0400
++++ importing.py 2007-04-24 02:18:46.000000000 -0400
+@@ -177,7 +177,7 @@
+ r = DEFAULT_ERROR
+
+
+- tables = { 'cmyk' : "$PYMOL_PATH/data/pymol/cmyk.png",
++ tables = { 'cmyk' : "$PYMOL_DATA/pymol/cmyk.png",
+ 'pymol' : 'pymol',
+ 'rgb' : 'rgb' }
+
+--- pymol-0.99rc8/modules/pymol/wizard/mutagenesis.py 2007-04-18 02:11:50.000000000 -0400
++++ mutagenesis.py 2007-04-24 04:08:44.000000000 -0400
+@@ -35,8 +35,8 @@
+
+ self.dep = default_dep
+
+- self.ind_library = io.pkl.fromFile(os.environ['PYMOL_PATH']+
+- "/data/chempy/sidechains/sc_bb_ind.pkl")
++ self.ind_library = io.pkl.fromFile(os.environ['PYMOL_DATA']+
++ "/chempy/sidechains/sc_bb_ind.pkl")
+ self.load_library()
+ self.status = 0 # 0 no selection, 1 mutagenizing
+ self.bump_check = 1
+@@ -108,8 +108,8 @@
+ def load_library(self):
+ if self.dep == 'dep':
+ if not hasattr(self,'dep_library'):
+- self.dep_library = io.pkl.fromFile(os.environ['PYMOL_PATH']+
+- "/data/chempy/sidechains/sc_bb_dep.pkl")
++ self.dep_library = io.pkl.fromFile(os.environ['PYMOL_DATA']+
++ "/chempy/sidechains/sc_bb_dep.pkl")
+
+ def set_mode(self,mode):
+ if mode in self.modes:
+
diff --git a/sci-chemistry/pymol/pymol-0.99_rc10.ebuild b/sci-chemistry/pymol/pymol-0.99_rc10.ebuild
new file mode 100644
index 000000000000..f5fd0160d707
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-0.99_rc10.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-0.99_rc10.ebuild,v 1.1 2007/06/06 18:26:40 je_fro Exp $
+
+inherit distutils eutils multilib subversion
+
+ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/pymol/branches/b099/pymol"
+ESVN_UPDATE_CMD="svn -r 2974 update"
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+
+LICENSE="PSF-2.2"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/python
+dev-python/pmw
+dev-python/numeric
+dev-lang/tk
+media-libs/libpng
+sys-libs/zlib
+virtual/glut"
+
+src_unpack() {
+ subversion_src_unpack
+
+ epatch "${FILESDIR}"/${P}-data-path.patch
+
+# Turn off splash screen. Please do make a project contribution
+# if you are able.
+ [[ -n "$WANT_NOSPLASH" ]] && epatch "${FILESDIR}"/nosplash-gentoo.patch
+
+# Respect CFLAGS
+ sed -i \
+ -e "s:\(ext_comp_args=\).*:\1[]:g" \
+ "${S}"/setup.py
+}
+
+src_install() {
+ python_version
+
+ distutils_src_install
+ cd "${S}"
+
+#The following three lines probably do not do their jobs and should be
+#changed
+ PYTHONPATH="${D}/usr/$(get_libdir)/site-packages" ${python} setup2.py
+
+# These environment variables should not go in the wrapper script, or else
+# it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol << EOF
+ PYMOL_PATH=/usr/$(get_libdir)/python${PYVER}/site-packages/pymol
+ PYMOL_DATA="/usr/share/pymol/data"
+ PYMOL_SCRIPTS="/usr/share/pymol/scripts"
+EOF
+
+ doenvd "${T}"/20pymol || die "Failed to install env.d file."
+
+# Make our own wrapper
+ cat >> "${T}"/pymol << EOF
+#!/bin/sh
+ ${python} \${PYMOL_PATH}/__init__.py \$*
+EOF
+
+ exeinto /usr/bin
+ doexe "${T}"/pymol || die "Failed to install wrapper."
+ dodoc DEVELOPERS CHANGES || die "Failed to install docs."
+
+ mv examples "${D}"/usr/share/doc/${PF}/ || die "Failed moving docs."
+
+ dodir /usr/share/pymol
+ mv test "${D}"/usr/share/pymol/ || die "Failed moving test files."
+ mv data "${D}"/usr/share/pymol/ || die "Failed moving data files."
+ mv scripts "${D}"/usr/share/pymol/ || die "Failed moving scripts."
+}