summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-04 13:03:15 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-04 13:03:15 +0000
commit389938e3e6d2d4998421daff0d9e2efcbef41eb6 (patch)
treecb91c7bdcf6e10b8224118373f957102ec778372 /sci-chemistry/autodock
parentFix LICENSE: same terms as perl (#301969). Maintenance (diff)
downloadgentoo-2-389938e3e6d2d4998421daff0d9e2efcbef41eb6.tar.gz
gentoo-2-389938e3e6d2d4998421daff0d9e2efcbef41eb6.tar.bz2
gentoo-2-389938e3e6d2d4998421daff0d9e2efcbef41eb6.zip
Version bump per bug #300834
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/autodock')
-rw-r--r--sci-chemistry/autodock/ChangeLog9
-rw-r--r--sci-chemistry/autodock/autodock-4.2.3.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/sci-chemistry/autodock/ChangeLog b/sci-chemistry/autodock/ChangeLog
index 637b06351545..ff9c6f9528e6 100644
--- a/sci-chemistry/autodock/ChangeLog
+++ b/sci-chemistry/autodock/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/autodock
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock/ChangeLog,v 1.6 2009/03/24 21:39:42 ribosome Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock/ChangeLog,v 1.7 2010/02/04 13:03:15 alexxy Exp $
+
+*autodock-4.2.3 (04 Feb 2010)
+
+ 04 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +autodock-4.2.3.ebuild:
+ Version bump per bug #300834
24 Mar 2009; Olivier Fisette <ribosome@gentoo.org> metadata.xml:
Giving up maintainership of this package.
diff --git a/sci-chemistry/autodock/autodock-4.2.3.ebuild b/sci-chemistry/autodock/autodock-4.2.3.ebuild
new file mode 100644
index 000000000000..465d14e7a73c
--- /dev/null
+++ b/sci-chemistry/autodock/autodock-4.2.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock/autodock-4.2.3.ebuild,v 1.1 2010/02/04 13:03:15 alexxy Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+MY_PN="autodocksuite"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A suite of automated docking tools"
+HOMEPAGE="http://autodock.scripps.edu/"
+SRC_URI="mirror://gentoo/${MY_PN}/${MY_P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/src"
+
+src_prepare() {
+ for i in autodock autogrid; do
+ pushd $i
+ eautoreconf
+ popd
+ done
+}
+
+src_configure() {
+ for i in autodock autogrid; do
+ pushd $i
+ econf || die "AutoDock econf failed."
+ popd
+ done
+}
+
+src_compile() {
+ emake -C autodock || die
+ emake -C autogrid || die
+}
+
+src_install() {
+ dobin "${S}"/autodock/autodock4 "${S}"/autogrid/autogrid4 \
+ || die "Failed to install autodock binary."
+
+ insinto "/usr/share/autodock"
+ doins "${S}"/autodock/{AD4_parameters.dat,AD4_PARM99.dat} \
+ || die "Failed to install shared files."
+
+ dodoc "${S}"/autodock/{AUTHORS,ChangeLog,NEWS,README} \
+ || die "Failed to install documentation."
+}
+
+src_test() {
+ cd "${S}/autodock/Tests"
+ python test_autodock4.py || die "AutoDock tests failed."
+ cd "${S}/autogrid/Tests"
+ python test_autogrid4.py || die "AutoGrid tests failed."
+}
+
+pkg_postinst() {
+ einfo "The AutoDock development team requests all users to fill out the"
+ einfo "registration form at:"
+ einfo
+ einfo "\thttp://autodock.scripps.edu/downloads/autodock-registration"
+ einfo
+ einfo "The number of unique users of AutoDock is used by Prof. Arthur J."
+ einfo "Olson and the Scripps Research Institude to support grant"
+ einfo "applications."
+}