summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-09-17 14:11:13 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-09-17 14:11:13 +0000
commitd2eb1025f5359c88d325b676c40aea14e9ecdd12 (patch)
tree40111fa9a4dd86caacd31b3b5a15b359fb86e2cb /sci-biology/meme
parentVersion bump (diff)
downloadgentoo-2-d2eb1025f5359c88d325b676c40aea14e9ecdd12.tar.gz
gentoo-2-d2eb1025f5359c88d325b676c40aea14e9ecdd12.tar.bz2
gentoo-2-d2eb1025f5359c88d325b676c40aea14e9ecdd12.zip
Fixup for amd64. Looks like repoman is going to mangle my patches again :(
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-biology/meme')
-rw-r--r--sci-biology/meme/ChangeLog8
-rw-r--r--sci-biology/meme/files/digest-meme-3.5.4-r13
-rw-r--r--sci-biology/meme/meme-3.5.4-r1.ebuild90
3 files changed, 100 insertions, 1 deletions
diff --git a/sci-biology/meme/ChangeLog b/sci-biology/meme/ChangeLog
index 28e5a6febb17..086d6e8d4c57 100644
--- a/sci-biology/meme/ChangeLog
+++ b/sci-biology/meme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/meme
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/ChangeLog,v 1.3 2007/09/17 06:00:16 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/ChangeLog,v 1.4 2007/09/17 14:11:13 je_fro Exp $
+
+*meme-3.5.4-r1 (17 Sep 2007)
+
+ 17 Sep 2007; <jeff@gentoo.org> files/meme-3.5.4-patch1.patch,
+ files/meme-3.5.4-patch2.patch, +meme-3.5.4-r1.ebuild:
+ Once again, remove parallel install for amd64 boxes, and add upstream patches.
17 Sep 2007; <jeff@gentoo.org> -meme-3.5.4-r1.ebuild:
Whoa...this version worked in my overlay. Pulling until I figure out what
diff --git a/sci-biology/meme/files/digest-meme-3.5.4-r1 b/sci-biology/meme/files/digest-meme-3.5.4-r1
new file mode 100644
index 000000000000..01fad3060d81
--- /dev/null
+++ b/sci-biology/meme/files/digest-meme-3.5.4-r1
@@ -0,0 +1,3 @@
+MD5 9a8b3d21c6094616cc7b9b424352c697 meme_3.5.4.tar.gz 1045501
+RMD160 063a804c18f07349e95f4aba2a3c97cb025ed2a8 meme_3.5.4.tar.gz 1045501
+SHA256 b753ee276bc5eafeab8ff310e6d938977da11f466d26cfd3ae9c0f0a7a91de86 meme_3.5.4.tar.gz 1045501
diff --git a/sci-biology/meme/meme-3.5.4-r1.ebuild b/sci-biology/meme/meme-3.5.4-r1.ebuild
new file mode 100644
index 000000000000..fe197fe6aba4
--- /dev/null
+++ b/sci-biology/meme/meme-3.5.4-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/meme-3.5.4-r1.ebuild,v 1.3 2007/09/17 14:11:13 je_fro Exp $
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="The MEME/MAST system - Motif discovery and search"
+HOMEPAGE="http://meme.sdsc.edu/meme"
+SRC_URI="http://meme.nbcr.net/downloads/${PN}_${PV}.tar.gz"
+LICENSE="meme"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+# Other possible USE flags include "debug", "client", "server", "web",
+# "queue". Other variables must be set at compile time, but only when
+# the Web server is built. Right now, Web server and client are disabled.
+IUSE="mpi"
+
+# Works only with LAM-MPI.
+DEPEND=">=dev-lang/perl-5.6.1
+ mpi? ( sys-cluster/lam-mpi )"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-Makefile.am.patch"
+ epatch "${FILESDIR}/${P}-patch1.patch"
+ epatch "${FILESDIR}/${P}-patch2.patch"
+ einfo "Regenerating autotools files..."
+ eautoreconf
+}
+
+src_compile() {
+ local EXTRA_CONF
+ # Build system is too bugy to make the programs use standard locations.
+ # Put everything in "/opt" instead.
+ EXTRA_CONF="${EXTRA_CONF} --prefix=/opt/${PN}"
+ EXTRA_CONF="${EXTRA_CONF} --with-logs=/var/log/${PN}"
+ # Connect hyperlinks to official Web site.
+ EXTRA_CONF="${EXTRA_CONF} --with-url=http://meme.nbcr.net/meme"
+ # Disable Web server, client and Web site.
+ EXTRA_CONF="${EXTRA_CONF} --disable-server --disable-client --disable-web"
+ # Parallel implementation
+ if ! use mpi; then
+ EXTRA_CONF="${EXTRA_CONF} --enable-serial"
+ fi
+
+ ./configure ${EXTRA_CONF} || die "Configure failed."
+ CC="$(tc-getCC)" ac_cc_opt="${CFLAGS}" make -e || die "Make failed."
+
+# Install parallel files only on x86, otherwise the install fails with the error:
+# i386 architecture of input file `mp.o' is incompatible with i386:x86-64 output
+ if [[ "${ARCH}" == "x86" ]] ; then
+ if use mpi; then
+ cd src/parallel
+ make || die "Parallel make failed."
+ fi
+ fi
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Failed to install program files."
+ exeinto "/opt/${PN}/bin"
+ if [[ "${ARCH}" == "x86" ]] ; then
+ if use mpi; then
+ doexe "${S}/src/parallel/${PN}_p" || \
+ die "Failed to install parallel MEME implementation."
+ fi
+ fi
+ keepdir "/var/log/${PN}"
+ fperms 777 "/var/log/${PN}"
+}
+
+pkg_postinst() {
+ echo
+ einfo 'Prior to using MEME/MAST, you should source "/opt/meme/etc/meme.sh"'
+ einfo '(or "/opt/meme/etc/meme.csh" if you use a csh-style shell). To do'
+ einfo 'this automatically with bash, add the following statement to your'
+ einfo '"~/.bashrc" file (without the quotes): "source /opt/meme/etc/meme.sh".'
+ echo
+ einfo 'Log files are produced in the "/var/log/meme" directory.'
+ echo
+}
+
+src_test() {
+ make test || die "Regression tests failed."
+}