summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-11-26 16:03:52 +0000
committerPacho Ramos <pacho@gentoo.org>2011-11-26 16:03:52 +0000
commitb2d63343711a616ea5bd3ce3c74910b165400c36 (patch)
treee71e77da95046150e4237e5bf6655b36d9df6d29 /net-voip
parentVersion bump. (diff)
downloadgentoo-2-b2d63343711a616ea5bd3ce3c74910b165400c36.tar.gz
gentoo-2-b2d63343711a616ea5bd3ce3c74910b165400c36.tar.bz2
gentoo-2-b2d63343711a616ea5bd3ce3c74910b165400c36.zip
Version bump.
(Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog7
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.14.1.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index fcc8bd5f5b83..a3f45ec04578 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.91 2011/11/20 13:09:24 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.92 2011/11/26 16:03:52 pacho Exp $
+
+*telepathy-gabble-0.14.1 (26 Nov 2011)
+
+ 26 Nov 2011; Pacho Ramos <pacho@gentoo.org> +telepathy-gabble-0.14.1.ebuild:
+ Version bump.
*telepathy-gabble-0.14.0 (20 Nov 2011)
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.14.1.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.14.1.ebuild
new file mode 100644
index 000000000000..4dc77c7e1823
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.14.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.14.1.ebuild,v 1.1 2011/11/26 16:03:52 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="debug +jingle test"
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.82
+ >=net-libs/telepathy-glib-0.15.9
+ >=net-libs/libnice-0.0.11
+ >=net-libs/gnutls-2.10.2
+
+ dev-db/sqlite:3
+ dev-libs/libxml2
+
+ jingle? ( || ( net-libs/libsoup:2.4[ssl]
+ >=net-libs/libsoup-2.33.1 ) )
+
+ !<net-im/telepathy-mission-control-5.5.0"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ test? ( >=dev-python/twisted-0.8.2
+ >=dev-python/twisted-words-0.8.2
+ >=dev-python/dbus-python-0.83 )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable jingle google-relay) \
+ $(use_enable debug handle-leak-debug)
+}
+
+src_test() {
+ # Twisted tests fail, upstream bug #30565
+ emake -C tests check-TESTS
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS NEWS ChangeLog README
+ find "${D}" -name '*.la' -exec rm -f {} +
+}