summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-06-28 03:09:05 +0000
committerJon Hood <squinky86@gentoo.org>2006-06-28 03:09:05 +0000
commite1d4d920d189febd778ee65938565d381ce56a33 (patch)
treed28ad775153b7a4734520587443af4f893ea7273 /net-p2p
parentarm/s390/sh stable #134168 (diff)
downloadgentoo-2-e1d4d920d189febd778ee65938565d381ce56a33.tar.gz
gentoo-2-e1d4d920d189febd778ee65938565d381ce56a33.tar.bz2
gentoo-2-e1d4d920d189febd778ee65938565d381ce56a33.zip
Add gcc-4.1 patch by Tristan Heaven <tristanheaven@gmail.com>, bug #138043. Fix configure script to find the kde libraries, bug #112155. Add libyahoo patch to compile yahoo support correctly.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qtella/ChangeLog10
-rw-r--r--net-p2p/qtella/files/digest-qtella-0.7.02
-rw-r--r--net-p2p/qtella/files/digest-qtella-0.7.0-r15
-rw-r--r--net-p2p/qtella/files/qtella-0.7.0-gcc41.patch47
-rw-r--r--net-p2p/qtella/qtella-0.7.0-r1.ebuild46
5 files changed, 87 insertions, 23 deletions
diff --git a/net-p2p/qtella/ChangeLog b/net-p2p/qtella/ChangeLog
index aa89e6649a65..e0a90b6b3183 100644
--- a/net-p2p/qtella/ChangeLog
+++ b/net-p2p/qtella/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qtella
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qtella/ChangeLog,v 1.25 2005/09/12 18:42:05 mkay Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qtella/ChangeLog,v 1.26 2006/06/28 03:09:05 squinky86 Exp $
+
+ 28 Jun 2006; Jon Hood <squinky86@gentoo.org>
+ +files/qtella-0.7.0-gcc41.patch, qtella-0.7.0-r1.ebuild:
+ Add gcc-4.1 patch by Tristan Heaven <tristanheaven@gmail.com>, bug #138043.
+ Fix configure script to find the kde libraries, bug #112155. Add libyahoo
+ patch to compile yahoo support correctly.
12 Sep 2005; <mkay@gentoo.org> qtella-0.7.0.ebuild,
qtella-0.7.0-r1.ebuild::
diff --git a/net-p2p/qtella/files/digest-qtella-0.7.0 b/net-p2p/qtella/files/digest-qtella-0.7.0
index 77c603f794c5..bd48d6792416 100644
--- a/net-p2p/qtella/files/digest-qtella-0.7.0
+++ b/net-p2p/qtella/files/digest-qtella-0.7.0
@@ -1 +1,3 @@
MD5 43f59fcf6366db64f8b6b3fc3d6b0fa3 qtella-0.7.0.tar.gz 672916
+RMD160 e642e0974891e6e96b89d53a117326530116b0c6 qtella-0.7.0.tar.gz 672916
+SHA256 d985e3ee9749016c3bbc8bd90c4c01af6533bff5c88407068b25fbe3107d597c qtella-0.7.0.tar.gz 672916
diff --git a/net-p2p/qtella/files/digest-qtella-0.7.0-r1 b/net-p2p/qtella/files/digest-qtella-0.7.0-r1
index 77c603f794c5..ad58823af275 100644
--- a/net-p2p/qtella/files/digest-qtella-0.7.0-r1
+++ b/net-p2p/qtella/files/digest-qtella-0.7.0-r1
@@ -1 +1,6 @@
+MD5 bc19001957de521d2fbad8e75559266c qtella-0.7.0-libyahoo.patch.gz 3566
+RMD160 ca2f94362b9d75da3c6730e8a86cfc9bb72cdab9 qtella-0.7.0-libyahoo.patch.gz 3566
+SHA256 f6b06583e30f6189377271545ee8d1f28dda8c4dfc60c4d1bf46a229aee0414d qtella-0.7.0-libyahoo.patch.gz 3566
MD5 43f59fcf6366db64f8b6b3fc3d6b0fa3 qtella-0.7.0.tar.gz 672916
+RMD160 e642e0974891e6e96b89d53a117326530116b0c6 qtella-0.7.0.tar.gz 672916
+SHA256 d985e3ee9749016c3bbc8bd90c4c01af6533bff5c88407068b25fbe3107d597c qtella-0.7.0.tar.gz 672916
diff --git a/net-p2p/qtella/files/qtella-0.7.0-gcc41.patch b/net-p2p/qtella/files/qtella-0.7.0-gcc41.patch
new file mode 100644
index 000000000000..df349c5ec0d2
--- /dev/null
+++ b/net-p2p/qtella/files/qtella-0.7.0-gcc41.patch
@@ -0,0 +1,47 @@
+--- include/AudioMp3.h
++++ include/AudioMp3.h
+@@ -11,7 +11,7 @@
+ class AudioMp3: public MyAudioFile
+ {
+ public:
+- AudioMp3::AudioMp3( std::string filename );
++ AudioMp3( std::string filename );
+ std::string &getTitle() { return _title; };
+ void setTitle( std::string str ) { _title = str; };
+ std::string &getArtist() { return _artist;} ;
+
+--- include/AudioOgg.h
++++ include/AudioOgg.h
+@@ -11,7 +11,7 @@
+ class AudioOgg: public MyAudioFile
+ {
+ public:
+- AudioOgg::AudioOgg( std::string filename );
++ AudioOgg( std::string filename );
+ std::string &getTitle() { return _title; };
+ void setTitle( std::string str ) { _title = str; }
+ std::string &getArtist() { return _artist;} ;
+
+--- include/AudioWav.h
++++ include/AudioWav.h
+@@ -11,7 +11,7 @@
+ class AudioWav: public MyAudioFile
+ {
+ public:
+- AudioWav::AudioWav( std::string filename );
++ AudioWav( std::string filename );
+ std::string &getTitle() { return _title; };
+ std::string &getArtist() { return _artist;} ;
+ // std::string &getAlbum() { return _album; };
+
+--- include/BitTorrent.h
++++ include/BitTorrent.h
+@@ -67,7 +67,7 @@
+ public:
+ ~BitTorrent();
+ static BitTorrent* decode( const char* buf, int len );
+- static BitTorrent* BitTorrent::bt_decode_file( const char* filename );
++ static BitTorrent* bt_decode_file( const char* filename );
+ void setAnnounce( const std::string& announce );
+ const std::string& getAnnounce() const;
+ void setSingleFile( bool s );
diff --git a/net-p2p/qtella/qtella-0.7.0-r1.ebuild b/net-p2p/qtella/qtella-0.7.0-r1.ebuild
index 81bfde9d9221..ea4fe848b91a 100644
--- a/net-p2p/qtella/qtella-0.7.0-r1.ebuild
+++ b/net-p2p/qtella/qtella-0.7.0-r1.ebuild
@@ -1,44 +1,48 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qtella/qtella-0.7.0-r1.ebuild,v 1.4 2005/09/12 17:31:55 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qtella/qtella-0.7.0-r1.ebuild,v 1.5 2006/06/28 03:09:05 squinky86 Exp $
-inherit eutils kde-functions
+inherit eutils qt3 multilib kde-functions
-SRC_URI="mirror://sourceforge/qtella/${P}.tar.gz"
-HOMEPAGE="http://www.qtella.net"
+need-kde 3
+
+SRC_URI="mirror://sourceforge/qtella/${P}.tar.gz
+ http://squinky.gotdns.com/${P}-libyahoo.patch.gz"
+HOMEPAGE="http://qtella.sourceforge.net/"
DESCRIPTION="Excellent QT/KDE Gnutella Client"
LICENSE="GPL-2"
IUSE="kde"
-KEYWORDS="~x86 ~ppc ~sparc"
+KEYWORDS="~ppc ~sparc ~x86"
SLOT="3" # why??
-DEPEND="=x11-libs/qt-3*
+DEPEND="$(qt_min_version 3)
kde? ( >=kde-base/kdelibs-3 )"
-export MAKEOPTS="$MAKEOPTS -j1"
-
src_unpack() {
- unpack ${A}
- cd ${S}
+ unpack ${P}.tar.gz
+ cd "${S}"
if ! use kde; then
- epatch ${FILESDIR}/${PV}-nokde.patch
+ epatch "${FILESDIR}"/${PV}-nokde.patch
fi
- epatch ${FILESDIR}/${P}-errno.patch
+ epatch "${FILESDIR}"/${P}-errno.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${DISTDIR}"/${P}-libyahoo.patch.gz
}
src_compile() {
- set-qtdir 3
- set-kdedir 3
-
local myconf
- use kde || myconf="--with-kde=no"
+ if use kde ; then
+ myconf="--with-kde=yes --with-kde-libs=${KDEDIR}"
+ else
+ myconf="--with-kde=no"
+ fi
- econf ${myconf} || die
- emake || die
+ econf ${myconf} || die "econf failed"
+ emake -j1 || die "emake failed"
}
src_install() {
- emake DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog THANKS
}