summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-10 20:26:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-10 20:26:56 +0000
commit0ca9322943b939a4470cbd2ee9ea0b4cc89a909b (patch)
tree18f3c149ca02403cf7062a172572403f2d04679b /net-p2p
parentNew version (diff)
downloadgentoo-2-0ca9322943b939a4470cbd2ee9ea0b4cc89a909b.tar.gz
gentoo-2-0ca9322943b939a4470cbd2ee9ea0b4cc89a909b.tar.bz2
gentoo-2-0ca9322943b939a4470cbd2ee9ea0b4cc89a909b.zip
Fix Pre-stripped files issue ( bug 265209 )
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/files/qbittorrent-1.3.3-no-strip.patch13
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild51
3 files changed, 71 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index adad17c2a674..b3897af0b10f 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.57 2009/06/27 12:49:31 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.58 2009/07/10 20:26:55 hwoarang Exp $
+
+*qbittorrent-1.3.3-r1 (10 Jul 2009)
+
+ 10 Jul 2009; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-1.3.3-r1.ebuild, +files/qbittorrent-1.3.3-no-strip.patch:
+ Fix Pre-stripped files issue ( bug 265209 )
27 Jun 2009; Ben de Groot <yngwin@gentoo.org> metadata.xml:
Add qt herd as co-maintainer
diff --git a/net-p2p/qbittorrent/files/qbittorrent-1.3.3-no-strip.patch b/net-p2p/qbittorrent/files/qbittorrent-1.3.3-no-strip.patch
new file mode 100644
index 000000000000..e2baa18b53a8
--- /dev/null
+++ b/net-p2p/qbittorrent/files/qbittorrent-1.3.3-no-strip.patch
@@ -0,0 +1,13 @@
+Index: qbittorrent-1.3.3/configure
+===================================================================
+--- qbittorrent-1.3.3.orig/configure
++++ qbittorrent-1.3.3/configure
+@@ -1542,7 +1542,7 @@ int main()
+ return 1;
+
+ // run qmake on the project file
+- int ret = qc_runprogram(qmake_path, QStringList() << proPath, 0, true);
++ int ret = qc_runprogram(qmake_path.append(" QMAKE_STRIP=''"), QStringList() << proPath, 0, true);
+ if(ret != 0)
+ return 1;
+
diff --git a/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild b/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..d37d8d241bdf
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.3.3-r1.ebuild,v 1.1 2009/07/10 20:26:55 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# boost version so that we always have thread support
+DEPEND=" x11-libs/qt-gui:4
+ >=net-libs/rb_libtorrent-0.14.1
+ >=dev-libs/boost-1.34.1
+ net-misc/curl
+ dev-cpp/commoncpp2"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-strip.patch"
+)
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4_src_prepare
+}
+
+src_configure() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/$(get_libdir) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}