summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 11:56:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-09 11:56:59 +0000
commit38a1242a805f9c8625fa3f0ebbcc0303a60d58ec (patch)
treeafa52ccf0afae604513755e23aaf20c5677c4734 /net-nntp/klibido
parentAdd patch to build with GCC 4.3. Thanks to Marek Miller in bug #225335. (diff)
downloadgentoo-2-38a1242a805f9c8625fa3f0ebbcc0303a60d58ec.tar.gz
gentoo-2-38a1242a805f9c8625fa3f0ebbcc0303a60d58ec.tar.bz2
gentoo-2-38a1242a805f9c8625fa3f0ebbcc0303a60d58ec.zip
Add patch to build with GCC 4.3. Thanks to Marek Miller in bug #225359.
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-nntp/klibido')
-rw-r--r--net-nntp/klibido/ChangeLog8
-rw-r--r--net-nntp/klibido/files/klibido-0.2.5+gcc-4.3.patch81
2 files changed, 87 insertions, 2 deletions
diff --git a/net-nntp/klibido/ChangeLog b/net-nntp/klibido/ChangeLog
index aec7e960eca5..af2aadae6d66 100644
--- a/net-nntp/klibido/ChangeLog
+++ b/net-nntp/klibido/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/klibido
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/ChangeLog,v 1.24 2007/05/18 20:20:44 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/ChangeLog,v 1.25 2008/06/09 11:56:59 flameeyes Exp $
+
+ 09 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/klibido-0.2.5+gcc-4.3.patch:
+ Add patch to build with GCC 4.3. Thanks to Marek Miller in bug #225359.
18 May 2007; Raúl Porcel <armin76@gentoo.org> klibido-0.2.5.ebuild:
Add ~alpha wrt #159654
diff --git a/net-nntp/klibido/files/klibido-0.2.5+gcc-4.3.patch b/net-nntp/klibido/files/klibido-0.2.5+gcc-4.3.patch
new file mode 100644
index 000000000000..10aec51161f5
--- /dev/null
+++ b/net-nntp/klibido/files/klibido-0.2.5+gcc-4.3.patch
@@ -0,0 +1,81 @@
+--- src/grouplist.cpp~ 2007-04-02 10:09:18.000000000 +0000
++++ src/grouplist.cpp 2007-04-02 10:09:24.000000000 +0000
+@@ -22,6 +22,7 @@
+ #include "grouplist.h"
+ #include "binheader.h"
+ #include <kmessagebox.h>
++#include <cstdlib>
+ #include <assert.h>
+ #include <kiconloader.h>
+ #include "progress.h"
+--- src/headerlist.cpp~ 2007-04-02 10:12:28.000000000 +0000
++++ src/headerlist.cpp 2007-04-02 10:12:34.000000000 +0000
+@@ -24,6 +24,7 @@
+ #include <kmessagebox.h>
+ #include <klocale.h>
+ #include "progress.h"
++#include <cstdlib>
+ #include <errno.h>
+ #include <kprogress.h>
+ #include <qregexp.h>
+--- src/hlistviewitem.cpp~ 2007-04-02 10:14:54.000000000 +0000
++++ src/hlistviewitem.cpp 2007-04-02 10:14:59.000000000 +0000
+@@ -21,6 +21,7 @@
+ #include "newsgroup.h"
+ #include <qpainter.h>
+ #include <klocale.h>
++#include <cstdlib>
+ /*
+ static const char *patterns[] = { "\\d+\\.(?:avi|mpg|mpeg|wmv)", //.nn.avi
+ "(?:avi|mpg|mpeg|wmv)\\.\\d+)", //.avi.nn
+--- src/nntpthreadsocket.cpp~ 2007-04-02 10:15:35.000000000 +0000
++++ src/nntpthreadsocket.cpp 2007-04-02 10:15:41.000000000 +0000
+@@ -22,6 +22,7 @@
+ #include "nntpthreadsocket.h"
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <cstdlib>
+ #include <assert.h>
+ #include <netdb.h>
+ #include <sys/poll.h>
+--- src/queueparts.cpp~ 2007-04-02 10:16:09.000000000 +0000
++++ src/queueparts.cpp 2007-04-02 10:16:15.000000000 +0000
+@@ -20,6 +20,7 @@
+
+ #include "queueparts.h"
+ #include <qfileinfo.h>
++#include <cstdlib>
+
+
+
+--- src/qmgr.cpp~ 2007-04-02 10:17:13.000000000 +0000
++++ src/qmgr.cpp 2007-04-02 10:17:20.000000000 +0000
+@@ -29,6 +29,7 @@
+ #include <qdatetime.h>
+ #include "nzbform.h"
+ #include "mylistview.h"
++#include <cstdlib>
+
+
+ extern bool g_qResume;
+--- src/updatedb.cpp~ 2007-04-02 10:18:26.000000000 +0000
++++ src/updatedb.cpp 2007-04-02 10:18:31.000000000 +0000
+@@ -20,6 +20,7 @@
+
+ #include "updatedb.h"
+ #include "binheader.h"
++#include <cstdlib>
+
+ //CACHE PARAMETERS
+ #define CACHESIZE 503
+
+--- src/newsgroup.h.orig 2008-06-08 16:03:20.000000000 +0200
++++ src/newsgroup.h 2008-06-08 16:03:37.000000000 +0200
+@@ -20,6 +20,7 @@
+ #ifndef NEWSGROUP_H
+ #define NEWSGROUP_H
+
++#include <cstdlib>
+ #include "globals.h"
+ // #include <kmdimainfrm.h>
+ #include <klistview.h>