summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-17 08:20:01 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-17 08:20:01 +0000
commitac426ea4db5833e6e876174352cd78ac320a4b6e (patch)
tree5a07cc6911ac08b59068526a80d84796c0919fa1 /net-nds/phpldapadmin
parentFix dev-util/intltool DEPEND (by Jan Psota). (diff)
downloadgentoo-2-ac426ea4db5833e6e876174352cd78ac320a4b6e.tar.gz
gentoo-2-ac426ea4db5833e6e876174352cd78ac320a4b6e.tar.bz2
gentoo-2-ac426ea4db5833e6e876174352cd78ac320a4b6e.zip
Version bump for bug #324529. Add explicit DEPEND and use src_prepare instead of src_unpack.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'net-nds/phpldapadmin')
-rw-r--r--net-nds/phpldapadmin/ChangeLog10
-rw-r--r--net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/net-nds/phpldapadmin/ChangeLog b/net-nds/phpldapadmin/ChangeLog
index bb7510bd9770..fed106abf69a 100644
--- a/net-nds/phpldapadmin/ChangeLog
+++ b/net-nds/phpldapadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/phpldapadmin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/phpldapadmin/ChangeLog,v 1.51 2010/07/03 15:41:09 mabi Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/phpldapadmin/ChangeLog,v 1.52 2011/02/17 08:20:01 radhermit Exp $
+
+*phpldapadmin-1.2.0.5 (17 Feb 2011)
+
+ 17 Feb 2011; Tim Harder <radhermit@gentoo.org> +phpldapadmin-1.2.0.5.ebuild:
+ Version bump for bug #324529. Add explicit DEPEND and use src_prepare instead
+ of src_unpack.
*phpldapadmin-1.2.0.4-r1 (03 Jul 2010)
diff --git a/net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild b/net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild
new file mode 100644
index 000000000000..857fdddec0f2
--- /dev/null
+++ b/net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild,v 1.1 2011/02/17 08:20:01 radhermit Exp $
+
+EAPI="2"
+
+inherit webapp depend.php
+
+DESCRIPTION="phpLDAPadmin is a web-based tool for managing all aspects of your LDAP server."
+HOMEPAGE="http://phpldapadmin.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[hash,ldap,session,xml,nls]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+need_httpd_cgi
+need_php_httpd
+
+src_prepare() {
+ mv config/config.php.example config/config.php
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc INSTALL
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall2-en.txt
+
+ webapp_src_install
+}