summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-05-08 08:58:21 +0000
committerYixun Lan <dlan@gentoo.org>2015-05-08 08:58:21 +0000
commit8445438862c905bb63b2ed2bb8b5354a00dd757f (patch)
tree49976a8c158618e20c9eb5660c3a097f34606c8c /net-misc
parentbump one remove one, fixes bug #548588 (diff)
downloadgentoo-2-8445438862c905bb63b2ed2bb8b5354a00dd757f.tar.gz
gentoo-2-8445438862c905bb63b2ed2bb8b5354a00dd757f.tar.bz2
gentoo-2-8445438862c905bb63b2ed2bb8b5354a00dd757f.zip
version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/connman/ChangeLog7
-rw-r--r--net-misc/connman/connman-1.29.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index ddfe71ceffb4..38989a68c022 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.96 2015/05/05 07:58:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.97 2015/05/08 08:58:21 dlan Exp $
+
+*connman-1.29 (08 May 2015)
+
+ 08 May 2015; Yixun Lan <dlan@gentoo.org> +connman-1.29.ebuild:
+ version bump
05 May 2015; Jeroen Roovers <jer@gentoo.org> connman-1.28.ebuild:
Mark ~ppc64 (bug #542336).
diff --git a/net-misc/connman/connman-1.29.ebuild b/net-misc/connman/connman-1.29.ebuild
new file mode 100644
index 000000000000..c699a11a0335
--- /dev/null
+++ b/net-misc/connman/connman-1.29.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.29.ebuild,v 1.1 2015/05/08 08:58:21 dlan Exp $
+
+EAPI="5"
+inherit base systemd
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet l2tp ofono openvpn openconnect pptp policykit tools vpnc +wifi wispr"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=net-firewall/iptables-1.4.8
+ bluetooth? ( net-wireless/bluez )
+ l2tp? ( net-dialup/xl2tpd )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-misc/openconnect )
+ openvpn? ( net-misc/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=( "${FILESDIR}/${PN}-1.16-execinfo-assumptions.patch" )
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wispr wispr builtin) \
+ $(use_enable debug) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dobin client/connmanctl || die "client installation failed"
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}"/connman.service
+}