summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-12-16 21:44:59 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-12-16 21:44:59 +0000
commit8f9a333abb2f35284a7484c9ef7cb2f588947e26 (patch)
treecf57620be9a521bc49ead33e069b1c286673650c /net-misc/tinc/tinc-1.0.5.ebuild
parentversion bump (diff)
downloadgentoo-2-8f9a333abb2f35284a7484c9ef7cb2f588947e26.tar.gz
gentoo-2-8f9a333abb2f35284a7484c9ef7cb2f588947e26.tar.bz2
gentoo-2-8f9a333abb2f35284a7484c9ef7cb2f588947e26.zip
version bump
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'net-misc/tinc/tinc-1.0.5.ebuild')
-rw-r--r--net-misc/tinc/tinc-1.0.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/tinc/tinc-1.0.5.ebuild b/net-misc/tinc/tinc-1.0.5.ebuild
new file mode 100644
index 000000000000..bc5cdbb237c5
--- /dev/null
+++ b/net-misc/tinc/tinc-1.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.5.ebuild,v 1.1 2006/12/16 21:44:59 dragonheart Exp $
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~sparc ~x86 ~ppc"
+IUSE="nls"
+
+DEPEND=">=dev-libs/openssl-0.9.7c
+ virtual/linux-sources
+ >=dev-libs/lzo-2
+ >=sys-libs/zlib-1.1.4-r2
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf --enable-jumbograms $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README THANKS TODO
+ exeinto /etc/init.d ; newexe ${FILESDIR}/tincd tincd
+}
+
+pkg_postinst() {
+ einfo "This package requires the tun/tap kernel device."
+ einfo "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}