summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-06 06:26:22 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-06 06:26:22 +0000
commiteca65674edef72a01d63e428f25fe0f17a47f791 (patch)
tree0c3ffe58b413fcb2b110bf7ef5f72b69e0d3365a /net-misc/rsync
parentadded prefix keywords (diff)
downloadgentoo-2-eca65674edef72a01d63e428f25fe0f17a47f791.tar.gz
gentoo-2-eca65674edef72a01d63e428f25fe0f17a47f791.tar.bz2
gentoo-2-eca65674edef72a01d63e428f25fe0f17a47f791.zip
Install unit file (#466088, thanks to Doug and base-system herd for allowing it).
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/ChangeLog9
-rw-r--r--net-misc/rsync/files/rsyncd.service12
-rw-r--r--net-misc/rsync/rsync-3.0.9-r3.ebuild75
3 files changed, 95 insertions, 1 deletions
diff --git a/net-misc/rsync/ChangeLog b/net-misc/rsync/ChangeLog
index e7a4aeecfb86..7f3cf203c646 100644
--- a/net-misc/rsync/ChangeLog
+++ b/net-misc/rsync/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/rsync
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.237 2013/02/19 05:05:05 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.238 2013/07/06 06:26:21 pacho Exp $
+
+*rsync-3.0.9-r3 (06 Jul 2013)
+
+ 06 Jul 2013; Pacho Ramos <pacho@gentoo.org> +files/rsyncd.service,
+ +rsync-3.0.9-r3.ebuild:
+ Install unit file (#466088, thanks to Doug and base-system herd for allowing
+ it).
19 Feb 2013; Zac Medico <zmedico@gentoo.org> rsync-3.0.9-r2.ebuild:
Add ~arm-linux keyword.
diff --git a/net-misc/rsync/files/rsyncd.service b/net-misc/rsync/files/rsyncd.service
new file mode 100644
index 000000000000..a2c1de0add1f
--- /dev/null
+++ b/net-misc/rsync/files/rsyncd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=rsync daemon
+After=networking.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/rsync --daemon --no-detach
+StandardOutput=syslog
+StandardError=syslog
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/rsync/rsync-3.0.9-r3.ebuild b/net-misc/rsync/rsync-3.0.9-r3.ebuild
new file mode 100644
index 000000000000..f2729650f3ae
--- /dev/null
+++ b/net-misc/rsync/rsync-3.0.9-r3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-3.0.9-r3.ebuild,v 1.1 2013/07/06 06:26:21 pacho Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic prefix systemd
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/src/${P/_/}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="acl iconv ipv6 static xattr"
+
+LIB_DEPEND="acl? ( virtual/acl[static-libs(+)] )
+ xattr? ( kernel_linux? ( sys-apps/attr[static-libs(+)] ) )
+ >=dev-libs/popt-1.5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --without-included-popt \
+ $(use_enable acl acl-support) \
+ $(use_enable xattr xattr-support) \
+ $(use_enable ipv6) \
+ $(use_enable iconv) \
+ --with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
+ touch proto.h-tstamp #421625
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d-r1 rsyncd
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+ insinto /etc
+ newins "${FILESDIR}"/rsyncd.conf-3.0.9-r1 rsyncd.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rsyncd.logrotate rsyncd
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd-3.0.9-r1 rsyncd
+
+ # Install the useful contrib scripts
+ exeinto /usr/share/rsync
+ doexe support/*
+ rm -f "${ED}"/usr/share/rsync/{Makefile*,*.c}
+
+ eprefixify "${ED}"/etc/{,xinetd.d}/rsyncd*
+
+ systemd_dounit "${FILESDIR}/rsyncd.service"
+}
+
+pkg_postinst() {
+ if egrep -qis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
+ "${EROOT}"/etc/rsyncd.conf "${EROOT}"/etc/rsync/rsyncd.conf ; then
+ ewarn "You have disabled chroot support in your rsyncd.conf. This"
+ ewarn "is a security risk which you should fix. Please check your"
+ ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
+ fi
+}