summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-06 14:03:07 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-06 14:03:07 +0000
commitbc9caadc1faaec8b5b811f15a6ce6e6ca715f9bc (patch)
tree0d2717859aad8e51690fb4c02ae737f13e8385c8 /net-libs/libtorrent
parentversion bump (diff)
downloadgentoo-2-bc9caadc1faaec8b5b811f15a6ce6e6ca715f9bc.tar.gz
gentoo-2-bc9caadc1faaec8b5b811f15a6ce6e6ca715f9bc.tar.bz2
gentoo-2-bc9caadc1faaec8b5b811f15a6ce6e6ca715f9bc.zip
Add missing ipv6 support, bug #207581, remove old
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog7
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.1.ebuild45
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.2.ebuild52
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.3.ebuild52
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.4.ebuild53
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.9.ebuild7
6 files changed, 10 insertions, 206 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 93a25389117a..ff6d29fe610d 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.107 2008/02/05 11:06:17 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.108 2008/02/06 14:03:07 armin76 Exp $
+
+ 06 Feb 2008; Raúl Porcel <armin76@gentoo.org> -libtorrent-0.11.1.ebuild,
+ -libtorrent-0.11.2.ebuild, -libtorrent-0.11.3.ebuild,
+ -libtorrent-0.11.4.ebuild, libtorrent-0.11.9.ebuild:
+ Add missing ipv6 support, bug #207581, remove old
05 Feb 2008; Markus Rothe <corsair@gentoo.org> libtorrent-0.11.9.ebuild:
Stable on ppc64
diff --git a/net-libs/libtorrent/libtorrent-0.11.1.ebuild b/net-libs/libtorrent/libtorrent-0.11.1.ebuild
deleted file mode 100644
index 78b75054d30d..000000000000
--- a/net-libs/libtorrent/libtorrent-0.11.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.1.ebuild,v 1.5 2007/02/03 15:24:42 nixnut Exp $
-
-inherit eutils toolchain-funcs flag-o-matic libtool
-
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
-
-IUSE="debug"
-
-RDEPEND=">=dev-libs/libsigc++-2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.11"
-
-src_compile() {
- replace-flags -Os -O2
-
- if [[ $(tc-arch) = "x86" ]]; then
- filter-flags -fomit-frame-pointer -fforce-addr
-
- # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
- # it could be safer to fallback to -O1, but with the high use of STL in
- # rtorrent, that could make it too slow.
- [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
- fi
-
- elibtoolize
- econf \
- $(use_enable debug) \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/net-libs/libtorrent/libtorrent-0.11.2.ebuild b/net-libs/libtorrent/libtorrent-0.11.2.ebuild
deleted file mode 100644
index f84380daffd9..000000000000
--- a/net-libs/libtorrent/libtorrent-0.11.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.2.ebuild,v 1.6 2007/04/05 15:42:20 drizzt Exp $
-
-inherit eutils toolchain-funcs flag-o-matic libtool autotools
-
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
-
-IUSE="debug"
-
-RDEPEND=">=dev-libs/libsigc++-2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.11"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- AT_M4DIR="scripts" eautoreconf
-}
-
-src_compile() {
- replace-flags -Os -O2
-
- if [[ $(tc-arch) = "x86" ]]; then
- filter-flags -fomit-frame-pointer -fforce-addr
-
- # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
- # it could be safer to fallback to -O1, but with the high use of STL in
- # rtorrent, that could make it too slow.
- [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
- fi
-
- elibtoolize
- econf \
- $(use_enable debug) \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/net-libs/libtorrent/libtorrent-0.11.3.ebuild b/net-libs/libtorrent/libtorrent-0.11.3.ebuild
deleted file mode 100644
index f59f617ff944..000000000000
--- a/net-libs/libtorrent/libtorrent-0.11.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.3.ebuild,v 1.1 2007/03/27 20:47:55 drizzt Exp $
-
-inherit eutils toolchain-funcs flag-o-matic libtool autotools
-
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="debug"
-
-RDEPEND=">=dev-libs/libsigc++-2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.11"
-
-#src_unpack() {
-# unpack ${A}
-# cd "${S}"
-
-# AT_M4DIR="scripts" eautoreconf
-#}
-
-src_compile() {
- replace-flags -Os -O2
-
- if [[ $(tc-arch) = "x86" ]]; then
- filter-flags -fomit-frame-pointer -fforce-addr
-
- # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
- # it could be safer to fallback to -O1, but with the high use of STL in
- # rtorrent, that could make it too slow.
- [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
- fi
-
- elibtoolize
- econf \
- $(use_enable debug) \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/net-libs/libtorrent/libtorrent-0.11.4.ebuild b/net-libs/libtorrent/libtorrent-0.11.4.ebuild
deleted file mode 100644
index 88333d272533..000000000000
--- a/net-libs/libtorrent/libtorrent-0.11.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.4.ebuild,v 1.2 2007/05/24 15:44:46 drizzt Exp $
-
-inherit eutils toolchain-funcs flag-o-matic libtool autotools
-
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="debug"
-
-RDEPEND=">=dev-libs/libsigc++-2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.11"
-
-#src_unpack() {
-# unpack ${A}
-# cd "${S}"
-
-# AT_M4DIR="scripts" eautoreconf
-#}
-
-src_compile() {
- replace-flags -Os -O2
- append-flags -fno-strict-aliasing
-
- if [[ $(tc-arch) = "x86" ]]; then
- filter-flags -fomit-frame-pointer -fforce-addr
-
- # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
- # it could be safer to fallback to -O1, but with the high use of STL in
- # rtorrent, that could make it too slow.
- [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
- fi
-
- elibtoolize
- econf \
- $(use_enable debug) \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/net-libs/libtorrent/libtorrent-0.11.9.ebuild b/net-libs/libtorrent/libtorrent-0.11.9.ebuild
index 17e713aa8546..0f47143f2430 100644
--- a/net-libs/libtorrent/libtorrent-0.11.9.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.11.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.9.ebuild,v 1.4 2008/02/05 11:06:17 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.9.ebuild,v 1.5 2008/02/06 14:03:07 armin76 Exp $
inherit eutils toolchain-funcs flag-o-matic libtool
@@ -9,9 +9,9 @@ HOMEPAGE="http://libtorrent.rakshasa.no/"
SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 hppa ~ia64 ~ppc ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~amd64 hppa ~ia64 ~ppc ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="debug"
+IUSE="debug ipv6"
RDEPEND=">=dev-libs/libsigc++-2"
@@ -28,6 +28,7 @@ src_compile() {
elibtoolize
econf \
$(use_enable debug) \
+ $(use_enable ipv6) \
--enable-static \
--enable-shared \
--disable-dependency-tracking \