summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-08 02:50:00 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-08 02:50:00 +0000
commit76ff566ca15218b48f7c6f5e6d5a1348c87bfcd1 (patch)
tree9502fe28bea5bfc29b9df09cdd2847223e849182 /net-libs/libtorrent
parentVersion bump #345841 by Jeroen Roovers. Includes fixes for broken shebang #3... (diff)
downloadgentoo-2-76ff566ca15218b48f7c6f5e6d5a1348c87bfcd1.tar.gz
gentoo-2-76ff566ca15218b48f7c6f5e6d5a1348c87bfcd1.tar.bz2
gentoo-2-76ff566ca15218b48f7c6f5e6d5a1348c87bfcd1.zip
Fix building on systems that lack posix_fallocate().
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog5
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.6.ebuild18
2 files changed, 18 insertions, 5 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 924d4f86607a..ac073ac8ba7e 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.153 2010/08/18 04:39:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.154 2010/12/08 02:50:00 vapier Exp $
+
+ 08 Dec 2010; Mike Frysinger <vapier@gentoo.org> libtorrent-0.12.6.ebuild:
+ Fix building on systems that lack posix_fallocate().
18 Aug 2010; Jeroen Roovers <jer@gentoo.org> libtorrent-0.12.6.ebuild:
Stable for HPPA (bug #311143).
diff --git a/net-libs/libtorrent/libtorrent-0.12.6.ebuild b/net-libs/libtorrent/libtorrent-0.12.6.ebuild
index 96fd6dca3f74..d153b97ce80b 100644
--- a/net-libs/libtorrent/libtorrent-0.12.6.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.12.6.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.6.ebuild,v 1.7 2010/08/18 04:39:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.6.ebuild,v 1.8 2010/12/08 02:50:00 vapier Exp $
EAPI=2
-inherit eutils libtool
+inherit eutils libtool toolchain-funcs
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+DESCRIPTION="BitTorrent library written in C++ for *nix"
HOMEPAGE="http://libtorrent.rakshasa.no/"
SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
@@ -25,13 +25,23 @@ src_prepare() {
}
src_configure() {
+ # the configure check for posix_fallocate is wrong.
+ # reported upstream as Ticket 2416.
+ local myconf
+ echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
+ if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
+ myconf="--with-posix-fallocate"
+ else
+ myconf="--without-posix-fallocate"
+ fi
+
econf \
--disable-dependency-tracking \
--enable-aligned \
$(use_enable debug) \
$(use_enable ipv6) \
$(use_enable ssl openssl) \
- --with-posix-fallocate
+ ${myconf}
}
src_install() {