summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-07-29 01:12:57 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-07-29 01:12:57 +0000
commitca96ebfb0f4a20d102c72f49483ff62421bd6d8c (patch)
treeb686e7dca39e9d309d7480e7ac491801c538ba77 /net-irc
parentInitial Release. Closes bug #18461 (diff)
downloadgentoo-2-ca96ebfb0f4a20d102c72f49483ff62421bd6d8c.tar.gz
gentoo-2-ca96ebfb0f4a20d102c72f49483ff62421bd6d8c.tar.bz2
gentoo-2-ca96ebfb0f4a20d102c72f49483ff62421bd6d8c.zip
Initial Release. Closes bug #18461
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/eggdrop/ChangeLog11
-rw-r--r--net-irc/eggdrop/Manifest4
-rw-r--r--net-irc/eggdrop/eggdrop-1.6.15.ebuild75
-rw-r--r--net-irc/eggdrop/files/digest-eggdrop-1.6.151
-rw-r--r--net-irc/eggdrop/files/eggdrop-installer79
5 files changed, 168 insertions, 2 deletions
diff --git a/net-irc/eggdrop/ChangeLog b/net-irc/eggdrop/ChangeLog
new file mode 100644
index 000000000000..8668c88cf9b3
--- /dev/null
+++ b/net-irc/eggdrop/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-irc/eggdrop
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.1 2003/07/29 01:12:51 gregf Exp $
+
+*eggdrop-1.6.15 (28 Jul 2003)
+
+ 28 Jul 2003; Greg Fitzgerald <gregf@gentoo.org> eggdrop-1.6.15.ebuild,
+ files/eggdrop-installer:
+ Initial Release. This closes bug #18461 Credit to both Curtis Hogg
+ <buckminst@inconnu.isu.edu> and Chuck Short <chuck_short@rogers.com>
+
diff --git a/net-irc/eggdrop/Manifest b/net-irc/eggdrop/Manifest
index 22043038bbfe..5ef1b7006858 100644
--- a/net-irc/eggdrop/Manifest
+++ b/net-irc/eggdrop/Manifest
@@ -1,4 +1,4 @@
-MD5 35b1d0ac69161e9bc2fc8f3ae0a1a552 eggdrop-1.6.15.ebuild 1511
-MD5 da23aa8b8f624a673906efa97b75350b ChangeLog 396
+MD5 d0cfb87a1b81e2bd73e7d22b5aab08d5 eggdrop-1.6.15.ebuild 1610
+MD5 28603c397510e59a6393d986ba5b43e0 ChangeLog 483
MD5 e9830c3f4fb21aa6a8651d6e47bae613 files/digest-eggdrop-1.6.15 65
MD5 39427a479d743e7e81bba1f9d58b2bae files/eggdrop-installer 2313
diff --git a/net-irc/eggdrop/eggdrop-1.6.15.ebuild b/net-irc/eggdrop/eggdrop-1.6.15.ebuild
new file mode 100644
index 000000000000..064573d01280
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.6.15.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/eggdrop-1.6.15.ebuild,v 1.1 2003/07/29 01:12:51 gregf Exp $
+
+DESCRIPTION="An IRC bot extensible with C or Tcl."
+HOMEPAGE="http://www.eggheads.org/"
+SRC_URI="ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/eggdrop${PV}.tar.gz"
+KEYWORDS="~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug static ipv6"
+DEPEND="dev-lang/tcl"
+
+
+src_unpack() {
+
+ unpack ${A}
+ mv ${WORKDIR}/eggdrop${PV} ${WORKDIR}/${P}
+
+ epatch ${FILESDIR}/eggdrop-1.6.15-config.patch
+ epatch ${FILESDIR}/eggdrop-1.6.15-botchk.patch
+ epatch ${FILESDIR}/eggdrop-1.6.15-configure-in.patch
+ epatch ${FILESDIR}/eggdrop-1.6.15-potential-undef-tm-struct.patch
+
+ cd ${WORKDIR}/${P} && autoconf || die "autoconf failed?!"
+
+}
+
+src_compile() {
+ local mytarg myconf
+
+ # Sets eggdrop to use ipv6
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+ ./configure \
+ --host=${CHOST} \
+ --disable-cc-optimization \
+ ${myconf} || die "./configure failed"
+
+ make config || die "module config failed"
+
+ if use static; then
+ make static || die "make static failed"
+ fi
+
+ if use debug; then
+ make debug || die "make debug failed"
+ fi
+ make || die "make failed"
+
+}
+
+src_install() {
+
+ local a
+ make DEST=${D}/opt/eggdrop install
+
+ for a in doc/*
+ do
+ [ -f $a ] && dodoc $a
+ done
+
+ for a in doc/html/*
+ do
+ [ -f $a ] && dohtml $a
+ done
+
+ dobin ${FILESDIR}/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinfo() {
+ einfo "Please run /usr/bin/eggdrop-insaller to install your eggdrop bot."
+}
diff --git a/net-irc/eggdrop/files/digest-eggdrop-1.6.15 b/net-irc/eggdrop/files/digest-eggdrop-1.6.15
new file mode 100644
index 000000000000..0d367abfd27e
--- /dev/null
+++ b/net-irc/eggdrop/files/digest-eggdrop-1.6.15
@@ -0,0 +1 @@
+MD5 f1f0c3e8b914d626c06a567560f737dd eggdrop1.6.15.tar.gz 961868
diff --git a/net-irc/eggdrop/files/eggdrop-installer b/net-irc/eggdrop/files/eggdrop-installer
new file mode 100644
index 000000000000..6cc25c48a347
--- /dev/null
+++ b/net-irc/eggdrop/files/eggdrop-installer
@@ -0,0 +1,79 @@
+#!/bin/bash
+
+source /etc/init.d/functions.sh || {
+ echo "$0: Could not source /etc/init.d/functions.sh!"
+ exit 1
+}
+
+# Checks to see if user is trying to install eggdrop as root.
+root_check() {
+
+echo "Installing Eggdrop"
+if [ "$HOME" = "/root" ] || [ `whoami` == "root" ];
+then
+ einfo "You should not be installing eggdrop as root."
+ einfo ""
+ einfo "Installing eggdrop as root leaves your computer vulnerable"
+ einfo "to attack from other irc clients. Please use the eggdrop-installer"
+ einfo "script as the user who you wish to run eggdrop with"
+ exit 1
+else
+ install_eggdrop
+fi
+
+}
+
+# Usage information
+usage() {
+cat << "USAGE_END"
+Usage: eggbot-installer [bot-name]
+Install eggdrop for a specific user, creating the directories and files
+needed for eggdrop to run securely and safely.
+USAGE_END
+
+exit 1
+}
+
+install_eggdrop()
+{
+ if [ ! -d $HOME/.eggdrop ]
+ then
+ mkdir -p $HOME/.eggdrop
+ fi
+ einfo "Creating directories for your $bot_name ..."
+ mkdir -p $HOME/.eggdrop/$bot_name
+ mkdir -p $HOME/.eggdrop/$bot_name/logs
+ mkdir -p $HOME/.eggdrop/$bot_name/filesys
+ mkdir -p $HOME/.eggdrop/$bot_name/filesys/incoming
+ mkdir -p $HOME/.eggdrop/$bot_name/text
+ mkdir -p $HOME/.eggdrop/$bot_name/scripts
+
+ einfo "Creating symlinks to required files for your bot to run ...."
+ ln -s /opt/eggdrop/help $HOME/.eggdrop/$bot_name/help
+ ln -s /opt/eggdrop/language $HOME/.eggdrop/$bot_name/language
+ ln -s /opt/eggdrop/modules $HOME/.eggdrop/$bot_name/modules
+
+ einfo "Copying motd and banner ... "
+ cp /opt/eggdrop/text/* $HOME/.eggdrop/$bot_name/text
+
+ # I changed this from a symlink to a direct copy because the user
+ # might not have write permissions to /opt/eggdrop/scripts
+ # as well as they might have their own custom scripts. - zul<chuck_short@rogers.com>
+ cp /opt/eggdrop/scripts/* $HOME/.eggdrop/$bot_name/scripts
+
+ einfo "Finished..."
+
+ einfo "Please edit your $HOME/.eggdrop/$botname/eggdrop.conf "
+ einfo "If you need any help pleaese refer to the man page, or "
+ einfo "eggdrop website at http://www.egghelper.org"
+
+ cp /opt/eggdrop/eggdrop.conf $HOME/.eggdrop/$bot_name/eggdrop.conf
+}
+
+if [ ! -n "$1" ]
+then
+ usage
+else
+ bot_name="$1"
+ root_check
+fi