summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-05-21 17:31:08 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-05-21 17:31:08 +0000
commit0d519806424e2673b1cc1349116e25c3c3744876 (patch)
treed6eb898b8e096c2c5f5808d315b4248a27598d3f /net-fs
parentx86 stable wrt bug #319961 (diff)
downloadgentoo-2-0d519806424e2673b1cc1349116e25c3c3744876.tar.gz
gentoo-2-0d519806424e2673b1cc1349116e25c3c3744876.tar.bz2
gentoo-2-0d519806424e2673b1cc1349116e25c3c3744876.zip
Fixing build with USE=ads
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog6
-rw-r--r--net-fs/samba/samba-3.5.3.ebuild26
2 files changed, 29 insertions, 3 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 82a8e1f55165..0d7e36981437 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.417 2010/05/20 00:04:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.418 2010/05/21 17:31:08 vostorga Exp $
+
+ 21 May 2010; Víctor Ostorga <vostorga@gentoo.org> samba-3.5.3.ebuild:
+ Fixing build with USE=ads winbind, patch thanks to Rainer Ruecker
+ <rainer@emdete.de> bugs #314709 #315975
20 May 2010; Jeroen Roovers <jer@gentoo.org> samba-3.4.6.ebuild:
Stable for HPPA (bug #300158).
diff --git a/net-fs/samba/samba-3.5.3.ebuild b/net-fs/samba/samba-3.5.3.ebuild
index c236f944802e..5dcb775e3b4a 100644
--- a/net-fs/samba/samba-3.5.3.ebuild
+++ b/net-fs/samba/samba-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.5.3.ebuild,v 1.2 2010/05/19 17:16:15 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.5.3.ebuild,v 1.3 2010/05/21 17:31:08 vostorga Exp $
EAPI="2"
@@ -49,6 +49,8 @@ RESTRICT="test"
SBINPROGS=""
BINPROGS=""
+KRBPLUGIN=""
+PLUGINEXT=".so"
if use server ; then
SBINPROGS="${SBINPROGS} bin/smbd bin/nmbd"
@@ -57,7 +59,7 @@ if use server ; then
use swat && SBINPROGS="${SBINPROGS} bin/swat"
use winbind && SBINPROGS="${SBINPROGS} bin/winbindd"
- use ads && use winbind && SBINPROGS="${SBINPROGS} bin/winbind_krb5_locator"
+ use ads && use winbind && KRBPLUGIN="${KRBPLUGIN} bin/winbind_krb5_locator"
fi
if use client ; then
@@ -214,6 +216,11 @@ src_compile() {
emake ${SBINPROGS} || die "emake sbinprogs failed";
fi
+ if [ -n "${KRBPLUGIN}" ] ; then
+ einfo "make krbplugin"
+ emake ${KRBPLUGIN}${PLUGINEXT} || die "emake krbplugin failed";
+ fi
+
if use client ; then
einfo "make {,u}mount.cifs"
emake bin/{,u}mount.cifs || die "emake {,u}mount.cifs failed"
@@ -277,6 +284,21 @@ src_install() {
doman ../docs/manpages/${prog/bin\/}* || die "doman failed"
done
+ # install krbplugin
+ if has_version app-crypt/mit-krb5 ; then
+ insinto /usr/$(get_libdir)/krb5/plugins/libkrb5
+ doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
+ ${KRBPLUGIN}${PLUGINEXT} failed"
+ elif has_version app-crypt/heimdal ; then
+ insinto /usr/$(get_libdir)/plugin/krb5
+ doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
+ ${KRBPLUGIN}${PLUGINEXT} failed"
+ fi
+ insinto /usr
+ for prog in ${KRBPLUGIN} ; do
+ doman ../docs/manpages/${prog/bin\/}* || die "doman failed"
+ done
+
# install server components
if use server ; then
doman ../docs/manpages/vfs* ../docs/manpages/samba.7