summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-05-03 18:09:11 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-05-03 18:09:11 +0000
commit7bb62e00850ed8755e7ce17cd3ae197a22e0b1d3 (patch)
tree2d247e2687274466e0dd165e00dc0134ea1a3541 /net-dns/bind-tools
parentInitial import. (diff)
downloadgentoo-2-7bb62e00850ed8755e7ce17cd3ae197a22e0b1d3.tar.gz
gentoo-2-7bb62e00850ed8755e7ce17cd3ae197a22e0b1d3.tar.bz2
gentoo-2-7bb62e00850ed8755e7ce17cd3ae197a22e0b1d3.zip
Bump to 9.4.2, include dnssec-keygen (# 198721).
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'net-dns/bind-tools')
-rw-r--r--net-dns/bind-tools/ChangeLog8
-rw-r--r--net-dns/bind-tools/bind-tools-9.4.2.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/net-dns/bind-tools/ChangeLog b/net-dns/bind-tools/ChangeLog
index 0cdd4698e8a5..d32f017ab310 100644
--- a/net-dns/bind-tools/ChangeLog
+++ b/net-dns/bind-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/bind-tools
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.92 2008/02/29 21:57:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.93 2008/05/03 18:09:11 dertobi123 Exp $
+
+*bind-tools-9.4.2 (03 May 2008)
+
+ 03 May 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +bind-tools-9.4.2.ebuild:
+ Bump to 9.4.2, include dnssec-keygen (# 198721).
29 Feb 2008; Raúl Porcel <armin76@gentoo.org> bind-tools-9.2.6-r3.ebuild,
bind-tools-9.2.8-r1.ebuild, bind-tools-9.3.2-r3.ebuild,
diff --git a/net-dns/bind-tools/bind-tools-9.4.2.ebuild b/net-dns/bind-tools/bind-tools-9.4.2.ebuild
new file mode 100644
index 000000000000..70ed6e19956b
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.4.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.4.2.ebuild,v 1.1 2008/05/03 18:09:11 dertobi123 Exp $
+
+inherit flag-o-matic
+
+MY_P=${P//-tools}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="idn ipv6"
+
+DEPEND="idn? ( || ( sys-libs/glibc dev-libs/libiconv ) )"
+
+src_unpack() {
+ unpack ${A} || die
+ cd "${S}" || die
+
+ use idn && {
+ # BIND 9.4.0 doesn't have this patch
+ # epatch ${S}/contrib/idn/idnkit-1.0-src/patch/bind9/bind-${PV}-patch
+
+ cd "${S}"/contrib/idn/idnkit-1.0-src
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ cd -
+ }
+
+ # bug #151839
+ sed -e \
+ 's:struct isc_socket {:#undef SO_BSDCOMPAT\n\nstruct isc_socket {:' \
+ -i lib/isc/unix/socket.c
+}
+
+src_compile() {
+ local myconf=
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+
+ econf ${myconf} || die "Configure failed"
+
+ cd "${S}"/lib
+ emake -j1 || die "make failed in /lib"
+
+ cd "${S}"/bin/dig
+ emake -j1 || die "make failed in /bin/dig"
+
+ cd "${S}"/lib/lwres/
+ emake -j1 || die "make failed in /lib/lwres"
+
+ cd "${S}"/bin/nsupdate/
+ emake -j1 || die "make failed in /bin/nsupdate"
+
+ cd "${S}"/bin/dnssec/
+ emake -j1 || die "make failed in /bin/dnssec"
+
+ use idn && {
+ cd "${S}"/contrib/idn/idnkit-1.0-src
+ local myconf=
+ has_version sys-libs/glibc || myconf="${myconf} --with-iconv"
+ econf ${myconf} || die "idn econf failed"
+ emake -j1 || die "idn emake failed"
+ }
+}
+
+src_install() {
+ dodoc README CHANGES FAQ
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup || die
+ doman dig.1 host.1 nslookup.1 || die
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate || die
+ doman nsupdate.8 || die
+ dohtml nsupdate.html || die
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen || die
+ doman dnssec-keygen.8 || die
+ dohtml dnssec-keygen.html || die
+}