summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-12-18 13:38:34 +0000
committerSven Wegener <swegener@gentoo.org>2007-12-18 13:38:34 +0000
commit9855a5cf4a12dd14d445b6e9815206f8868443c9 (patch)
tree56cc39bbe0f53619a9cc1232578246a5ec2db188 /net-dns/avahi
parentAdd current CVS snapshot. (diff)
downloadgentoo-2-9855a5cf4a12dd14d445b6e9815206f8868443c9.tar.gz
gentoo-2-9855a5cf4a12dd14d445b6e9815206f8868443c9.tar.bz2
gentoo-2-9855a5cf4a12dd14d445b6e9815206f8868443c9.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-dns/avahi')
-rw-r--r--net-dns/avahi/ChangeLog8
-rw-r--r--net-dns/avahi/avahi-0.6.22.ebuild195
-rw-r--r--net-dns/avahi/files/avahi-0.6.22-vncviewer.patch14
-rw-r--r--net-dns/avahi/files/digest-avahi-0.6.223
4 files changed, 219 insertions, 1 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index 2dfd63134dc0..71489fba8ad3 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/avahi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.131 2007/11/19 22:19:58 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.132 2007/12/18 13:38:33 swegener Exp $
+
+*avahi-0.6.22 (18 Dec 2007)
+
+ 18 Dec 2007; Sven Wegener <swegener@gentoo.org>
+ +files/avahi-0.6.22-vncviewer.patch, +avahi-0.6.22.ebuild:
+ Version bump.
19 Nov 2007; Sven Wegener <swegener@gentoo.org>
+files/avahi-vncviewer.patch, avahi-0.6.19-r2.ebuild,
diff --git a/net-dns/avahi/avahi-0.6.22.ebuild b/net-dns/avahi/avahi-0.6.22.ebuild
new file mode 100644
index 000000000000..0c903b10435c
--- /dev/null
+++ b/net-dns/avahi/avahi-0.6.22.ebuild
@@ -0,0 +1,195 @@
+# Copyright 2000-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.22.ebuild,v 1.1 2007/12/18 13:38:33 swegener Exp $
+
+inherit eutils mono python qt3 qt4
+
+DESCRIPTION="System which facilitates service discovery on a local network"
+HOMEPAGE="http://avahi.org/"
+SRC_URI="http://avahi.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="bookmarks howl-compat mdnsresponder-compat gdbm dbus doc mono gtk python qt3 qt4 autoipd kernel_linux test ipv6"
+
+RDEPEND=">=dev-libs/libdaemon-0.11-r1
+ dev-libs/expat
+ >=dev-libs/glib-2
+ gdbm? ( sys-libs/gdbm )
+ qt3? ( $(qt_min_version 3.3.6-r2) )
+ qt4? ( $(qt4_min_version 4) )
+ gtk? (
+ >=x11-libs/gtk+-2.4.0
+ >=gnome-base/libglade-2.4.0
+ )
+ dbus? (
+ >=sys-apps/dbus-0.30
+ python? (
+ || (
+ dev-python/dbus-python
+ (
+ <sys-apps/dbus-0.90
+ >=sys-apps/dbus-0.30
+ )
+ )
+ )
+ )
+ mono? (
+ >=dev-lang/mono-1.1.10
+ gtk? ( dev-dotnet/gtk-sharp )
+ )
+ howl-compat? ( !net-misc/howl )
+ mdnsresponder-compat? ( !net-misc/mDNSResponder )
+ python? (
+ >=virtual/python-2.4
+ gtk? ( >=dev-python/pygtk-2 )
+ )
+ bookmarks? (
+ dev-python/twisted
+ dev-python/twisted-web
+ )
+ kernel_linux? ( sys-libs/libcap )
+ !net-misc/mDNSResponder"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ doc? (
+ app-doc/doxygen
+ mono? ( >=dev-util/monodoc-1.1.8 )
+ )"
+
+pkg_setup() {
+ if use python && ! built_with_use dev-lang/python gdbm
+ then
+ die "For python support you need dev-lang/python compiled with gdbm support!"
+ fi
+
+ if use python && use dbus && ! has_version dev-python/dbus-python && ! built_with_use sys-apps/dbus python
+ then
+ die "For python and dbus support you need sys-apps/dbus compiled with python support or dev-python/dbus-python!"
+ fi
+
+ if ( use mdnsresponder-compat || use howl-compat || use mono ) && ! use dbus
+ then
+ die "For *-compat or mono support you also need to enable the dbus USE flag!"
+ fi
+
+ if use bookmarks && ! ( use python && use dbus && use gtk )
+ then
+ die "For bookmarks support you also need to enable the python, dbus and gtk USE flags!"
+ fi
+}
+
+pkg_preinst() {
+ enewgroup netdev
+ enewgroup avahi
+ enewuser avahi -1 -1 -1 avahi
+
+ if use autoipd
+ then
+ enewgroup avahi-autoipd
+ enewuser avahi-autoipd -1 -1 -1 avahi-autoipd
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-vncviewer.patch
+
+ use ipv6 && sed -i -e s/use-ipv6=no/use-ipv6=yes/ avahi-daemon/avahi-daemon.conf
+
+ sed -i -e "s:\\.\\./\\.\\./\\.\\./doc/avahi-docs/html/:../../../doc/${PF}/html/:" doxygen_to_devhelp.xsl
+}
+
+src_compile() {
+ local myconf=""
+
+ if use python
+ then
+ use dbus && myconf="${myconf} --enable-python-dbus"
+ use gtk && myconf="${myconf} --enable-pygtk"
+ fi
+
+ if use mono && use doc
+ then
+ myconf="${myconf} --enable-monodoc"
+ fi
+
+ # We need to unset DISPLAY, else the configure script might have problems detecting the pygtk module
+ unset DISPLAY
+
+ econf \
+ --localstatedir=/var \
+ --with-distro=gentoo \
+ --disable-python-dbus \
+ --disable-pygtk \
+ --disable-xmltoman \
+ --disable-monodoc \
+ --enable-glib \
+ $(use_enable test tests) \
+ $(use_enable autoipd) \
+ $(use_enable mdnsresponder-compat compat-libdns_sd) \
+ $(use_enable howl-compat compat-howl) \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable mono) \
+ $(use_enable dbus) \
+ $(use_enable python) \
+ $(use_enable gtk) \
+ $(use_enable qt3) \
+ $(use_enable qt4) \
+ $(use_enable gdbm) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ use doc && emake avahi.devhelp
+}
+
+src_install() {
+ emake install py_compile=true DESTDIR="${D}" || die "make install failed"
+ use bookmarks || rm -f "${D}"/usr/bin/avahi-bookmarks
+
+ use howl-compat && ln -s avahi-compat-howl.pc "${D}"/usr/$(get_libdir)/pkgconfig/howl.pc
+ use mdnsresponder-compat && ln -s avahi-compat-libdns_sd/dns_sd.h "${D}"/usr/include/dns_sd.h
+
+ if use autoipd
+ then
+ insinto /lib/rcscripts/net
+ doins "${FILESDIR}"/autoipd.sh
+ fi
+
+ dodoc docs/{AUTHORS,README,TODO}
+
+ if use doc
+ then
+ dohtml -r doxygen/html/.
+ insinto /usr/share/devhelp/books/avahi
+ doins avahi.devhelp
+ fi
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize "${ROOT}"/usr/lib*/python*/site-packages/avahi
+
+ if use autoipd
+ then
+ elog
+ elog "To use avahi-autoipd to configure your interfaces with IPv4LL (RFC3927)"
+ elog "addresses, just set config_<interface>=( autoipd ) in /etc/conf.d/net!"
+ elog
+ fi
+
+ if use dbus
+ then
+ elog
+ elog "If this is your first install of avahi please reload your dbus config"
+ elog "with /etc/init.d/dbus reload before starting avahi-daemon!"
+ elog
+ fi
+}
diff --git a/net-dns/avahi/files/avahi-0.6.22-vncviewer.patch b/net-dns/avahi/files/avahi-0.6.22-vncviewer.patch
new file mode 100644
index 000000000000..f20e22f4225c
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.6.22-vncviewer.patch
@@ -0,0 +1,14 @@
+diff -Nur avahi-0.6.22.orig/avahi-ui/bssh.c avahi-0.6.22/avahi-ui/bssh.c
+--- avahi-0.6.22.orig/avahi-ui/bssh.c 2007-12-17 15:12:57.000000000 +0000
++++ avahi-0.6.22/avahi-ui/bssh.c 2007-12-17 16:07:54.021586488 +0000
+@@ -86,8 +86,8 @@
+
+ gtk_widget_destroy(d);
+
+- g_print("xvncviewer %s\n", p);
+- execlp("xvncviewer", "xvncviewer", p, NULL);
++ g_print("vncviewer %s\n", p);
++ execlp("vncviewer", "vncviewer", p, NULL);
+
+ } else {
+ char p[16];
diff --git a/net-dns/avahi/files/digest-avahi-0.6.22 b/net-dns/avahi/files/digest-avahi-0.6.22
new file mode 100644
index 000000000000..197f80d3c14b
--- /dev/null
+++ b/net-dns/avahi/files/digest-avahi-0.6.22
@@ -0,0 +1,3 @@
+MD5 c84b1a8a23126e188426728710414dc8 avahi-0.6.22.tar.gz 1199901
+RMD160 fad35f473a9109c8648e43b0f6f547c32b18e32f avahi-0.6.22.tar.gz 1199901
+SHA256 9dc6f870b6ce050059054a26bfc15d6e7a836fa299edd1b89c63c1089bfedd52 avahi-0.6.22.tar.gz 1199901