summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-09-03 07:36:42 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-09-03 07:36:42 +0000
commit87542e0e63dabb4cdda6c821509871e10bc7a897 (patch)
tree3c6fda8c846fcac3571702fc01f37245dbc56e54 /net-analyzer/ns
parentreplace virtual/tetex with virtual/latex-base and remove unnecessary COPYRIGH... (diff)
downloadgentoo-2-87542e0e63dabb4cdda6c821509871e10bc7a897.tar.gz
gentoo-2-87542e0e63dabb4cdda6c821509871e10bc7a897.tar.bz2
gentoo-2-87542e0e63dabb4cdda6c821509871e10bc7a897.zip
clean up and unquote A variable
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-analyzer/ns')
-rw-r--r--net-analyzer/ns/ChangeLog7
-rw-r--r--net-analyzer/ns/files/ns-2.28-gentoo.diff58
-rw-r--r--net-analyzer/ns/files/ns-2.29-gcc41.patch113
-rw-r--r--net-analyzer/ns/ns-2.29.ebuild132
-rw-r--r--net-analyzer/ns/ns-2.31.ebuild4
5 files changed, 8 insertions, 306 deletions
diff --git a/net-analyzer/ns/ChangeLog b/net-analyzer/ns/ChangeLog
index e9c0d6d34541..f7c740e71421 100644
--- a/net-analyzer/ns/ChangeLog
+++ b/net-analyzer/ns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ns
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.28 2008/09/03 07:33:13 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.29 2008/09/03 07:36:41 opfer Exp $
+
+ 03 Sep 2008; Christian Faulhammer <opfer@gentoo.org>
+ -files/ns-2.28-gentoo.diff, -files/ns-2.29-gcc41.patch, -ns-2.29.ebuild,
+ ns-2.31.ebuild:
+ clean up and unquote A variable
03 Sep 2008; Christian Faulhammer <opfer@gentoo.org> ns-2.29.ebuild,
ns-2.31.ebuild:
diff --git a/net-analyzer/ns/files/ns-2.28-gentoo.diff b/net-analyzer/ns/files/ns-2.28-gentoo.diff
deleted file mode 100644
index 05a193925499..000000000000
--- a/net-analyzer/ns/files/ns-2.28-gentoo.diff
+++ /dev/null
@@ -1,58 +0,0 @@
-diff -urN ns-2.27.orig/diffusion/diff_rate.cc ns-2.27/diffusion/diff_rate.cc
---- ns-2.27.orig/diffusion/diff_rate.cc 2004-01-12 19:57:58.000000000 -0500
-+++ ns-2.27/diffusion/diff_rate.cc 2005-01-22 21:41:36.578976416 -0500
-@@ -370,7 +370,7 @@
- INTF_INSERT(routing_table[dtype].active, OutPtr);
- routing_table[dtype].num_active ++;
- } else {
-- GRAD_TMOUT(RetVal.cur) = max(GRAD_TMOUT(RetVal.cur),
-+ GRAD_TMOUT(RetVal.cur) = MAX(GRAD_TMOUT(RetVal.cur),
- dfh->ts_ + INTEREST_TIMEOUT);
- }
-
-@@ -789,7 +789,7 @@
- if (RetVal.cur != NULL) {
- cur_out = (Out_List *)(RetVal.cur);
- GRADIENT(cur_out) = ORIGINAL;
-- GRAD_TMOUT(RetVal.cur) = max(GRAD_TMOUT(RetVal.cur),
-+ GRAD_TMOUT(RetVal.cur) = MAX(GRAD_TMOUT(RetVal.cur),
- dfh->ts_ + INTEREST_TIMEOUT);
- NUM_POS_RECV(cur_out)++;
- } else {
-diff -urN ns-2.27.orig/diffusion/diffusion.h ns-2.27/diffusion/diffusion.h
---- ns-2.27.orig/diffusion/diffusion.h 2004-01-12 19:57:58.000000000 -0500
-+++ ns-2.27/diffusion/diffusion.h 2005-01-22 21:41:36.578976416 -0500
-@@ -75,7 +75,7 @@
-
-
- #define SEND_MESSAGE(x,y,z) send_to_dmux(prepare_message(x,y,z), 0)
--#define max(a,b) (((a)<(b))?(b):(a))
-+#define MAX(a,b) (((a)<(b))?(b):(a))
-
- class DiffusionAgent;
-
-diff -urN ns-2.27.orig/diffusion/routing_table.cc ns-2.27/diffusion/routing_table.cc
---- ns-2.27.orig/diffusion/routing_table.cc 2004-01-12 19:57:59.000000000 -0500
-+++ ns-2.27/diffusion/routing_table.cc 2005-01-22 21:41:36.579976264 -0500
-@@ -129,7 +129,7 @@
- int most = 0;
-
- for (cur=iif; cur!=NULL; cur = IN_NEXT(cur)) {
-- most = max(most,NEW_ORG_RECV(cur));
-+ most = MAX(most,NEW_ORG_RECV(cur));
- }
- return most;
- }
-diff -urN ns-2.27.orig/diffusion3/lib/nr/nr.hh ns-2.27/diffusion3/lib/nr/nr.hh
---- ns-2.27.orig/diffusion3/lib/nr/nr.hh 2004-01-12 19:58:05.000000000 -0500
-+++ ns-2.27/diffusion3/lib/nr/nr.hh 2005-01-22 21:41:36.579976264 -0500
-@@ -43,7 +43,8 @@
- typedef signed int int32_t;
- #endif
- typedef signed short int16_t;
--#if defined (sparc)
-+// #if defined (sparc)
-+#if defined (__SVR4) && defined (__sun)
- typedef char int8_t;
- #else
- // Conflicts with system declaration of int8_t in Solaris
diff --git a/net-analyzer/ns/files/ns-2.29-gcc41.patch b/net-analyzer/ns/files/ns-2.29-gcc41.patch
deleted file mode 100644
index dbe7c01e4e30..000000000000
--- a/net-analyzer/ns/files/ns-2.29-gcc41.patch
+++ /dev/null
@@ -1,113 +0,0 @@
---- sctp/sctp.h.orig 2006-06-16 16:41:37.000000000 -0400
-+++ sctp/sctp.h 2006-06-16 16:42:04.000000000 -0400
-@@ -702,7 +702,7 @@
-
- /* debugging functions
- */
-- void SctpAgent::DumpSendBuffer();
-+ void DumpSendBuffer();
-
- /* sctp association state variable
- */
---- ./mobile/god.h.orig 2006-06-16 16:43:19.000000000 -0400
-+++ ./mobile/god.h 2006-06-16 16:43:41.000000000 -0400
-@@ -85,20 +85,20 @@
- return sqrt(X*X + Y*Y + Z*Z);
- }
-
-- inline void vector::operator=(const vector a) {
-+ inline void operator=(const vector a) {
- X = a.X;
- Y = a.Y;
- Z = a.Z;
- }
-- inline void vector::operator+=(const vector a) {
-+ inline void operator+=(const vector a) {
- X += a.X;
- Y += a.Y;
- Z += a.Z;
- }
-- inline int vector::operator==(const vector a) {
-+ inline int operator==(const vector a) {
- return (X == a.X && Y == a.Y && Z == a.Z);
- }
-- inline int vector::operator!=(const vector a) {
-+ inline int operator!=(const vector a) {
- return (X != a.X || Y != a.Y || Z != a.Z);
- }
- inline vector operator-(const vector a) {
---- dsr/dsragent.h.orig 2006-06-16 17:04:40.000000000 -0400
-+++ dsr/dsragent.h 2006-06-16 17:05:47.000000000 -0400
-@@ -284,4 +284,7 @@
- static DSRAgent_List agthead;
- };
-
-+void XmitFlowFailureCallback(Packet *pkt, void *data);
-+void XmitFailureCallback(Packet *pkt, void *data);
-+
- #endif // _DSRAgent_h
---- diffusion/diffusion.h.orig 2006-06-16 17:08:27.000000000 -0400
-+++ diffusion/diffusion.h 2006-06-16 17:08:45.000000000 -0400
-@@ -208,6 +208,8 @@
- friend class SendBufTimer;
- };
-
-+void XmitFailedCallback(Packet *pkt, void *data);
-+
- #endif
-
-
---- diffusion/omni_mcast.h.orig 2006-06-16 17:10:46.000000000 -0400
-+++ diffusion/omni_mcast.h 2006-06-16 17:11:00.000000000 -0400
-@@ -225,6 +225,7 @@
-
- };
-
-+void OmniMcastXmitFailedCallback(Packet *pkt, void *data);
-
-
- #endif
---- tcp/tcp-sack-rh.cc.orig 2006-06-16 17:11:33.000000000 -0400
-+++ tcp/tcp-sack-rh.cc 2006-06-16 17:11:45.000000000 -0400
-@@ -65,7 +65,7 @@
- virtual void estadjust();
- virtual void rhclear();
- virtual void computefack();
-- virtual void SackRHTcpAgent::newack(Packet* pkt);
-+ virtual void newack(Packet* pkt);
- protected:
- int fack_; /* the FACK state variable */
- int retran_data_; /* the number of retransmitted packets in the pipe */
---- pgm/pgm-agent.cc.orig 2006-06-16 17:12:44.000000000 -0400
-+++ pgm/pgm-agent.cc 2006-06-16 17:12:56.000000000 -0400
-@@ -304,7 +304,7 @@
-
- void print_stats();
-
-- void PgmAgent::trace_event(char *evType, double evTime);
-+ void trace_event(char *evType, double evTime);
-
- #ifdef PGM_DEBUG
- void display_packet(Packet *pkt);
---- pgm/pgm-sender.cc.orig 2006-06-16 17:13:32.000000000 -0400
-+++ pgm/pgm-sender.cc 2006-06-16 17:13:41.000000000 -0400
-@@ -186,7 +186,7 @@
-
- void display_packet(Packet *pkt); // For debugging.
-
-- void PgmSender::trace_event(char *evType, nsaddr_t daddr, double evTime);
-+ void trace_event(char *evType, nsaddr_t daddr, double evTime);
-
- EventTrace * et_; //Trace Object for custom Event Traces
-
---- pgm/pgm-receiver.cc.orig 2006-06-16 17:14:37.000000000 -0400
-+++ pgm/pgm-receiver.cc 2006-06-16 17:14:52.000000000 -0400
-@@ -183,7 +183,7 @@
- void print_stats();
- void display_packet(Packet *pkt); // For debugging.
-
-- void PgmReceiver::trace_event(char *evType, double evTime);
-+ void trace_event(char *evType, double evTime);
-
- EventTrace * et_; //Trace Object for Custom Event Trace
-
diff --git a/net-analyzer/ns/ns-2.29.ebuild b/net-analyzer/ns/ns-2.29.ebuild
deleted file mode 100644
index b2fff39c5f21..000000000000
--- a/net-analyzer/ns/ns-2.29.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.29.ebuild,v 1.3 2008/09/03 07:33:13 opfer Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="Network Simulator"
-HOMEPAGE="http://www.isi.edu/nsnam/ns/"
-SRC_URI="http://www.isi.edu/nsnam/dist/${PN}-src-${PV}.tar.gz"
-
-LICENSE="BSD as-is"
-SLOT="0"
-KEYWORDS="~ppc ~sparc ~x86 ~amd64"
-IUSE="doc debug"
-
-RDEPEND=">=dev-lang/tcl-8.4.5
- >=dev-lang/tk-8.4.5
- >=dev-tcltk/otcl-1.11
- >=dev-tcltk/tclcl-1.17
- virtual/libpcap
- debug? ( =dev-lang/perl-5*
- >=sci-visualization/xgraph-12.1
- >=dev-libs/dmalloc-4.8.2
- >=dev-tcltk/tcl-debug-2.0 )"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- virtual/ghostscript
- dev-tex/latex2html )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-# epatch ${FILESDIR}/${P}-gentoo.diff
- epatch "${FILESDIR}/${P}-gcc41.patch"
- sed '/$(CC)/s!-g!$(CFLAGS)!g' ${S}/indep-utils/model-gen/Makefile
-}
-
-src_compile() {
- local myconf
- local mytclver=""
- local i
-
- tc-export CC CXX
-
- # correctness is more important than speed
- replace-flags -Os -O2
- replace-flags -O3 -O2
-
- use debug \
- && myconf="${myconf} --with-tcldebug=/usr/lib/tcldbg2.0" \
- || myconf="${myconf} --with-tcldebug=no"
- myconf="${myconf} $(use_with debug dmalloc)"
-
- for i in 8.4 ; do
- einfo "Testing TCL ${i}"
- has_version "=dev-lang/tcl-${i}*" && mytclver=${i}
- [ "${#mytclver}" -gt 2 ] && break
- done
- einfo "Using TCL ${mytclver}"
- myconf="${myconf} --with-tcl-ver=${mytclver} --with-tk-ver=${mytclver}"
-
- econf \
- ${myconf} \
- --mandir=/usr/share/man \
- --enable-stl \
- --enable-release || die "./configure failed"
- emake CCOPT="${CFLAGS}" || die
-
- cd ${S}/indep-utils/dosdbell
- emake DFLAGS="${CFLAGS}" || die
- cd ${S}/indep-utils/dosreduce
- ${CC} ${CFLAGS} dosreduce.c -o dosreduce
- cd ${S}/indep-utils/propagation
- ${CXX} ${CXXFLAGS} threshold.cc -o threshold
- cd ${S}/indep-utils/model-gen
- emake CFLAGS="${CFLAGS}" || die
-
- if useq doc; then
- einfo "Generating extra docs"
- cd ${S}/doc
- yes '' | emake all
- fi
-}
-
-src_install() {
- dodir /usr/bin /usr/share/man/man1 /usr/share/doc/${PF} /usr/share/ns
- make DESTDIR="${D}" MANDEST=/usr/share/man install \
- || die "make install failed"
- dobin nse
-
- dodoc BASE-VERSION COPYRIGHTS FILES HOWTO-CONTRIBUTE README VERSION
- dohtml CHANGES.html TODO.html
-
- cd "${S}"
- insinto /usr/share/doc/${PF}
- doins -r ns-tutorial
- insinto /usr/share/ns
- doins -r tcl
-
- cd "${S}/indep-utils/dosdbell"
- dobin dosdbell dosdbellasim
- newdoc README README.dosdbell
- cd "${S}/indep-utils/dosreduce"
- dobin dosreduce
- newdoc README README.dosreduce
- cd "${S}/indep-utils/cmu-scen-gen"
- dobin cbrgen.tcl
- newdoc README README.cbrgen
- cd "${S}/indep-utils/propagation"
- dobin threshold
- cd "${S}/indep-utils/model-gen"
- dobin http_connect http_active
-
- if use doc; then
- cd ${S}/doc
- docinto doc
- dodoc everything.dvi everything.ps.gz everything.html everything.pdf
- docinto model-gen
- cd ${S}/indep-utils/model-gen
- dodoc *
- fi
-}
-
-src_test() {
- einfo "Warning, these tests will take upwards of 45 minutes."
- einfo "Additionally, as shipped, a number of tests may fail."
- einfo "We log to 'validate.run', which you should compare against"
- einfo "the shipped 'validate.out' to evaluate success."
- einfo "At the time of assembling this ebuild, these test suites failed:"
- einfo "all-smac-multihop all-red all-plm all-wireless-tdma"
- ./validate 2>&1 | tee ${S}/validate.run
-}
diff --git a/net-analyzer/ns/ns-2.31.ebuild b/net-analyzer/ns/ns-2.31.ebuild
index d5c77b820287..38892f70fefd 100644
--- a/net-analyzer/ns/ns-2.31.ebuild
+++ b/net-analyzer/ns/ns-2.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.31.ebuild,v 1.3 2008/09/03 07:33:13 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.31.ebuild,v 1.4 2008/09/03 07:36:41 opfer Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
dev-tex/latex2html )"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
sed '/$(CC)/s!-g!$(CFLAGS)!g' "${S}/indep-utils/model-gen/Makefile"
}