summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-15 00:29:43 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-15 00:29:43 +0000
commitcfa52d5186fcbd263ef33bab5ce95b0e6595ac4a (patch)
treec271904d73a8fa318877e015d8922282faf752b5 /net-analyzer/ippl
parentRespect LDFLAGS (bug #337024), CC. (diff)
downloadgentoo-2-cfa52d5186fcbd263ef33bab5ce95b0e6595ac4a.tar.gz
gentoo-2-cfa52d5186fcbd263ef33bab5ce95b0e6595ac4a.tar.bz2
gentoo-2-cfa52d5186fcbd263ef33bab5ce95b0e6595ac4a.zip
Respect LDFLAGS (bug #337192), CC. Fix missing includes. Use $(MAKE) instead of make.
(Portage version: 2.2_rc81/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/ippl')
-rw-r--r--net-analyzer/ippl/ChangeLog11
-rw-r--r--net-analyzer/ippl/files/ippl-1.4.14-includes.patch20
-rw-r--r--net-analyzer/ippl/ippl-1.4.14-r2.ebuild52
-rw-r--r--net-analyzer/ippl/ippl-1.4.14.ebuild30
4 files changed, 81 insertions, 32 deletions
diff --git a/net-analyzer/ippl/ChangeLog b/net-analyzer/ippl/ChangeLog
index 59fde6ccf1be..fc01c4d20e6e 100644
--- a/net-analyzer/ippl/ChangeLog
+++ b/net-analyzer/ippl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ippl
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ChangeLog,v 1.16 2008/11/17 21:50:21 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ChangeLog,v 1.17 2010/09/15 00:29:43 jer Exp $
+
+*ippl-1.4.14-r2 (15 Sep 2010)
+
+ 15 Sep 2010; Jeroen Roovers <jer@gentoo.org> -ippl-1.4.14.ebuild,
+ +ippl-1.4.14-r2.ebuild, +files/ippl-1.4.14-includes.patch:
+ Respect LDFLAGS (bug #337192), CC. Fix missing includes. Use $(MAKE)
+ instead of make.
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
files/ippl-1.4.14-manpage.patch:
diff --git a/net-analyzer/ippl/files/ippl-1.4.14-includes.patch b/net-analyzer/ippl/files/ippl-1.4.14-includes.patch
new file mode 100644
index 000000000000..d1883ee0883a
--- /dev/null
+++ b/net-analyzer/ippl/files/ippl-1.4.14-includes.patch
@@ -0,0 +1,20 @@
+--- a/Source/filter.c 2010-09-15 02:17:55.000000000 +0200
++++ b/Source/filter.c 2010-09-15 02:23:46.000000000 +0200
+@@ -22,6 +22,7 @@
+
+ #include <stdlib.h>
+ #include <ctype.h>
++#include <string.h> /* memcpy() */
+
+ #include <fnmatch.h>
+
+--- a/Source/main.c 2010-09-15 02:17:56.000000000 +0200
++++ b/Source/main.c 2010-09-15 02:24:00.000000000 +0200
+@@ -37,6 +37,7 @@
+ #include <pwd.h>
+ #include <stdlib.h>
+ #include <getopt.h>
++#include <grp.h> /* initgroups() */
+
+ #include "defines.h"
+ #include "configuration.h"
diff --git a/net-analyzer/ippl/ippl-1.4.14-r2.ebuild b/net-analyzer/ippl/ippl-1.4.14-r2.ebuild
new file mode 100644
index 000000000000..bda7fbfe3cdd
--- /dev/null
+++ b/net-analyzer/ippl/ippl-1.4.14-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ippl-1.4.14-r2.ebuild,v 1.1 2010/09/15 00:29:43 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A daemon which logs TCP/UDP/ICMP packets"
+HOMEPAGE="http://pltplp.net/ippl/"
+SRC_URI="http://pltplp.net/ippl/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="|| ( sys-devel/bison >=dev-util/yacc-1.9.1-r1 )
+ >=sys-devel/flex-2.5.4a-r4"
+RDEPEND=""
+
+pkg_setup() {
+ enewuser ippl
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/ippl-1.4.14-noportresolve.patch \
+ "${FILESDIR}"/ippl-1.4.14-manpage.patch \
+ "${FILESDIR}"/ippl-1.4.14-privilege-drop.patch \
+ "${FILESDIR}"/ippl-1.4.14-includes.patch
+ sed -i Source/Makefile.in \
+ -e 's|^LDFLAGS=|&@LDFLAGS@|g' \
+ || die "sed Source/Makefile.in"
+ sed -i Makefile.in \
+ -e 's|make |$(MAKE) |g' \
+ || die "sed Makefile.in"
+ tc-export CC
+}
+
+src_install() {
+ dosbin Source/ippl
+
+ insinto "/etc"
+ doins ippl.conf
+
+ doman Docs/{ippl.8,ippl.conf.5}
+
+ dodoc BUGS CREDITS HISTORY README TODO
+
+ newinitd "${FILESDIR}"/ippl.rc ippl
+}
diff --git a/net-analyzer/ippl/ippl-1.4.14.ebuild b/net-analyzer/ippl/ippl-1.4.14.ebuild
deleted file mode 100644
index b2491acf798b..000000000000
--- a/net-analyzer/ippl/ippl-1.4.14.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ippl/ippl-1.4.14.ebuild,v 1.11 2007/04/28 12:35:52 tove Exp $
-
-DESCRIPTION="A daemon which logs TCP/UDP/ICMP packets"
-HOMEPAGE="http://pltplp.net/ippl/"
-SRC_URI="http://pltplp.net/ippl/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-DEPEND=">=dev-util/yacc-1.9.1-r1
- >=sys-devel/flex-2.5.4a-r4"
-RDEPEND=""
-
-src_install() {
- dosbin Source/ippl
-
- insinto "/etc"
- doins ippl.conf
-
- doman Docs/ippl.8 Docs/ippl.conf.5
-
- dodoc BUGS CREDITS HISTORY README TODO
- newdoc ippl.conf ippl.conf-sample
-
- newinitd "${FILESDIR}"/ippl.rc ippl
-}