summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-15 16:05:45 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-15 16:05:45 +0000
commitc955bf3fc9c846daf2554fca42afdca110f72a1e (patch)
tree0cb068860d198fb03d6128167aa9414ec1949402 /net-analyzer/hydra
parentx86 stable wrt security bug #339401 (diff)
downloadgentoo-2-c955bf3fc9c846daf2554fca42afdca110f72a1e.tar.gz
gentoo-2-c955bf3fc9c846daf2554fca42afdca110f72a1e.tar.bz2
gentoo-2-c955bf3fc9c846daf2554fca42afdca110f72a1e.zip
Version bump by Anton Bolshakov (bug #341099).
(Portage version: 2.2_rc96/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/hydra')
-rw-r--r--net-analyzer/hydra/ChangeLog7
-rw-r--r--net-analyzer/hydra/hydra-5.8.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/net-analyzer/hydra/ChangeLog b/net-analyzer/hydra/ChangeLog
index c8866cf63573..75f1e1c2be39 100644
--- a/net-analyzer/hydra/ChangeLog
+++ b/net-analyzer/hydra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/hydra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.38 2010/08/22 21:57:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.39 2010/10/15 16:05:45 jer Exp $
+
+*hydra-5.8 (15 Oct 2010)
+
+ 15 Oct 2010; Jeroen Roovers <jer@gentoo.org> +hydra-5.8.ebuild:
+ Version bump by Anton Bolshakov (bug #341099).
*hydra-5.7 (22 Aug 2010)
diff --git a/net-analyzer/hydra/hydra-5.8.ebuild b/net-analyzer/hydra/hydra-5.8.ebuild
new file mode 100644
index 000000000000..0426b7131c75
--- /dev/null
+++ b/net-analyzer/hydra/hydra-5.8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/hydra-5.8.ebuild,v 1.1 2010/10/15 16:05:45 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Advanced parallized login hacker"
+HOMEPAGE="http://www.thc.org/thc-hydra/"
+SRC_URI="http://freeworld.thc.org/releases/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk ssl"
+
+DEPEND="
+ dev-libs/openssl
+ gtk? ( >=x11-libs/gtk+-1.2 )
+ ssl? ( >=net-libs/libssh-0.4.0 )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ # None of the settings in Makefile.unix are useful to us
+ : > Makefile.unix
+
+ sed -i \
+ -e 's:-O2:$(CPPFLAGS) $(CFLAGS):g' \
+ -e 's:|| echo.*$::' \
+ -e '/\t-$(CC)/s/-//' \
+ -e '/ -o /s:$(OPTS):& $(LDFLAGS):g' \
+ Makefile.am || die "sed failed"
+}
+
+src_configure() {
+ # Note: despite the naming convention, the top level script is not an
+ # autoconf-based script.
+ ./configure \
+ --prefix=/usr \
+ $(use gtk && echo --disable-xhydra) \
+ || die "configure failed"
+
+ sed -i \
+ -e '/^XDEFINES=/s:=.*:=:' \
+ -e '/^XLIBS=/s:=.*:=-lcrypto:' \
+ -e '/^XLIBPATHS/s:=.*:=:' \
+ -e '/^XIPATHS=/s:=.*:=:' \
+ Makefile || die "pruning vars"
+
+ if use ssl ; then
+ sed -i \
+ -e '/^XDEFINES=/s:=:=-DLIBOPENSSL -DLIBSSH:' \
+ -e '/^XLIBS=/s:$: -lssl -lssh:' \
+ Makefile || die "adding ssl"
+ fi
+
+ if use gtk ; then
+ cd hydra-gtk && \
+ econf || die "econf failed"
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "make failed"
+ if use gtk ; then
+ cd hydra-gtk && \
+ emake || die "emake hydra-gtk failed"
+ fi
+}
+
+src_install() {
+ dobin hydra pw-inspector || die "dobin failed"
+ if use gtk ; then
+ dobin hydra-gtk/src/xhydra || die "gtk"
+ fi
+ dodoc CHANGES README TODO
+}