summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-07-01 17:20:31 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-07-01 17:20:31 +0000
commit9d1548af745c080e048f621ba436fca7e07031b9 (patch)
treeacfd573fb248257c75aa0c8e2bc53ce2c0829dc9 /net-analyzer/fwlogwatch
parentFix for JAVA_PKG_FORCE_COMPILER. exports JAVA and JAVAC now. (diff)
downloadgentoo-2-9d1548af745c080e048f621ba436fca7e07031b9.tar.gz
gentoo-2-9d1548af745c080e048f621ba436fca7e07031b9.tar.bz2
gentoo-2-9d1548af745c080e048f621ba436fca7e07031b9.zip
1.1 version bump for bug 138734. Thanks to Taku Murakami <murakami.taku at gmail dot com>. Also using tc-getCC instead of gcc hardcoded by Makefile.
(Portage version: 2.1-r1)
Diffstat (limited to 'net-analyzer/fwlogwatch')
-rw-r--r--net-analyzer/fwlogwatch/ChangeLog8
-rw-r--r--net-analyzer/fwlogwatch/files/digest-fwlogwatch-1.13
-rw-r--r--net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild51
3 files changed, 61 insertions, 1 deletions
diff --git a/net-analyzer/fwlogwatch/ChangeLog b/net-analyzer/fwlogwatch/ChangeLog
index 554e5902a963..545d7d6214c4 100644
--- a/net-analyzer/fwlogwatch/ChangeLog
+++ b/net-analyzer/fwlogwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/fwlogwatch
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fwlogwatch/ChangeLog,v 1.13 2006/03/01 17:01:41 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fwlogwatch/ChangeLog,v 1.14 2006/07/01 17:20:31 vanquirius Exp $
+
+*fwlogwatch-1.1 (01 Jul 2006)
+
+ 01 Jul 2006; Marcelo Goes <vanquirius@gentoo.org> +fwlogwatch-1.1.ebuild:
+ 1.1 version bump for bug 138734. Thanks to Taku Murakami <murakami.taku at
+ gmail dot com>. Also using tc-getCC instead of gcc hardcoded by Makefile.
01 Mar 2006; Marcelo Goes <vanquirius@gentoo.org>
-fwlogwatch-0.9.3.ebuild, fwlogwatch-1.0.ebuild:
diff --git a/net-analyzer/fwlogwatch/files/digest-fwlogwatch-1.1 b/net-analyzer/fwlogwatch/files/digest-fwlogwatch-1.1
new file mode 100644
index 000000000000..1394b150f36b
--- /dev/null
+++ b/net-analyzer/fwlogwatch/files/digest-fwlogwatch-1.1
@@ -0,0 +1,3 @@
+MD5 266974c417a7b973d3e54b64f95e9536 fwlogwatch-1.1.tar.bz2 90341
+RMD160 e1f4d979cfa71de64918bc2a07869f05288f80d3 fwlogwatch-1.1.tar.bz2 90341
+SHA256 9908ef51f79aa069b31851e23550d5bfacb4583fc3569f87ad1a0957c974ba7f fwlogwatch-1.1.tar.bz2 90341
diff --git a/net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild b/net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild
new file mode 100644
index 000000000000..a1f17c648823
--- /dev/null
+++ b/net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild,v 1.1 2006/07/01 17:20:31 vanquirius Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A packet filter and firewall log analyzer"
+HOMEPAGE="http://fwlogwatch.inside-security.de/"
+SRC_URI="http://www.kybs.de/boris/sw/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/^CFLAGS = /CFLAGS = ${CFLAGS} /g" Makefile || \
+ die "sed Makefile failed"
+
+ sed -i -e "s:gcc:$(tc-getCC):g" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dosbin fwlogwatch
+ dosbin contrib/fwlw_notify
+ dosbin contrib/fwlw_respond
+ dodir /usr/share/fwlogwatch/contrib
+ insinto /usr/share/fwlogwatch/contrib
+
+ doins contrib/fwlogsummary.cgi
+ doins contrib/fwlogsummary_small.cgi
+ doins contrib/fwlogwatch.php
+ doins contrib
+ insinto /etc
+
+ doins fwlogwatch.config fwlogwatch.template
+
+ dodoc AUTHORS ChangeLog CREDITS README
+ doman fwlogwatch.8
+}