summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2013-10-19 14:25:26 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2013-10-19 14:25:26 +0000
commit7c2228cbfc078e152f3af8762bfb1a7d3c235fd8 (patch)
treecb784f32e55b968fa725ca9bb9a2d482107e5ab8 /media-sound/rgain
parentDrop old (diff)
downloadgentoo-2-7c2228cbfc078e152f3af8762bfb1a7d3c235fd8.tar.gz
gentoo-2-7c2228cbfc078e152f3af8762bfb1a7d3c235fd8.tar.bz2
gentoo-2-7c2228cbfc078e152f3af8762bfb1a7d3c235fd8.zip
Version bump to 1.2.1, migrate to EAPI 5, add use flags (#488528)
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 7B087241)
Diffstat (limited to 'media-sound/rgain')
-rw-r--r--media-sound/rgain/ChangeLog10
-rw-r--r--media-sound/rgain/rgain-1.0.1.ebuild24
-rw-r--r--media-sound/rgain/rgain-1.2.1.ebuild34
3 files changed, 42 insertions, 26 deletions
diff --git a/media-sound/rgain/ChangeLog b/media-sound/rgain/ChangeLog
index 9a4e2562004e..40cb183d617b 100644
--- a/media-sound/rgain/ChangeLog
+++ b/media-sound/rgain/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/rgain
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rgain/ChangeLog,v 1.6 2012/10/25 20:37:48 eva Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rgain/ChangeLog,v 1.7 2013/10/19 14:25:25 sochotnicky Exp $
+
+*rgain-1.2.1 (19 Oct 2013)
+
+ 19 Oct 2013; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ -rgain-1.0.1.ebuild, +rgain-1.2.1.ebuild:
+ Version bump to 1.2.1, migrate to EAPI 5, add use flags (#488528)
25 Oct 2012; Gilles Dartiguelongue <eva@gentoo.org> rgain-1.0.1.ebuild,
rgain-1.0.2.ebuild:
diff --git a/media-sound/rgain/rgain-1.0.1.ebuild b/media-sound/rgain/rgain-1.0.1.ebuild
deleted file mode 100644
index 0847f983d3bc..000000000000
--- a/media-sound/rgain/rgain-1.0.1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rgain/rgain-1.0.1.ebuild,v 1.4 2012/10/25 20:37:48 eva Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Set of programmes and Python modules to deal with Replay Gain information"
-HOMEPAGE="http://bitbucket.org/fk/rgain"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="media-libs/mutagen
- dev-python/gst-python:0.10"
diff --git a/media-sound/rgain/rgain-1.2.1.ebuild b/media-sound/rgain/rgain-1.2.1.ebuild
new file mode 100644
index 000000000000..8a52ba35c01c
--- /dev/null
+++ b/media-sound/rgain/rgain-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rgain/rgain-1.2.1.ebuild,v 1.1 2013/10/19 14:25:25 sochotnicky Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of programmes and Python modules to deal with Replay Gain information"
+HOMEPAGE="http://bitbucket.org/fk/rgain"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac mp3 vorbis wavpack"
+
+DEPEND=">=dev-python/docutils-0.9"
+RDEPEND="media-libs/mutagen
+ dev-python/pygobject:3[$PYTHON_USEDEP]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-base:1.0[vorbis?]
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ mp3? ( media-plugins/gst-plugins-mad:1.0 )
+ wavpack? ( media-plugins/gst-plugins-wavpack:1.0 )
+"
+
+src_install() {
+ distutils-r1_src_install
+ doman build/man/*
+}