summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-11-22 16:43:48 +0000
committerPacho Ramos <pacho@gentoo.org>2014-11-22 16:43:48 +0000
commit439a3de893479f8a4cad362bb16edc3324ddb71e (patch)
tree29bdef5399b064ca3d2a6754d8ec6ea74b3109b5 /media-sound/gnaural
parentBump to eapi5, fix .desktop file and respect LINGUAS (diff)
downloadgentoo-2-439a3de893479f8a4cad362bb16edc3324ddb71e.tar.gz
gentoo-2-439a3de893479f8a4cad362bb16edc3324ddb71e.tar.bz2
gentoo-2-439a3de893479f8a4cad362bb16edc3324ddb71e.zip
Set proper dependencies for gtk+ and glib slots (otherwise people will get latest gtk3 instead of slot2), really use gnome2.eclass instead of only phases that were exported by default, prevent future breakage due configure.in becoming not supported soon.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-sound/gnaural')
-rw-r--r--media-sound/gnaural/ChangeLog10
-rw-r--r--media-sound/gnaural/gnaural-1.0.20110606.ebuild27
2 files changed, 24 insertions, 13 deletions
diff --git a/media-sound/gnaural/ChangeLog b/media-sound/gnaural/ChangeLog
index 93f6cb507377..7d94875d2f4d 100644
--- a/media-sound/gnaural/ChangeLog
+++ b/media-sound/gnaural/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/gnaural
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnaural/ChangeLog,v 1.3 2013/08/07 13:27:15 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnaural/ChangeLog,v 1.4 2014/11/22 16:43:48 pacho Exp $
+
+ 22 Nov 2014; Pacho Ramos <pacho@gentoo.org> gnaural-1.0.20110606.ebuild:
+ Set proper dependencies for gtk+ and glib slots (otherwise people will get
+ latest gtk3 instead of slot2), really use gnome2.eclass instead of only phases
+ that were exported by default, prevent future breakage due configure.in
+ becoming not supported soon.
07 Aug 2013; Agostino Sarubbo <ago@gentoo.org> gnaural-1.0.20110606.ebuild:
Stable for x86, wrt bug #477094
diff --git a/media-sound/gnaural/gnaural-1.0.20110606.ebuild b/media-sound/gnaural/gnaural-1.0.20110606.ebuild
index 8093db088c7f..c01b797c0eba 100644
--- a/media-sound/gnaural/gnaural-1.0.20110606.ebuild
+++ b/media-sound/gnaural/gnaural-1.0.20110606.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnaural/gnaural-1.0.20110606.ebuild,v 1.3 2013/08/07 13:27:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnaural/gnaural-1.0.20110606.ebuild,v 1.4 2014/11/22 16:43:48 pacho Exp $
-EAPI=2
+EAPI=5
+GCONF_DEBUG="no"
inherit autotools gnome2
@@ -16,25 +17,29 @@ KEYWORDS="amd64 x86"
IUSE="nls"
RDEPEND="
- >=x11-libs/gtk+-2
+ >=x11-libs/gtk+-2:2
>=gnome-base/libglade-2
- >=dev-libs/glib-2
+ >=dev-libs/glib-2:2
>=media-libs/libsndfile-1.0.2
- >=media-libs/portaudio-19_pre20071207"
-
-DEPEND="
- ${RDEPEND}
+ >=media-libs/portaudio-19_pre20071207
+"
+DEPEND="${RDEPEND}
nls? ( dev-util/intltool )
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
src_prepare() {
+ mv configure.in configure.ac || die #426262
+
# Install desktop file into xdg compliant location
sed -i -e 's@/gnome/apps/Multimedia@/applications@g' \
Makefile.am || die "Failed to sed Makefile.am"
eautoreconf
+ gnome2_src_prepare
}
src_configure() {
- econf $(use_enable nls)
+ gnome2_src_configure \
+ $(use_enable nls)
}