summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-23 08:15:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-23 08:15:50 +0000
commit3bf607169bc4b0850aa6f79a8df7b8679a102c63 (patch)
tree887951b16fef2fabbc2bd7e38aacc6fa04f2d171 /media-sound/ezstream
parentp.masked, and just found out it doesn't even work (diff)
downloadgentoo-2-3bf607169bc4b0850aa6f79a8df7b8679a102c63.tar.gz
gentoo-2-3bf607169bc4b0850aa6f79a8df7b8679a102c63.tar.bz2
gentoo-2-3bf607169bc4b0850aa6f79a8df7b8679a102c63.zip
conf.d and init.d files wrt #199602, thanks to Yoann LE TOUCHE.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ezstream')
-rw-r--r--media-sound/ezstream/ChangeLog8
-rw-r--r--media-sound/ezstream/ezstream-0.5.3.ebuild20
-rw-r--r--media-sound/ezstream/files/ezstream.confd5
-rw-r--r--media-sound/ezstream/files/ezstream.initd33
4 files changed, 57 insertions, 9 deletions
diff --git a/media-sound/ezstream/ChangeLog b/media-sound/ezstream/ChangeLog
index ff18f6967214..1befc75c6a75 100644
--- a/media-sound/ezstream/ChangeLog
+++ b/media-sound/ezstream/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/ezstream
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ezstream/ChangeLog,v 1.8 2008/01/13 18:49:03 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ezstream/ChangeLog,v 1.9 2009/07/23 08:15:50 ssuominen Exp $
+
+ 23 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> ezstream-0.5.3.ebuild,
+ +files/ezstream.confd, +files/ezstream.initd:
+ conf.d and init.d files wrt #199602, thanks to Yoann LE TOUCHE.
13 Jan 2008; Alexis Ballier <aballier@gentoo.org> ezstream-0.5.3.ebuild:
add missing pkconfig dep, bug #205665
diff --git a/media-sound/ezstream/ezstream-0.5.3.ebuild b/media-sound/ezstream/ezstream-0.5.3.ebuild
index af1bf41d55d7..fe819a660f01 100644
--- a/media-sound/ezstream/ezstream-0.5.3.ebuild
+++ b/media-sound/ezstream/ezstream-0.5.3.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ezstream/ezstream-0.5.3.ebuild,v 1.2 2008/01/13 18:49:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ezstream/ezstream-0.5.3.ebuild,v 1.3 2009/07/23 08:15:50 ssuominen Exp $
+
+EAPI=2
+inherit eutils
DESCRIPTION="Enables you to stream mp3 or vorbis files to an icecast server without reencoding"
HOMEPAGE="http://www.icecast.org/ezstream.php"
@@ -22,14 +25,17 @@ RDEPEND="${COMMON_DEPEND}
DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
-src_compile() {
- econf --enable-examplesdir="/usr/share/doc/${PF}/examples" \
- --docdir="/usr/share/doc/${PF}" $(use_with taglib)
- emake || die "emake failed."
+src_configure() {
+ econf \
+ --enable-examplesdir=/usr/share/doc/${PF}/examples \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with taglib)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "newinitd failed"
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
rm -f "${D}"/usr/share/doc/${PF}/COPYING
dodoc ChangeLog
prepalldocs
diff --git a/media-sound/ezstream/files/ezstream.confd b/media-sound/ezstream/files/ezstream.confd
new file mode 100644
index 000000000000..6480e0c7a71f
--- /dev/null
+++ b/media-sound/ezstream/files/ezstream.confd
@@ -0,0 +1,5 @@
+# Config location
+CONFIGFILE=""
+
+# Options
+EZSTREAM_OPTS=""
diff --git a/media-sound/ezstream/files/ezstream.initd b/media-sound/ezstream/files/ezstream.initd
new file mode 100644
index 000000000000..a5c0d56514c5
--- /dev/null
+++ b/media-sound/ezstream/files/ezstream.initd
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+
+depend() {
+ need icecast
+}
+
+checkconfig() {
+ if [ ! -e ${CONFIGFILE} ]; then
+ eerror "You need to make a config file"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ezstream"
+ start-stop-daemon --background --start --pidfile /var/run/ezstream.pid \
+ --make-pidfile --user icecast --group nogroup \
+ --exec /usr/bin/ezstream -- ${EZSTREAM_OPTS} -c "${CONFIGFILE}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ezstream"
+ start-stop-daemon --stop --pidfile /var/run/ezstream.pid --name ezstream
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ezstream"
+ kill -1 `cat /var/run/ezstream.pid`
+ eend $?
+}