summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-09-24 17:52:16 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-09-24 17:52:16 +0000
commit58bbdf0470d323312f4d9c8104ab5ce4c55f0916 (patch)
treedd12d307c563d191fcba810cf02fd2af081a97d3 /media-radio
parentVersion bump (diff)
downloadgentoo-2-58bbdf0470d323312f4d9c8104ab5ce4c55f0916.tar.gz
gentoo-2-58bbdf0470d323312f4d9c8104ab5ce4c55f0916.tar.bz2
gentoo-2-58bbdf0470d323312f4d9c8104ab5ce4c55f0916.zip
Fix for bug #337365 (Thanks Diego for reporting) and fix installdir for doc files
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xastir/ChangeLog9
-rw-r--r--media-radio/xastir/files/xastir-1.9.8-fortify.diff141
-rw-r--r--media-radio/xastir/xastir-1.9.8-r1.ebuild79
3 files changed, 228 insertions, 1 deletions
diff --git a/media-radio/xastir/ChangeLog b/media-radio/xastir/ChangeLog
index 71ceff0e1584..87242e3a2935 100644
--- a/media-radio/xastir/ChangeLog
+++ b/media-radio/xastir/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-radio/xastir
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.13 2010/07/17 09:41:43 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.14 2010/09/24 17:52:16 tomjbe Exp $
+
+*xastir-1.9.8-r1 (24 Sep 2010)
+
+ 24 Sep 2010; Thomas Beierlein <tomjbe@gentoo.org> +xastir-1.9.8-r1.ebuild,
+ +files/xastir-1.9.8-fortify.diff:
+ Fix for bug #337365 (Thanks Diego for reporting) and fix installdir for
+ doc files
17 Jul 2010; Christian Faulhammer <fauli@gentoo.org> xastir-1.9.8.ebuild:
stable x86, bug 328067
diff --git a/media-radio/xastir/files/xastir-1.9.8-fortify.diff b/media-radio/xastir/files/xastir-1.9.8-fortify.diff
new file mode 100644
index 000000000000..b9fb4a9f38a5
--- /dev/null
+++ b/media-radio/xastir/files/xastir-1.9.8-fortify.diff
@@ -0,0 +1,141 @@
+--- src/rac_data.c.orig 2010-09-24 15:43:04.000000000 +0000
++++ src/rac_data.c 2010-09-24 15:57:00.000000000 +0000
+@@ -209,12 +209,13 @@
+ char char_offset[16];
+ char index[32];
+ int found = 0;
+- rac_record racdata;
++ char buffer[sizeof(rac_record)];
++ rac_record *racdata = (rac_record *)buffer;
+ /*char filler[8];*/
+
+
+ xastir_snprintf(index, sizeof(index)," ");
+- xastir_snprintf(racdata.callsign, sizeof(racdata.callsign)," ");
++ xastir_snprintf(racdata->callsign, sizeof(racdata->callsign)," ");
+
+ /* ==================================================================== */
+ /* Search thru the index, get the RBA */
+@@ -251,19 +252,19 @@
+ if (callsign[5] == '-')
+ (void)chomp(callsign,5);
+
+- while (!feof(fdb) && strncmp((char *)&racdata, callsign, 6) < 0)
++ while (!feof(fdb) && strncmp(buffer, callsign, 6) < 0)
+
+ //WE7U
+ // Problem here: We're sticking 8 bytes too many into racdata!
+- rc = fgets((char *)&racdata, sizeof(racdata), fdb);
++ rc = fgets(buffer, sizeof(buffer), fdb);
+
+ } else
+ fprintf(stderr,"Search:Could not open RAC data base: %s\n", get_data_base_dir("fcc/AMACALL.LST") );
+
+ /* || (callsign[5] == '-' && strncmp((char *)&racdata,callsign,5) < 0)) */
+- (void)chomp(racdata.callsign, 6);
++ (void)chomp(racdata->callsign, 6);
+
+- if (!strncmp((char *)racdata.callsign, callsign, 6)) {
++ if (!strncmp(racdata->callsign, callsign, 6)) {
+ found = 1;
+
+ // Some of these cause problems on 64-bit processors, so commented
+@@ -287,82 +288,82 @@
+ xastir_snprintf(data->callsign,
+ sizeof(data->callsign),
+ "%s",
+- racdata.callsign);
++ racdata->callsign);
+
+ xastir_snprintf(data->first_name,
+ sizeof(data->first_name),
+ "%s",
+- racdata.first_name);
++ racdata->first_name);
+
+ xastir_snprintf(data->last_name,
+ sizeof(data->last_name),
+ "%s",
+- racdata.last_name);
++ racdata->last_name);
+
+ xastir_snprintf(data->address,
+ sizeof(data->address),
+ "%s",
+- racdata.address);
++ racdata->address);
+
+ xastir_snprintf(data->city,
+ sizeof(data->city),
+ "%s",
+- racdata.city);
++ racdata->city);
+
+ xastir_snprintf(data->province,
+ sizeof(data->province),
+ "%s",
+- racdata.province);
++ racdata->province);
+
+ xastir_snprintf(data->postal_code,
+ sizeof(data->postal_code),
+ "%s",
+- racdata.postal_code);
++ racdata->postal_code);
+
+ xastir_snprintf(data->qual_a,
+ sizeof(data->qual_a),
+ "%s",
+- racdata.qual_a);
++ racdata->qual_a);
+
+ xastir_snprintf(data->qual_b,
+ sizeof(data->qual_b),
+ "%s",
+- racdata.qual_b);
++ racdata->qual_b);
+
+ xastir_snprintf(data->qual_c,
+ sizeof(data->qual_c),
+ "%s",
+- racdata.qual_c);
++ racdata->qual_c);
+
+ xastir_snprintf(data->qual_d,
+ sizeof(data->qual_d),
+ "%s",
+- racdata.qual_d);
++ racdata->qual_d);
+
+ xastir_snprintf(data->club_name,
+ sizeof(data->club_name),
+ "%s",
+- racdata.club_name);
++ racdata->club_name);
+
+ xastir_snprintf(data->club_address,
+ sizeof(data->club_address),
+ "%s",
+- racdata.club_address);
++ racdata->club_address);
+
+ xastir_snprintf(data->club_city,
+ sizeof(data->club_city),
+ "%s",
+- racdata.club_city);
++ racdata->club_city);
+
+ xastir_snprintf(data->club_province,
+ sizeof(data->club_province),
+ "%s",
+- racdata.club_province);
++ racdata->club_province);
+
+ xastir_snprintf(data->club_postal_code,
+ sizeof(data->club_postal_code),
+ "%s",
+- racdata.club_postal_code);
++ racdata->club_postal_code);
+
+ }
+ (void)fclose(fdb);
diff --git a/media-radio/xastir/xastir-1.9.8-r1.ebuild b/media-radio/xastir/xastir-1.9.8-r1.ebuild
new file mode 100644
index 000000000000..06d94c6f594d
--- /dev/null
+++ b/media-radio/xastir/xastir-1.9.8-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/xastir-1.9.8-r1.ebuild,v 1.1 2010/09/24 17:52:16 tomjbe Exp $
+
+EAPI=2
+inherit autotools eutils multilib
+
+DESCRIPTION="X Amateur Station Tracking and Information Reporting"
+HOMEPAGE="http://xastir.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="festival gdal geotiff imagemagick"
+
+DEPEND="x11-libs/openmotif
+ x11-libs/libXpm
+ x11-apps/xfontsel
+ dev-libs/libpcre
+ net-misc/curl
+ sys-libs/db
+ sci-libs/shapelib
+ geotiff? ( sci-libs/proj
+ sci-libs/libgeotiff
+ media-libs/tiff )
+ gdal? ( sci-libs/gdal )
+ imagemagick? ( media-gfx/imagemagick )
+ festival? ( app-accessibility/festival )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix hardcoded /usr/local paths in scripts
+ epatch "${FILESDIR}"/${P}-scripts.diff
+ # and patch libdir
+ for f in scripts/permutations.pl scripts/test_coord.pl \
+ scripts/toporama250k.pl scripts/toporama50k.pl; do
+ sed -i -e "s:/usr/lib:/usr/$(get_libdir):g" "${f}" \
+ || die "sed failed on ${f}"
+ done
+
+ # fix __FORTIFY_SOURCE warning (bug #337365)
+ epatch "${FILESDIR}"/${P}-fortify.diff
+
+ # fix for DESTDIR
+ epatch "${FILESDIR}"/${P}-Destdir.diff
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --without-graphicsmagick \
+ --with-pcre \
+ --with-shapelib \
+ --with-dbfawk \
+ --without-ax25 \
+ --without-gpsman \
+ $(use_with geotiff libproj) \
+ $(use_with geotiff) \
+ $(use_with gdal) \
+ $(use_with imagemagick) \
+ $(use_with festival)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc AUTHORS ChangeLog FAQ README README.Contributing \
+ README.Getting-Started README.MAPS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Kernel mode AX.25 and GPSman library not supported."
+ elog
+ elog "Remember you have to be root to add addditional scripts,"
+ elog "maps and other configuration data under /usr/share/xastir"
+ elog "and /usr/$(get_libdir)/xastir."
+}