summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 03:27:43 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 03:27:43 +0000
commitc0de863211d190b942ee419266b2ae4f102ef010 (patch)
tree817f7e92bf818f4cfd1d831ccd668e6e7e76d361 /media-plugins/mythgallery
parentBump to version 0.12. Add support for alsa, lirc, and vcd. (diff)
downloadgentoo-2-c0de863211d190b942ee419266b2ae4f102ef010.tar.gz
gentoo-2-c0de863211d190b942ee419266b2ae4f102ef010.tar.bz2
gentoo-2-c0de863211d190b942ee419266b2ae4f102ef010.zip
Bump to version 0.12.
Diffstat (limited to 'media-plugins/mythgallery')
-rw-r--r--media-plugins/mythgallery/ChangeLog7
-rw-r--r--media-plugins/mythgallery/Manifest4
-rw-r--r--media-plugins/mythgallery/files/digest-mythgallery-0.121
-rw-r--r--media-plugins/mythgallery/mythgallery-0.12.ebuild60
4 files changed, 70 insertions, 2 deletions
diff --git a/media-plugins/mythgallery/ChangeLog b/media-plugins/mythgallery/ChangeLog
index 1553fc324f12..7b7c0e8bcaca 100644
--- a/media-plugins/mythgallery/ChangeLog
+++ b/media-plugins/mythgallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgallery
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.5 2003/09/17 06:24:27 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.6 2003/10/20 03:27:42 max Exp $
+
+*mythgallery-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythgallery-0.12.ebuild:
+ Bump to version 0.12.
16 Sep 2003; Max Kalika <max@gentoo.org> mythgallery-0.10.ebuild,
mythgallery-0.11.ebuild:
diff --git a/media-plugins/mythgallery/Manifest b/media-plugins/mythgallery/Manifest
index 8ae2d2bff428..698860ecf301 100644
--- a/media-plugins/mythgallery/Manifest
+++ b/media-plugins/mythgallery/Manifest
@@ -1,6 +1,8 @@
MD5 e7617040c11110efb67d6c159c366001 mythgallery-0.11.ebuild 1691
MD5 77f7c1c71ed6f4bcb728fa0e83c08003 mythgallery-0.10.ebuild 1724
-MD5 797aaafd06f28788c81829c776466b3e ChangeLog 1619
+MD5 bd33147ee3f047cded5326edc5c390e5 mythgallery-0.12.ebuild 1677
+MD5 c7b8ba048a5dd1a81deaee5405cccce6 ChangeLog 1745
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 08ad7857fea9bfc28178d4e14aa3ae10 files/digest-mythgallery-0.10 67
MD5 f367099e5641367ed71e682eed2243e5 files/digest-mythgallery-0.11 67
+MD5 2ead189a9b4ae726aa0565a7f4d7a78f files/digest-mythgallery-0.12 68
diff --git a/media-plugins/mythgallery/files/digest-mythgallery-0.12 b/media-plugins/mythgallery/files/digest-mythgallery-0.12
new file mode 100644
index 000000000000..6f980e8baa29
--- /dev/null
+++ b/media-plugins/mythgallery/files/digest-mythgallery-0.12
@@ -0,0 +1 @@
+MD5 e9b9ca211bf928d4cb6b1ff1f5e00406 mythgallery-0.12.tar.bz2 15495
diff --git a/media-plugins/mythgallery/mythgallery-0.12.ebuild b/media-plugins/mythgallery/mythgallery-0.12.ebuild
new file mode 100644
index 000000000000..2f0850402796
--- /dev/null
+++ b/media-plugins/mythgallery/mythgallery-0.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/mythgallery-0.12.ebuild,v 1.1 2003/10/20 03:27:42 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Gallery and slideshow module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins database/*.sql
+
+ dodoc COPYING README UPGRADING
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGallery,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/gallery.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/gallery.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}