summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-01-18 12:20:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-01-18 12:20:50 +0000
commite707f95762635788e25d0d21b103f30b56d36155 (patch)
tree263c535c32c9d93038d6f2e2cd0a934c1c73a115 /media-libs
parentAdd arm64 love. (diff)
downloadgentoo-2-e707f95762635788e25d0d21b103f30b56d36155.tar.gz
gentoo-2-e707f95762635788e25d0d21b103f30b56d36155.tar.bz2
gentoo-2-e707f95762635788e25d0d21b103f30b56d36155.zip
version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/suil/ChangeLog9
-rw-r--r--media-libs/suil/suil-0.8.0.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/media-libs/suil/ChangeLog b/media-libs/suil/ChangeLog
index 5593401977a6..323ed14ae6a9 100644
--- a/media-libs/suil/ChangeLog
+++ b/media-libs/suil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/suil
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/suil/ChangeLog,v 1.13 2013/03/02 21:49:15 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/suil/ChangeLog,v 1.14 2014/01/18 12:20:50 aballier Exp $
+
+*suil-0.8.0 (18 Jan 2014)
+
+ 18 Jan 2014; Alexis Ballier <aballier@gentoo.org> +suil-0.8.0.ebuild:
+ version bump
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> suil-0.4.4.ebuild,
suil-0.6.0.ebuild, suil-0.6.10.ebuild, suil-0.6.12.ebuild, suil-0.6.2.ebuild,
diff --git a/media-libs/suil/suil-0.8.0.ebuild b/media-libs/suil/suil-0.8.0.ebuild
new file mode 100644
index 000000000000..0bf71e71fc0d
--- /dev/null
+++ b/media-libs/suil/suil-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/suil/suil-0.8.0.ebuild,v 1.1 2014/01/18 12:20:50 aballier Exp $
+
+EAPI=4
+
+inherit base waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk qt4"
+
+RDEPEND="media-libs/lv2
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? ( dev-qt/qtgui:4 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ # otherwise automagic
+ use gtk || sed -i -e 's/gtk+-2.0/DiSaBlEd/' wscript
+ use qt4 || sed -i -e 's/QtGui/DiSaBlEd/' wscript
+ waf-utils_src_configure \
+ "--mandir=${EPREFIX}/usr/share/man" \
+ "--docdir=${EPREFIX}/usr/share/doc/${PF}" \
+ $(use doc && echo "--docs")
+}