summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2012-04-11 23:09:39 +0000
committerSebastian Pipping <sping@gentoo.org>2012-04-11 23:09:39 +0000
commite4c236029e0a246250bf6e1a583307e077ee9211 (patch)
tree5c391f10f6020e046f91d195cb690635e635a53d /media-libs
parentMask >=media-libs/babl-0.1.8[introspection] (diff)
downloadgentoo-2-e4c236029e0a246250bf6e1a583307e077ee9211.tar.gz
gentoo-2-e4c236029e0a246250bf6e1a583307e077ee9211.tar.bz2
gentoo-2-e4c236029e0a246250bf6e1a583307e077ee9211.zip
media-libs/babl: 0.1.10
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/babl/ChangeLog7
-rw-r--r--media-libs/babl/babl-0.1.10.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/media-libs/babl/ChangeLog b/media-libs/babl/ChangeLog
index dee398392c68..a080dbc04125 100644
--- a/media-libs/babl/ChangeLog
+++ b/media-libs/babl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/babl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.36 2012/02/13 20:23:40 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.37 2012/04/11 23:09:39 sping Exp $
+
+*babl-0.1.10 (11 Apr 2012)
+
+ 11 Apr 2012; Sebastian Pipping <sping@gentoo.org> +babl-0.1.10.ebuild:
+ Bump to 0.1.10
13 Feb 2012; Fabian Groffen <grobian@gentoo.org> babl-0.1.6.ebuild:
Marked ~x64-macos
diff --git a/media-libs/babl/babl-0.1.10.ebuild b/media-libs/babl/babl-0.1.10.ebuild
new file mode 100644
index 000000000000..e7727c8632b1
--- /dev/null
+++ b/media-libs/babl/babl-0.1.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.10.ebuild,v 1.1 2012/04/11 23:09:39 sping Exp $
+
+EAPI=3
+VALASLOT=0.14
+
+inherit autotools eutils
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+SRC_URI="ftp://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="altivec +introspection sse mmx vala"
+
+RDEPEND="introspection? ( >=dev-libs/gobject-introspection-0.10 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ vala? ( dev-lang/vala:${VALASLOT}[vapigen] )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.1.6-introspection.patch
+ eautoreconf
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ VAPIGEN="$(type -p vapigen-${VALASLOT})" \
+ econf \
+ --disable-static \
+ --disable-maintainer-mode \
+ $(use_enable altivec) \
+ $(use_enable introspection) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_with vala)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ find "${ED}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog README NEWS || die "dodoc failed"
+}