summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-30 09:44:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-30 09:44:35 +0000
commitc5c277835518c74553db126e25190e30e4affe89 (patch)
tree5e762305d459fe67175267369d53c32e383548b6 /media-libs
parentcleanup old versions (diff)
downloadgentoo-2-c5c277835518c74553db126e25190e30e4affe89.tar.gz
gentoo-2-c5c277835518c74553db126e25190e30e4affe89.tar.bz2
gentoo-2-c5c277835518c74553db126e25190e30e4affe89.zip
On x86 we need to force a few more flags. Added a workaround section for it and a warning about the unusable debug information caused by -fomit-frame-pointer.
(Portage version: 2.0.51.22)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog8
-rw-r--r--media-libs/xine-lib/xine-lib-1.1.0-r2.ebuild14
2 files changed, 19 insertions, 3 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index ab710c4aea05..82477e2f66e9 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.247 2005/08/29 10:13:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.248 2005/08/30 09:44:35 flameeyes Exp $
+
+ 30 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ xine-lib-1.1.0-r2.ebuild:
+ On x86 we need to force a few more flags. Added a workaround section for it
+ and a warning about the unusable debug information caused by
+ -fomit-frame-pointer.
29 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
-xine-lib-1_rc6-r2.ebuild, xine-lib-1.1.0-r2.ebuild:
diff --git a/media-libs/xine-lib/xine-lib-1.1.0-r2.ebuild b/media-libs/xine-lib/xine-lib-1.1.0-r2.ebuild
index 44b4a4eb5b3e..a9a9843fb7d4 100644
--- a/media-libs/xine-lib/xine-lib-1.1.0-r2.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.1.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.0-r2.ebuild,v 1.2 2005/08/29 10:13:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.0-r2.ebuild,v 1.3 2005/08/30 09:44:35 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs libtool autotools
@@ -85,7 +85,17 @@ src_compile() {
#prevent quicktime crashing
append-flags -frename-registers -ffunction-sections
- [[ $(tc-arch) == "x86" ]] && has_pic && append-flags -UHAVE_MMX
+ # Specific workarounds for too-few-registers arch...
+ if [[ $(tc-arch) == "x86" ]]; then
+ has_pic && append-flags -UHAVE_MMX
+
+ append-flags -mno-sse -fomit-frame-pointer
+ ewarn ""
+ ewarn "Debug information will be almost useless as the frame pointer is omitted."
+ ewarn "This makes debugging harder, so crashes that has no fixed behavior are"
+ ewarn "difficult to fix. Please have that in mind."
+ ewarn ""
+ fi
local myconf