summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-03-17 23:45:24 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-03-17 23:45:24 +0000
commit5b18c2ea775f1fbffcd1ac44205e3e04223f665d (patch)
tree79d52d189f86c4e0abe89410841b8e62f21bfb81 /media-libs
parentFix patch to work with both freetype-2.4.11 and >=2.5.1 (bug #504850, thanks ... (diff)
downloadgentoo-2-5b18c2ea775f1fbffcd1ac44205e3e04223f665d.tar.gz
gentoo-2-5b18c2ea775f1fbffcd1ac44205e3e04223f665d.tar.bz2
gentoo-2-5b18c2ea775f1fbffcd1ac44205e3e04223f665d.zip
Version bump to 2.6.8; fixes bug #504780, reported by Frank Krömmelbein.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/avidemux-core/ChangeLog7
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.8.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/media-libs/avidemux-core/ChangeLog b/media-libs/avidemux-core/ChangeLog
index c7d4423933d4..48d9bb0bbee8 100644
--- a/media-libs/avidemux-core/ChangeLog
+++ b/media-libs/avidemux-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/avidemux-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/ChangeLog,v 1.20 2014/03/10 14:13:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/ChangeLog,v 1.21 2014/03/17 23:45:24 tomwij Exp $
+
+*avidemux-core-2.6.8 (17 Mar 2014)
+
+ 17 Mar 2014; Tom Wijsman <TomWij@gentoo.org> +avidemux-core-2.6.8.ebuild:
+ Version bump to 2.6.8; fixes bug #504780, reported by Frank Krömmelbein.
10 Mar 2014; Samuli Suominen <ssuominen@gentoo.org>
avidemux-core-2.6.2-r1.ebuild, avidemux-core-2.6.3.ebuild,
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.8.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.8.ebuild
new file mode 100644
index 000000000000..5b156042c9e5
--- /dev/null
+++ b/media-libs/avidemux-core/avidemux-core-2.6.8.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/avidemux-core/avidemux-core-2.6.8.ebuild,v 1.1 2014/03/17 23:45:24 tomwij Exp $
+
+EAPI="5"
+
+inherit cmake-utils eutils flag-o-matic
+
+SLOT="2.6"
+
+DESCRIPTION="Core libraries for a video editor designed for simple cutting, filtering and encoding tasks."
+HOMEPAGE="http://fixounet.free.fr/avidemux"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+IUSE="debug nls sdl system-ffmpeg vaapi vdpau video_cards_fglrx xv"
+KEYWORDS="~amd64 ~x86"
+
+MY_PN="${PN/-core/}"
+if [[ ${PV} == *9999* ]] ; then
+ KEYWORDS=""
+ EGIT_REPO_URI="git://gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git https://git.gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git"
+
+ inherit git-2
+else
+ MY_P="${MY_PN}_${PV}"
+ SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
+DEPEND="
+ !<media-video/avidemux-${PV}:${SLOT}
+ dev-db/sqlite:3
+ sdl? ( media-libs/libsdl:0 )
+ system-ffmpeg? ( >=virtual/ffmpeg-9:0[mp3,theora] )
+ xv? ( x11-libs/libXv:0 )
+ vaapi? ( x11-libs/libva:0 )
+ vdpau? ( x11-libs/libvdpau:0 )
+ video_cards_fglrx? ( x11-libs/xvba-video:0 )
+"
+RDEPEND="
+ $DEPEND
+ nls? ( virtual/libintl:0 )
+"
+DEPEND="
+ $DEPEND
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ !system-ffmpeg? ( dev-lang/yasm[nls=] )
+"
+
+S="${WORKDIR}/${MY_P}"
+BUILD_DIR="${S}/buildCore"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ mkdir "${BUILD_DIR}" || die "Can't create build folder."
+
+ cmake-utils_src_prepare
+
+ if use system-ffmpeg ; then
+ # Preparations to support the system ffmpeg. Currently fails because it depends on files the system ffmpeg doesn't install.
+ local error="Failed to remove ffmpeg."
+
+ rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
+ sed -i -e 's/include(admFFmpegUtil)//g' avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -i -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "${error}"
+ else
+ # Avoid existing avidemux installations from making the build process fail, bug #461496.
+ sed -i -e "s:getFfmpegLibNames(\"\${sourceDir}\"):getFfmpegLibNames(\"${S}/buildCore/ffmpeg/source/\"):g" cmake/admFFmpegUtil.cmake \
+ || die "Failed to avoid existing avidemux installation from making the build fail."
+ fi
+
+ # Add lax vector typing for PowerPC.
+ if use ppc || use ppc64 ; then
+ append-cflags -flax-vector-conversions
+ fi
+
+ # See bug 432322.
+ use x86 && replace-flags -O0 -O1
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DAVIDEMUX_SOURCE_DIR='${S}'
+ $(cmake-utils_use nls GETTEXT)
+ $(cmake-utils_use sdl SDL)
+ $(cmake-utils_use vaapi LIBVA)
+ $(cmake-utils_use vdpau VDPAU)
+ $(cmake-utils_use video_cards_fglrx XVBA)
+ $(cmake-utils_use xv XVIDEO)
+ "
+
+ if use debug ; then
+ mycmakeargs+=" -DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug -DADM_DEBUG=1"
+ fi
+
+ CMAKE_USE_DIR="${S}"/avidemux_core cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile -j1
+}
+
+src_install() {
+ cmake-utils_src_install -j1
+}