summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-09-06 20:33:19 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-09-06 20:33:19 +0000
commit4554fb8a629357447fd621f0df0371d4a60918ac (patch)
treeee2e05c6c911fb00ce87ffb81ce8da484a9651f1 /media-libs/dumb
parentVersion bump (diff)
downloadgentoo-2-4554fb8a629357447fd621f0df0371d4a60918ac.tar.gz
gentoo-2-4554fb8a629357447fd621f0df0371d4a60918ac.tar.bz2
gentoo-2-4554fb8a629357447fd621f0df0371d4a60918ac.zip
converted to support multilib-build; commit OKd by Joker
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'media-libs/dumb')
-rw-r--r--media-libs/dumb/ChangeLog9
-rw-r--r--media-libs/dumb/dumb-0.9.3-r2.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/media-libs/dumb/ChangeLog b/media-libs/dumb/ChangeLog
index b7214a6211a8..66699db4d767 100644
--- a/media-libs/dumb/ChangeLog
+++ b/media-libs/dumb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/dumb
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/ChangeLog,v 1.39 2011/08/09 12:28:53 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/ChangeLog,v 1.40 2013/09/06 20:33:19 axs Exp $
+
+*dumb-0.9.3-r2 (06 Sep 2013)
+
+ 06 Sep 2013; Ian Stakenvicius <axs@gentoo.org> +dumb-0.9.3-r2.ebuild:
+ converted to support multilib-build; commit OKd by Joker
09 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> dumb-0.9.3-r1.ebuild:
ppc64 stable wrt #375491
diff --git a/media-libs/dumb/dumb-0.9.3-r2.ebuild b/media-libs/dumb/dumb-0.9.3-r2.ebuild
new file mode 100644
index 000000000000..df27998e5b64
--- /dev/null
+++ b/media-libs/dumb/dumb-0.9.3-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/dumb-0.9.3-r2.ebuild,v 1.1 2013/09/06 20:33:19 axs Exp $
+
+EAPI=5
+inherit eutils multilib-build multilib-minimal
+
+DESCRIPTION="IT/XM/S3M/MOD player library with click removal and IT filters"
+HOMEPAGE="http://dumb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dumb/${P}.tar.gz"
+
+LICENSE="DUMB-0.9.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ cat << EOF > make/config.txt
+include make/unix.inc
+ALL_TARGETS := core core-examples core-headers
+PREFIX := /usr
+EOF
+
+ epatch "${FILESDIR}"/${P}-PIC-as-needed.patch
+ epatch "${FILESDIR}"/${P}_CVE-2006-3668.patch
+ sed -i '/= -s/d' Makefile || die "sed failed"
+ cp -f Makefile Makefile.rdy
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake OFLAGS="${CFLAGS}" all
+}
+
+multilib_src_install() {
+ dolib.so lib/unix/libdumb.so
+ use debug && dolib.so lib/unix/libdumbd.so
+
+ doheader include/dumb.h
+
+ dobin examples/{dumbout,dumb2wav}
+ dodoc readme.txt release.txt docs/*
+}
+
+pkg_postinst() {
+ elog "DUMB's core has been installed. This will enable you to convert module"
+ elog "files to PCM data (ready for sending to /dev/dsp, writing to a .wav"
+ elog "file, piping through oggenc, etc.)."
+ elog
+ elog "If you are using Allegro, you will also want to 'emerge aldumb'. This"
+ elog "provides you with a convenient API for playing module files through"
+ elog "Allegro's sound system, and also enables DUMB to integrate with"
+ elog "Allegro's datafile system so you can add modules to datafiles."
+ elog
+ elog "As a developer, when you distribute your game and write your docs, be"
+ elog "aware that 'dumb' and 'aldumb' actually come from the same download."
+ elog "People who don't use Gentoo will only have to download and install one"
+ elog "package. See readme.txt in /usr/share/doc/${PF} for details on"
+ elog "how DUMB would be compiled manually."
+}