summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-17 07:24:00 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-17 07:24:00 +0000
commit1906fd9794de7ce9d89129eb9f38c3b061955e7d (patch)
tree3bb2947cb780808642e0f06c14d3582042761e34 /media-libs/coin
parentVersion bump, and uses new DLJ distributed files (diff)
downloadgentoo-2-1906fd9794de7ce9d89129eb9f38c3b061955e7d.tar.gz
gentoo-2-1906fd9794de7ce9d89129eb9f38c3b061955e7d.tar.bz2
gentoo-2-1906fd9794de7ce9d89129eb9f38c3b061955e7d.zip
version bump thanks to Tristan Heaven <tristanheaven@gmail.com>, Tamer Fahmy <tamer@tammura.at>, Piotr Jaroszynski <peper@aster.pl> and Christian 'Opfer' Faulhammer <gentoo@faulhammer.org> in bug 132831
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'media-libs/coin')
-rw-r--r--media-libs/coin/ChangeLog9
-rw-r--r--media-libs/coin/coin-2.4.5.ebuild72
-rw-r--r--media-libs/coin/files/digest-coin-2.4.53
3 files changed, 83 insertions, 1 deletions
diff --git a/media-libs/coin/ChangeLog b/media-libs/coin/ChangeLog
index 9035b8cfe736..9f634ffa0b96 100644
--- a/media-libs/coin/ChangeLog
+++ b/media-libs/coin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/coin
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/coin/ChangeLog,v 1.15 2006/02/17 13:44:26 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/coin/ChangeLog,v 1.16 2006/08/17 07:24:00 genstef Exp $
+
+*coin-2.4.5 (17 Aug 2006)
+
+ 17 Aug 2006; Stefan Schweizer <genstef@gentoo.org> +coin-2.4.5.ebuild:
+ version bump thanks to Tristan Heaven <tristanheaven@gmail.com>, Tamer Fahmy
+ <tamer@tammura.at>, Piotr Jaroszynski <peper@aster.pl> and Christian 'Opfer'
+ Faulhammer <gentoo@faulhammer.org> in bug 132831
17 Feb 2006; Gustavo Zacarias <gustavoz@gentoo.org> coin-2.1.0.ebuild,
coin-2.4.3.ebuild:
diff --git a/media-libs/coin/coin-2.4.5.ebuild b/media-libs/coin/coin-2.4.5.ebuild
new file mode 100644
index 000000000000..31777ce6279a
--- /dev/null
+++ b/media-libs/coin/coin-2.4.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/coin/coin-2.4.5.ebuild,v 1.1 2006/08/17 07:24:00 genstef Exp $
+
+inherit eutils
+
+MY_P=${P/c/C}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Coin3D is a high-level 3D graphics toolkit, fully compatible with SGI Open Inventor 2.1."
+HOMEPAGE="http://www.coin3d.org/"
+SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 PEL )"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="bzip2 debug doc fontconfig openal opengl X zlib" # java javascript
+
+RDEPEND="media-libs/freetype
+ bzip2? ( app-arch/bzip2 )
+ fontconfig? ( media-libs/fontconfig )
+ openal? ( media-libs/openal )
+ opengl? ( virtual/opengl virtual/glu )
+ X? ( || ( ( x11-libs/libXt x11-libs/libXext ) virtual/x11 ) )
+ zlib? ( sys-libs/zlib )"
+ # java? ( virtual/jdk )
+ # javascript? ( dev-lang/spidermonkey )
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_compile() {
+ # "waiting" for someone needing mesa, instead opengl
+ # simage currently not in the repository
+ # java and javascript support fails for differnt reasons
+ # otherwise hopefully sensible defaults and enough use flags
+ local myconf="--enable-optimization \
+ --enable-3ds-import \
+ --enable-vrml97 \
+ --enable-man \
+ --disable-html-help \
+ --without-mesa \
+ --without-simage \
+ --with-doxygen \
+ --with-freetype \
+ $(use_enable debug) \
+ $(use_enable debug symbols) \
+ $(use_enable doc html) \
+ $(use_with bzip2) \
+ $(use_with fontconfig) \
+ $(use_with openal) \
+ $(use_with opengl) \
+ $(use_with opengl glu) \
+ $(use_with X x) \
+ $(use_with zlib ) \
+ --disable-java-wrapper \
+ --disable-javascript-api \
+ --without-spidermokey"
+ # $(use_enable java java-wrapper) \
+ # $(use_enable javascript javascript-api) \
+ # $(use_with javascript spidermonkey) \
+
+ econf ${myconf} htmldir=${ROOT}usr/share/doc/${PF}/html || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ dodoc AUTHORS NEWS README* RELNOTES THANKS
+
+ # Waiting for a maintainer to fix, see #117756.
+ rm -f ${D}/usr/share/man/man3/_var_tmp* ${D}/usr/sharedoc/coin-2.4.4/html/dir__*
+}
diff --git a/media-libs/coin/files/digest-coin-2.4.5 b/media-libs/coin/files/digest-coin-2.4.5
new file mode 100644
index 000000000000..4229fd9d6b10
--- /dev/null
+++ b/media-libs/coin/files/digest-coin-2.4.5
@@ -0,0 +1,3 @@
+MD5 99b83c5189c3755fd5f08fcad0994a7b Coin-2.4.5.tar.gz 4721898
+RMD160 acf04dcfcb66af1cd98249b63bca2ff40f7b3c1b Coin-2.4.5.tar.gz 4721898
+SHA256 fc8d7c03b21cd9f12f396d36af35a4bc88aa412b84e671c495a8e3f46fefd4f8 Coin-2.4.5.tar.gz 4721898