summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-04-20 11:48:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-04-20 11:48:13 +0000
commit4ed9c0ad9fc78de51d92391dbbd7944b185f007a (patch)
tree92eb05d43ef0d440ff9b91e680c8aa9ac6d7882f /kde-misc/kanyremote
parentInitial commit of anyremote program. Fixes bug #209686 (diff)
downloadgentoo-2-4ed9c0ad9fc78de51d92391dbbd7944b185f007a.tar.gz
gentoo-2-4ed9c0ad9fc78de51d92391dbbd7944b185f007a.tar.bz2
gentoo-2-4ed9c0ad9fc78de51d92391dbbd7944b185f007a.zip
Initial commit of kanyremote program. Fixes bug #209689
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/kanyremote')
-rw-r--r--kde-misc/kanyremote/ChangeLog10
-rw-r--r--kde-misc/kanyremote/kanyremote-5.8.2.ebuild27
-rw-r--r--kde-misc/kanyremote/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
new file mode 100644
index 000000000000..5480e348f1d0
--- /dev/null
+++ b/kde-misc/kanyremote/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for kde-misc/kanyremote
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.1 2009/04/20 11:48:13 hwoarang Exp $
+
+*kanyremote-5.8.2 (21 Apr 2009)
+
+ 21 Apr 2009; Markos Chandras <hwoarang@gentoo.org> +metadata.xml,
+ +kanyremote-5.8.2.ebuild:
+ Initial commit of kanyremote program. Fixes bug #209689
+
diff --git a/kde-misc/kanyremote/kanyremote-5.8.2.ebuild b/kde-misc/kanyremote/kanyremote-5.8.2.ebuild
new file mode 100644
index 000000000000..ae1d931fb2ee
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-5.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.8.2.ebuild,v 1.1 2009/04/20 11:48:13 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=">=net-misc/anyremote-4.4[bluetooth=]
+ >=dev-python/PyQt-3.17
+ >=dev-python/pykde-3.16"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ make_desktop_entry ${PN} ${PN} ${PN}.png "Network;RemoteAccess"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
diff --git a/kde-misc/kanyremote/metadata.xml b/kde-misc/kanyremote/metadata.xml
new file mode 100644
index 000000000000..3d43c690d0f6
--- /dev/null
+++ b/kde-misc/kanyremote/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd></herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+