summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:29:05 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:29:05 +0000
commit42577a818ab916d2ae4e4896afa1ea18dc8825d8 (patch)
tree3652f16981d25791fe18db21d089d3cb63a52f96 /kde-base/ksplash
parentamd64/x86 stable, bug #215978 (diff)
downloadgentoo-2-42577a818ab916d2ae4e4896afa1ea18dc8825d8.tar.gz
gentoo-2-42577a818ab916d2ae4e4896afa1ea18dc8825d8.tar.bz2
gentoo-2-42577a818ab916d2ae4e4896afa1ea18dc8825d8.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog9
-rw-r--r--kde-base/ksplash/ksplash-4.0.3.ebuild29
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 22062586af48..4c0729e05ca3 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.6 2008/03/20 17:56:23 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.7 2008/04/03 21:29:05 philantrop Exp $
+
+*ksplash-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +ksplash-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org> -ksplash-4.0.1.ebuild:
Old.
diff --git a/kde-base/ksplash/ksplash-4.0.3.ebuild b/kde-base/ksplash/ksplash-4.0.3.ebuild
new file mode 100644
index 000000000000..8e5564215c44
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.0.3.ebuild,v 1.1 2008/04/03 21:29:05 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+RDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_has 3dnow X86_3DNOW)
+ $(cmake-utils_has altivec PPC_ALTIVEC)
+ $(cmake-utils_has mmx X86_MMX)
+ $(cmake-utils_has sse X86_SSE)
+ $(cmake-utils_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+ kde4-meta_src_compile
+}