summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-02-11 19:04:30 +0000
committerDan Armak <danarmak@gentoo.org>2005-02-11 19:04:30 +0000
commitf0bd73b7325eb66fe0a1d03bcb650e6eea81caf8 (patch)
treecdaa0fee3556310a0c3f10e4e16f614ef7cf1460 /kde-base/kdeaddons
parentDisabled src_test() as a fix for bug #81541. (diff)
downloadgentoo-2-f0bd73b7325eb66fe0a1d03bcb650e6eea81caf8.tar.gz
gentoo-2-f0bd73b7325eb66fe0a1d03bcb650e6eea81caf8.tar.bz2
gentoo-2-f0bd73b7325eb66fe0a1d03bcb650e6eea81caf8.zip
Added the same patch noatun-oblique and noatun-plugins use. This fixes the berkeley db test, which enables the oblique plugin.
Note that the berkdb USE flag actually works here wrt what is built. (Portage version: 2.0.51-r15)
Diffstat (limited to 'kde-base/kdeaddons')
-rw-r--r--kde-base/kdeaddons/ChangeLog9
-rw-r--r--kde-base/kdeaddons/files/noatun-oblique-db-location-3.4.0_beta2.diff24
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.4.0_beta2.ebuild30
3 files changed, 53 insertions, 10 deletions
diff --git a/kde-base/kdeaddons/ChangeLog b/kde-base/kdeaddons/ChangeLog
index 85ee982d8fce..c7a3112d9905 100644
--- a/kde-base/kdeaddons/ChangeLog
+++ b/kde-base/kdeaddons/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdeaddons
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/ChangeLog,v 1.118 2005/02/09 16:15:27 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/ChangeLog,v 1.119 2005/02/11 19:04:30 danarmak Exp $
+
+ 11 Feb 2005; Dan Armak <danarmak@gentoo.org>
+ +files/noatun-oblique-db-location-3.4.0_beta2.diff,
+ kdeaddons-3.4.0_beta2.ebuild:
+ Added the same patch noatun-oblique and noatun-plugins use. This fixes the
+ berkeley db test, which enables the oblique plugin. Note that the berkdb USE
+ flag actually works here wrt what is built.
*kdeaddons-3.4.0_beta2 (09 Feb 2005)
diff --git a/kde-base/kdeaddons/files/noatun-oblique-db-location-3.4.0_beta2.diff b/kde-base/kdeaddons/files/noatun-oblique-db-location-3.4.0_beta2.diff
new file mode 100644
index 000000000000..bf3f954f57af
--- /dev/null
+++ b/kde-base/kdeaddons/files/noatun-oblique-db-location-3.4.0_beta2.diff
@@ -0,0 +1,24 @@
+--- noatun-plugins/oblique/configure.in.in.orig 2004-10-09 11:41:38.000000000 +0200
++++ noatun-plugins/oblique/configure.in.in 2005-02-11 20:29:38.760533256 +0200
+@@ -1,19 +1,4 @@
+-
+-AC_MSG_CHECKING(for Berkeley DB++)
+-berkeley_db=no
+-AC_LANG_PUSH(C++)
+-AC_TRY_COMPILE([
+- #include <db_cxx.h>
+- ],[
+- ],[
+- berkeley_db=yes
+- ])
+-AC_MSG_RESULT($berkeley_db)
+-AC_DEFINE(BERKELEY_DB,1,[Define if you have Berkeley DB++ installed])
+-BERKELEY_DB_LIBS="-ldb_cxx"
++berkeley_db=yes
++BERKELEY_DB_LIBS="-ldb_cxx-4.2"
+ AC_SUBST(BERKELEY_DB_LIBS)
+-AC_LANG_POP(C++)
+-
+ AM_CONDITIONAL(include_BERKELEY_DB, test "$berkeley_db" = yes)
+-
+-
diff --git a/kde-base/kdeaddons/kdeaddons-3.4.0_beta2.ebuild b/kde-base/kdeaddons/kdeaddons-3.4.0_beta2.ebuild
index 5c80c608b1d8..f91492cfc651 100644
--- a/kde-base/kdeaddons/kdeaddons-3.4.0_beta2.ebuild
+++ b/kde-base/kdeaddons/kdeaddons-3.4.0_beta2.ebuild
@@ -1,28 +1,40 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.4.0_beta2.ebuild,v 1.1 2005/02/09 16:15:27 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.4.0_beta2.ebuild,v 1.2 2005/02/11 19:04:30 danarmak Exp $
inherit kde-dist eutils
DESCRIPTION="KDE addon modules: plugins for konqueror, noatun etc"
KEYWORDS="~x86 ~amd64"
-IUSE="arts sdl xmms"
+IUSE="arts sdl xmms berkdb"
DEPEND="~kde-base/kdepim-${PV}
~kde-base/kdemultimedia-${PV}
~kde-base/kdegames-${PV}
arts? ( ~kde-base/arts-${PV} )
sdl? ( >=media-libs/libsdl-1.2 )
- xmms? ( media-sound/xmms )"
-
+ xmms? ( media-sound/xmms )
+ berkdb? ( =sys-lib/db-4.2* )"
+
+# Make vimpart use /usr/bin/kvim -- fixes bug 33257.
+# This should continue to apply to upcoming versions since it's
+# Gentoo-specific and won't go upstream.
+PATCHES="${FILESDIR}/${PN}-3.2.0-kvim.diff"
+
+# This patch makes the configure test in noatun-oblique find db_cxx.h,
+# but it also makes db support non-optional. should be fixed, ideally
+if useq berkdb; then
+ PATCHES="$FILESDIR/noatun-oblique-db-location-$PV.diff"
+ myconf="--with-extra-includes=/usr/include/db4.2"
+fi
+
src_unpack() {
kde_src_unpack
-
- # Make vimpart use /usr/bin/kvim -- fixes bug 33257.
- # This should continue to apply to upcoming versions since it's
- # Gentoo-specific and won't go upstream.
- epatch ${FILESDIR}/${PN}-3.2.0-kvim.diff
+
+ if useq berkdb; then
+ rm $S/configure
+ fi
}
src_compile() {